chrisjvanover
IS-IT--Management
I have a pix, vpn client, all is fine, trying to add rules to allow an iphone to access the internal exchange server behind pix. here is the running config, it has been so long since ive done this ive hit a roadblock. All can be accessed fine on exchange and remote web workplace from inside.
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password e9wppGI.2EJ2mo3O encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname intrustpix
domain-name intrust.org
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.125 server
access-list intrust_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.0
access-list outside_cryptomap_dyn_40 permit ip any 172.16.1.0 255.255.255.0
access-list 100 permit tcp any host 216.158.19.7 eq www
access-list inbound permit tcp any host 216.158.19.7 eq smtp
access-list inbound permit tcp any host 216.158.19.7 eq www
access-list inbound permit tcp any host 216.158.19.7 eq https
access-list inbound permit tcp any host server eq www
access-list inbound permit tcp any host server eq https
access-list inside-out permit tcp host server any eq smtp
access-list inside-out permit udp any any eq isakmp
access-list inside-out permit ip any any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 216.158.19.7 255.255.255.128
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool intrustpool 172.16.1.1-172.16.1.254
pdm location server 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 216.158.19.1 1
route inside 192.168.1.1 255.255.255.255 server 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
ntp server 146.186.216.60 source outside
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup intrust address-pool intrustpool
vpngroup intrust dns-server server 204.183.82.2
vpngroup intrust default-domain intrust.org
vpngroup intrust split-tunnel intrust_splitTunnelAcl
vpngroup intrust idle-time 1800
vpngroup intrust password ********
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.100 inside
dhcpd dns server 204.183.82.2
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain intrust.org
dhcpd enable inside
username intrust password DUYtuyAwKtvNtReO encrypted privilege 15
username chrisv password Yv5wzOB.qJKSVt9x encrypted privilege 15
terminal width 80
Cryptochecksum:c4329b821e443045ccf7ae66085e5849
: end
[OK]
Building configuration...
: Saved
:
PIX Version 6.3(5)
interface ethernet0 100full
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password e9wppGI.2EJ2mo3O encrypted
passwd 2KFQnbNIdI.2KYOU encrypted
hostname intrustpix
domain-name intrust.org
clock timezone EST -5
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name 192.168.1.125 server
access-list intrust_splitTunnelAcl permit ip 192.168.1.0 255.255.255.0 any
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 172.16.1.0 255.255.255.0
access-list outside_cryptomap_dyn_40 permit ip any 172.16.1.0 255.255.255.0
access-list 100 permit tcp any host 216.158.19.7 eq www
access-list inbound permit tcp any host 216.158.19.7 eq smtp
access-list inbound permit tcp any host 216.158.19.7 eq www
access-list inbound permit tcp any host 216.158.19.7 eq https
access-list inbound permit tcp any host server eq www
access-list inbound permit tcp any host server eq https
access-list inside-out permit tcp host server any eq smtp
access-list inside-out permit udp any any eq isakmp
access-list inside-out permit ip any any
pager lines 24
mtu outside 1500
mtu inside 1500
ip address outside 216.158.19.7 255.255.255.128
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool intrustpool 172.16.1.1-172.16.1.254
pdm location server 255.255.255.255 inside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
route outside 0.0.0.0 0.0.0.0 216.158.19.1 1
route inside 192.168.1.1 255.255.255.255 server 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
ntp server 146.186.216.60 source outside
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 match address outside_cryptomap_dyn_40
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 86400
vpngroup intrust address-pool intrustpool
vpngroup intrust dns-server server 204.183.82.2
vpngroup intrust default-domain intrust.org
vpngroup intrust split-tunnel intrust_splitTunnelAcl
vpngroup intrust idle-time 1800
vpngroup intrust password ********
telnet timeout 5
ssh timeout 5
console timeout 0
dhcpd address 192.168.1.2-192.168.1.100 inside
dhcpd dns server 204.183.82.2
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd domain intrust.org
dhcpd enable inside
username intrust password DUYtuyAwKtvNtReO encrypted privilege 15
username chrisv password Yv5wzOB.qJKSVt9x encrypted privilege 15
terminal width 80
Cryptochecksum:c4329b821e443045ccf7ae66085e5849
: end
[OK]