Hey guys,
I was just wondering if there is any settings on the cisco router that might be causing ftp connections to time out.
I have client that continues to time out while transferring files and I need to ensure it's not my the 1710 routerI put in place, which seemed to happen about the same time I installed it.
And if there isn't anything that I can do on the router, has anyone else had this issue and know where I can look to solve it.
Here is a copy of my router config...
Cisco1721#sh run
Building configuration...
Current configuration : 4765 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco1721
!
enable secret 5
!
ip subnet-zero
!
!
no ip domain-lookup
!
ip inspect max-incomplete high 1100
ip inspect one-minute high 1100
ip inspect name FastEthernet_0 tcp
ip inspect name FastEthernet_0 udp
ip inspect name FastEthernet_0 cuseeme
ip inspect name FastEthernet_0 ftp
ip inspect name FastEthernet_0 h323
ip inspect name FastEthernet_0 rcmd
ip inspect name FastEthernet_0 realaudio
ip inspect name FastEthernet_0 streamworks
ip inspect name FastEthernet_0 vdolive
ip inspect name FastEthernet_0 sqlnet
ip inspect name FastEthernet_0 tftp
ip inspect name Serial_0 udp
ip inspect name Serial_0 tcp
ip inspect name Serial_0 ftp
ip audit notify log
ip audit po max-events 100
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
!
interface FastEthernet0
description connected to Company
ip address 192.168.0.1 255.255.255.0
ip access-group 100 in
ip nat inside
ip inspect FastEthernet_0 in
speed auto
!
interface Serial0
description connected to Internet
ip address x.x.x.x 255.255.255.252
ip access-group 101 in
ip nat outside
ip inspect Serial_0 in
encapsulation ppp
!
router rip
version 2
passive-interface Serial0
network 192.168.0.0
no auto-summary
!
ip nat pool Cisco1721-natpool-1 x.x.x.x 216.199.185.30 netmask 255.255.25
5.240
ip nat inside source list 1 pool Cisco1721-natpool-1 overload
ip nat inside source static tcp 192.168.0.13 20 x.x.x.x 20 extendable
ip nat inside source static tcp 192.168.0.13 3389 x.x.x.x 3389 extendable
ip nat inside source static tcp 192.168.0.8 80 x.x.x.x 80 extendable
ip nat inside source static udp 192.168.0.8 1604 x.x.x.x 1604 extendable
ip nat inside source static tcp 192.168.0.8 1494 x.x.x.x 1494 extendable
ip nat inside source static tcp 192.168.0.8 3389 x.x.x.x 3389 extendable
ip nat inside source static udp 192.168.0.6 53 x.x.x.x 53 extendable
ip nat inside source static tcp 192.168.0.6 20 x.x.x.x 20 extendable
ip nat inside source static tcp 192.168.0.6 80 x.x.x.x 80 extendable
ip nat inside source static tcp 192.168.0.6 46 x.x.x.x 46 extendable
ip nat inside source static udp 192.168.0.13 53 x.x.x.x 53 extendable
ip nat inside source static tcp 192.168.0.13 80 x.x.x.x 80 extendable
ip nat inside source static tcp 192.168.0.13 25 x.x.x.x 25 extendable
ip nat inside source static tcp 192.168.0.13 110 x.x.x.x 110 extendable
ip nat inside source static udp 192.168.0.5 53 x.x.x.x 53 extendable
ip nat inside source static tcp 192.168.0.5 80 x.x.x.x 80 extendable
ip nat inside source static tcp 192.168.0.5 25 x.x.x.x 25 extendable
ip nat inside source static tcp 192.168.0.5 110 x.x.x.x 110 extendable
ip nat inside source static tcp 192.168.0.13 21 x.x.x.x 21 extendable
ip nat inside source static tcp 192.168.0.6 21 x.x.x.x 21 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
no ip http server
ip pim bidir-enable
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 100 permit ip any any
access-list 101 permit tcp any host x.x.x.x eq www
access-list 101 permit udp any host x.x.x.x eq domain
access-list 101 permit tcp any host x.x.x.x eq www
access-list 101 permit tcp any host x.x.x.x eq smtp
access-list 101 permit tcp any host x.x.x.x eq pop3
access-list 101 permit tcp any host x.x.x.x eq 3389
access-list 101 permit tcp any host x.x.x.x range ftp-data ftp
access-list 101 permit tcp any host x.x.x.x gt 1013 established
access-list 101 permit tcp any host x.x.x.x eq 46
access-list 101 permit udp any host x.x.x.x eq 1604
access-list 101 permit tcp any host x.x.x.x eq 1494
access-list 101 permit tcp any host x.x.x.x eq www
access-list 101 permit tcp any host x.x.x.x eq www
access-list 101 permit udp any host x.x.x.x eq domain
access-list 101 permit tcp any host x.x.x.x range ftp-data ftp
access-list 101 permit tcp any host x.x.x.x gt 1013 established
access-list 101 permit tcp any host x.x.x.x eq 3389
access-list 101 permit tcp any host x.x.x.x eq smtp
access-list 101 permit tcp any host x.x.x.x eq pop3
!
snmp-server location Company
snmp-server contact someone
banner motd ^CUnauthorized Access is prohibited.
If you have no business being here, then leave.
Thank You, Have a wonderful day.^C
!
line con 0
exec-timeout 0 0
password 7
login
line aux 0
line vty 0 4
password 7
login
!
no scheduler allocate
end
I was just wondering if there is any settings on the cisco router that might be causing ftp connections to time out.
I have client that continues to time out while transferring files and I need to ensure it's not my the 1710 routerI put in place, which seemed to happen about the same time I installed it.
And if there isn't anything that I can do on the router, has anyone else had this issue and know where I can look to solve it.
Here is a copy of my router config...
Cisco1721#sh run
Building configuration...
Current configuration : 4765 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco1721
!
enable secret 5
!
ip subnet-zero
!
!
no ip domain-lookup
!
ip inspect max-incomplete high 1100
ip inspect one-minute high 1100
ip inspect name FastEthernet_0 tcp
ip inspect name FastEthernet_0 udp
ip inspect name FastEthernet_0 cuseeme
ip inspect name FastEthernet_0 ftp
ip inspect name FastEthernet_0 h323
ip inspect name FastEthernet_0 rcmd
ip inspect name FastEthernet_0 realaudio
ip inspect name FastEthernet_0 streamworks
ip inspect name FastEthernet_0 vdolive
ip inspect name FastEthernet_0 sqlnet
ip inspect name FastEthernet_0 tftp
ip inspect name Serial_0 udp
ip inspect name Serial_0 tcp
ip inspect name Serial_0 ftp
ip audit notify log
ip audit po max-events 100
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
!
!
interface FastEthernet0
description connected to Company
ip address 192.168.0.1 255.255.255.0
ip access-group 100 in
ip nat inside
ip inspect FastEthernet_0 in
speed auto
!
interface Serial0
description connected to Internet
ip address x.x.x.x 255.255.255.252
ip access-group 101 in
ip nat outside
ip inspect Serial_0 in
encapsulation ppp
!
router rip
version 2
passive-interface Serial0
network 192.168.0.0
no auto-summary
!
ip nat pool Cisco1721-natpool-1 x.x.x.x 216.199.185.30 netmask 255.255.25
5.240
ip nat inside source list 1 pool Cisco1721-natpool-1 overload
ip nat inside source static tcp 192.168.0.13 20 x.x.x.x 20 extendable
ip nat inside source static tcp 192.168.0.13 3389 x.x.x.x 3389 extendable
ip nat inside source static tcp 192.168.0.8 80 x.x.x.x 80 extendable
ip nat inside source static udp 192.168.0.8 1604 x.x.x.x 1604 extendable
ip nat inside source static tcp 192.168.0.8 1494 x.x.x.x 1494 extendable
ip nat inside source static tcp 192.168.0.8 3389 x.x.x.x 3389 extendable
ip nat inside source static udp 192.168.0.6 53 x.x.x.x 53 extendable
ip nat inside source static tcp 192.168.0.6 20 x.x.x.x 20 extendable
ip nat inside source static tcp 192.168.0.6 80 x.x.x.x 80 extendable
ip nat inside source static tcp 192.168.0.6 46 x.x.x.x 46 extendable
ip nat inside source static udp 192.168.0.13 53 x.x.x.x 53 extendable
ip nat inside source static tcp 192.168.0.13 80 x.x.x.x 80 extendable
ip nat inside source static tcp 192.168.0.13 25 x.x.x.x 25 extendable
ip nat inside source static tcp 192.168.0.13 110 x.x.x.x 110 extendable
ip nat inside source static udp 192.168.0.5 53 x.x.x.x 53 extendable
ip nat inside source static tcp 192.168.0.5 80 x.x.x.x 80 extendable
ip nat inside source static tcp 192.168.0.5 25 x.x.x.x 25 extendable
ip nat inside source static tcp 192.168.0.5 110 x.x.x.x 110 extendable
ip nat inside source static tcp 192.168.0.13 21 x.x.x.x 21 extendable
ip nat inside source static tcp 192.168.0.6 21 x.x.x.x 21 extendable
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0
no ip http server
ip pim bidir-enable
!
!
access-list 1 permit 192.168.0.0 0.0.0.255
access-list 100 permit ip any any
access-list 101 permit tcp any host x.x.x.x eq www
access-list 101 permit udp any host x.x.x.x eq domain
access-list 101 permit tcp any host x.x.x.x eq www
access-list 101 permit tcp any host x.x.x.x eq smtp
access-list 101 permit tcp any host x.x.x.x eq pop3
access-list 101 permit tcp any host x.x.x.x eq 3389
access-list 101 permit tcp any host x.x.x.x range ftp-data ftp
access-list 101 permit tcp any host x.x.x.x gt 1013 established
access-list 101 permit tcp any host x.x.x.x eq 46
access-list 101 permit udp any host x.x.x.x eq 1604
access-list 101 permit tcp any host x.x.x.x eq 1494
access-list 101 permit tcp any host x.x.x.x eq www
access-list 101 permit tcp any host x.x.x.x eq www
access-list 101 permit udp any host x.x.x.x eq domain
access-list 101 permit tcp any host x.x.x.x range ftp-data ftp
access-list 101 permit tcp any host x.x.x.x gt 1013 established
access-list 101 permit tcp any host x.x.x.x eq 3389
access-list 101 permit tcp any host x.x.x.x eq smtp
access-list 101 permit tcp any host x.x.x.x eq pop3
!
snmp-server location Company
snmp-server contact someone
banner motd ^CUnauthorized Access is prohibited.
If you have no business being here, then leave.
Thank You, Have a wonderful day.^C
!
line con 0
exec-timeout 0 0
password 7
login
line aux 0
line vty 0 4
password 7
login
!
no scheduler allocate
end