mi24k
MIS
- Jul 27, 2001
- 13
Hello All and thanks for the help in advance! I was wondering how to set up failover routes. I have a couple of offices connected back to HQ via P2P T1's (connection a), they also have connections back to HQ over an additonal T1 but this T1 also carries our voice but is only utilizing 1/2 the bandwidth (connection b). So my question is how do I make it so that if connection a, fails, that traffic will be routed over connection b?
The routers we are using are 2801's....
here are my running conf's
The routers we are using are 2801's....
here are my running conf's
BRANCH OFFICE
!This is the running config of the router: 192.168.1.20
!----------------------------------------------------------------------------
!version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -8
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip flow-cache timeout active 1
ip name-server 192.168.1.1
ip name-server 192.169.254.2
ip name-server 192.168.254.1
!
username admin privilege 15 secret 5
!
!
interface FastEthernet0/0
description $ETH-WAN$
ip address 192.168.1.20 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
!
interface FastEthernet0/1
description $ETH-WAN$
ip address 192.168.20.2 255.255.255.248
ip route-cache flow
duplex auto
speed auto
!
interface Serial0/2/0
ip address 192.168.21.2 255.255.255.252
no ip proxy-arp
ip route-cache flow
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
ip route 0.0.0.0 0.0.0.0 Serial0/2/0 2
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
ip flow-export source FastEthernet0/0
ip flow-export version 5
ip flow-export destination 192.168.1.1 9996
!
ip http server
!
ip access-list standard Internal_IF
remark SDM_ACL Category=2
permit 192.168.1.0 0.0.0.255
!
snmp-server ifindex persist
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password
login
transport input telnet
transport output none
!
end
BRANCH OFFICE
!This is the running config of the router: 192.168.2.20
!----------------------------------------------------------------------------
!version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cisco-Roseburg
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -8
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip bootp server
ip domain name mvengineering.com
ip name-server 192.168.254.2
ip name-server 192.168.254.1
!
username $$$$$ privilege 15 secret 5
username $$$$$ privilege 15 secret 5
!
!
!
interface FastEthernet0/0
description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$$ETH-LAN$
ip address 192.168.2.20 255.255.255.0
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
description $ETH-WAN$
ip address 192.168.20.3 255.255.255.248
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface Serial0/2/0
ip address 192.168.22.2 255.255.255.248
no ip proxy-arp
ip route-cache flow
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
ip route 0.0.0.0 0.0.0.0 Serial0/2/0 2
!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
line vty 5 15
privilege level 15
login local
transport input telnet
!
end
-------------------------------------
HQ
!This is the running config of the router: 192.168.254.20
!----------------------------------------------------------------------------
!version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname mod-cisco-1
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -8
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
ip cef
!
!
ip tcp synwait-time 10
no ip dhcp use vrf connected
!
!
no ip bootp server
ip domain name mvengineering.com
ip name-server 192.168.254.1
ip name-server 192.168.254.2
ip name-server 192.168.1.1
!
username $$$$$$ privilege 15 secret 5
!
!
!
interface FastEthernet0/0
description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$$ETH-LAN$
ip address 192.168.254.20 255.255.255.0
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
description $FW_OUTSIDE$$ETH-WAN$
ip address 192.168.20.1 255.255.255.248
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface Serial0/1/0
ip address 192.168.22.1 255.255.255.248
no ip proxy-arp
ip route-cache flow
!
interface Serial0/2/0
ip address 192.168.21.1 255.255.255.248
no ip proxy-arp
ip route-cache flow
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 192.168.1.0 255.255.255.0 FastEthernet0/1
ip route 192.168.1.0 255.255.255.0 Serial0/2/0 2
ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
ip route 192.168.2.0 255.255.255.0 Serial0/1/0 2
ip route 192.168.20.0 255.255.255.248 FastEthernet0/1
ip route 192.168.21.0 255.255.255.248 Serial0/2/0
ip route 192.168.22.0 255.255.255.248 Serial0/1/0
ip route 192.168.50.0 255.255.255.0 192.168.254.200
ip route 192.168.51.0 255.255.255.0 192.168.254.200
ip route 192.168.254.0 255.255.255.0 FastEthernet0/0
!
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
logging trap debugging
access-list 1 remark INSIDE_IF=FastEthernet0/0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.254.0 0.0.0.255
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet
line vty 5 15
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
end
The routers we are using are 2801's....
here are my running conf's
The routers we are using are 2801's....
here are my running conf's
BRANCH OFFICE
!This is the running config of the router: 192.168.1.20
!----------------------------------------------------------------------------
!version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname router
!
boot-start-marker
boot-end-marker
!
no logging buffered
enable secret 5
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -8
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
ip cef
!
!
no ip dhcp use vrf connected
!
!
ip flow-cache timeout active 1
ip name-server 192.168.1.1
ip name-server 192.169.254.2
ip name-server 192.168.254.1
!
username admin privilege 15 secret 5
!
!
interface FastEthernet0/0
description $ETH-WAN$
ip address 192.168.1.20 255.255.255.0
no ip redirects
no ip unreachables
no ip proxy-arp
ip route-cache flow
duplex auto
speed auto
!
interface FastEthernet0/1
description $ETH-WAN$
ip address 192.168.20.2 255.255.255.248
ip route-cache flow
duplex auto
speed auto
!
interface Serial0/2/0
ip address 192.168.21.2 255.255.255.252
no ip proxy-arp
ip route-cache flow
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
ip route 0.0.0.0 0.0.0.0 Serial0/2/0 2
ip route 192.168.1.0 255.255.255.0 FastEthernet0/0
ip flow-export source FastEthernet0/0
ip flow-export version 5
ip flow-export destination 192.168.1.1 9996
!
ip http server
!
ip access-list standard Internal_IF
remark SDM_ACL Category=2
permit 192.168.1.0 0.0.0.255
!
snmp-server ifindex persist
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
password
login
transport input telnet
transport output none
!
end
BRANCH OFFICE
!This is the running config of the router: 192.168.2.20
!----------------------------------------------------------------------------
!version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname Cisco-Roseburg
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -8
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
ip cef
!
!
no ip dhcp use vrf connected
!
!
no ip bootp server
ip domain name mvengineering.com
ip name-server 192.168.254.2
ip name-server 192.168.254.1
!
username $$$$$ privilege 15 secret 5
username $$$$$ privilege 15 secret 5
!
!
!
interface FastEthernet0/0
description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$$ETH-LAN$
ip address 192.168.2.20 255.255.255.0
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
description $ETH-WAN$
ip address 192.168.20.3 255.255.255.248
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface Serial0/2/0
ip address 192.168.22.2 255.255.255.248
no ip proxy-arp
ip route-cache flow
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/1
ip route 0.0.0.0 0.0.0.0 Serial0/2/0 2
!
ip http server
ip http authentication local
ip http timeout-policy idle 60 life 86400 requests 10000
!
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
line aux 0
line vty 0 4
privilege level 15
login local
transport input telnet
line vty 5 15
privilege level 15
login local
transport input telnet
!
end
-------------------------------------
HQ
!This is the running config of the router: 192.168.254.20
!----------------------------------------------------------------------------
!version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname mod-cisco-1
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
logging buffered 51200 debugging
logging console critical
enable secret 5
!
no aaa new-model
!
resource policy
!
clock timezone PCTime -8
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
mmi polling-interval 60
no mmi auto-configure
no mmi pvc
mmi snmp-timeout 180
ip subnet-zero
no ip source-route
ip cef
!
!
ip tcp synwait-time 10
no ip dhcp use vrf connected
!
!
no ip bootp server
ip domain name mvengineering.com
ip name-server 192.168.254.1
ip name-server 192.168.254.2
ip name-server 192.168.1.1
!
username $$$$$$ privilege 15 secret 5
!
!
!
interface FastEthernet0/0
description $ETH-SW-LAUNCH$$INTF-INFO-FE 0$$ES_LAN$$FW_INSIDE$$ETH-LAN$
ip address 192.168.254.20 255.255.255.0
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface FastEthernet0/1
description $FW_OUTSIDE$$ETH-WAN$
ip address 192.168.20.1 255.255.255.248
ip route-cache flow
duplex auto
speed auto
no mop enabled
!
interface Serial0/1/0
ip address 192.168.22.1 255.255.255.248
no ip proxy-arp
ip route-cache flow
!
interface Serial0/2/0
ip address 192.168.21.1 255.255.255.248
no ip proxy-arp
ip route-cache flow
!
ip classless
ip route 0.0.0.0 0.0.0.0 FastEthernet0/0
ip route 192.168.1.0 255.255.255.0 FastEthernet0/1
ip route 192.168.1.0 255.255.255.0 Serial0/2/0 2
ip route 192.168.2.0 255.255.255.0 FastEthernet0/1
ip route 192.168.2.0 255.255.255.0 Serial0/1/0 2
ip route 192.168.20.0 255.255.255.248 FastEthernet0/1
ip route 192.168.21.0 255.255.255.248 Serial0/2/0
ip route 192.168.22.0 255.255.255.248 Serial0/1/0
ip route 192.168.50.0 255.255.255.0 192.168.254.200
ip route 192.168.51.0 255.255.255.0 192.168.254.200
ip route 192.168.254.0 255.255.255.0 FastEthernet0/0
!
ip http server
ip http authentication local
ip http timeout-policy idle 600 life 86400 requests 10000
!
logging trap debugging
access-list 1 remark INSIDE_IF=FastEthernet0/0
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.254.0 0.0.0.255
no cdp run
!
control-plane
!
banner login ^CAuthorized access only!
Disconnect IMMEDIATELY if you are not an authorized user!^C
!
line con 0
login local
transport output telnet
line aux 0
login local
transport output telnet
line vty 0 4
privilege level 15
login local
transport input telnet
line vty 5 15
privilege level 15
login local
transport input telnet
!
scheduler allocate 20000 1000
end