MWM
MIS
- Aug 9, 2001
- 200
827 help appreciated.
Using static ip from PacBell--connects using IRB just fine, but I have to assign a static route to the gateway address for DNS to work. Shouldn't it work as well using the BVI 1 interface?
----Static route 0.0.0.0/0 to BVI 1 cannot ping DNS server.
Static route 0.0.0.0/0 to 63.192.xxx.xxx, the PacBell gateway, does connect to DNS; this works.
The Static Route command synatx allows both the Bridge Virtual Interface and the Forwarding Router Address, but only the Forwarding Router Address works. Why?
Also, "IP Name-Server" command seems redundant since there is a dhcp command, "DNS-Server"? DNS works fine using only the dhcp DNS-Server command.
And, is there any syntax significance between "BVI 1" (with a space) and "BVI1" (without a space)?
Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname WCRouter
!
enable secret 5 -------------------
enable password 7 -----------------
!
ip subnet-zero
no ip finger
ip name-server 206.13.28.12
ip name-server 206.13.31.12
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool CLIENT
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 206.13.28.12 206.13.31.12
lease 0 0 5
!
bridge irb
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
ip nat inside
no ip mroute-cache
!
interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5snap
!
bundle-enable
bridge-group 1
hold-queue 224 in
!
interface BVI1
ip address 63.192.yyy.yyy 255.255.255.0 (63.192.yyy.yyy = my static ip)
no ip directed-broadcast
ip nat outside
!
ip nat inside source list 1 interface BVI1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 63.192.xxx.xxx (63.192.xxx.xxx = PacBell gateway)
no ip http server
!
access-list 1 permit 10.10.10.0 0.0.0.255
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 30 0
login local
length 0
!
scheduler max-task-time 5000
end
Using static ip from PacBell--connects using IRB just fine, but I have to assign a static route to the gateway address for DNS to work. Shouldn't it work as well using the BVI 1 interface?
----Static route 0.0.0.0/0 to BVI 1 cannot ping DNS server.
Static route 0.0.0.0/0 to 63.192.xxx.xxx, the PacBell gateway, does connect to DNS; this works.
The Static Route command synatx allows both the Bridge Virtual Interface and the Forwarding Router Address, but only the Forwarding Router Address works. Why?
Also, "IP Name-Server" command seems redundant since there is a dhcp command, "DNS-Server"? DNS works fine using only the dhcp DNS-Server command.
And, is there any syntax significance between "BVI 1" (with a space) and "BVI1" (without a space)?
Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname WCRouter
!
enable secret 5 -------------------
enable password 7 -----------------
!
ip subnet-zero
no ip finger
ip name-server 206.13.28.12
ip name-server 206.13.31.12
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool CLIENT
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 206.13.28.12 206.13.31.12
lease 0 0 5
!
bridge irb
!
interface Ethernet0
ip address 10.10.10.1 255.255.255.0
no ip directed-broadcast
ip nat inside
no ip mroute-cache
!
interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive
pvc 8/35
encapsulation aal5snap
!
bundle-enable
bridge-group 1
hold-queue 224 in
!
interface BVI1
ip address 63.192.yyy.yyy 255.255.255.0 (63.192.yyy.yyy = my static ip)
no ip directed-broadcast
ip nat outside
!
ip nat inside source list 1 interface BVI1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 63.192.xxx.xxx (63.192.xxx.xxx = PacBell gateway)
no ip http server
!
access-list 1 permit 10.10.10.0 0.0.0.255
bridge 1 protocol ieee
bridge 1 route ip
!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 30 0
login local
length 0
!
scheduler max-task-time 5000
end