makemorebeer
Technical User
i've got three cisco 1811 routers and three ADSL lines. i need our two remote sites to connect via VPN, or anything that may work over ADSL to the main office. my plan is to use a dynamic multipoint GRE tunnel from each remote site to the main office and i'm having trouble getting a good how to on the setup. i do have a functional GRE tunnel between one of the remote sites and the main office right now but i need bi-directional traffic flow from both sites to the same router. SDM won't allow setup of two GRE tunnels, and the DMVPN setup in SDM is a waste of time. If i can get one fo the multipoint links up, i'm sure i can get the other up so i'll post the config from the main facility and the first remote site. Also to add a bit of wonder to it, the remote site i'm working with right now is the same subnet as the main facilitys subnet and they are connected at a different point by a wireless bridge. (am i shooting myself in the foot here)
Main facility configuration
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
crypto pki trustpoint TP-self-signed-
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-
revocation-check none
rsakeypair TP-self-signed-
!
!
crypto pki certificate chain TP-self-signed-
certificate self-signed 01
quit
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
crypto isakmp key {removed} address 64.91.x.x 255.255.255.252
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA1 esp-3des esp-sha-hmac
mode transport
crypto ipsec transform-set hisec esp-3des esp-md5-hmac
!
crypto ipsec profile DMVPN
!
crypto ipsec profile SDM_Profile1
set transform-set ESP-3DES-SHA1
!
crypto ipsec profile SDM_Profile2
set transform-set ESP-3DES-SHA
!
crypto ipsec profile citybrew
set transform-set hisec
!
no ip source-route
!
!
ip cef
!
!
no ip bootp server
ip domain name {removed}
ip name-server x.x.x.x
ip name-server x.x.x.x
!
multilink bundle-name authenticated
vpdn enable
!
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface Tunnel0
bandwidth 1000
ip address 10.10.1.3 255.255.255.0
no ip redirects
ip mtu 1492
ip nhrp authentication {removed}
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip nhrp holdtime 360
ip nhrp cache non-authoritative
ip tcp adjust-mss 1360
delay 1000
tunnel source FastEthernet1
tunnel mode gre multipoint
tunnel key 0
tunnel protection ipsec profile DMVPN
!
interface Null0
no ip unreachables
Remote Facility config
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname LAX-R4
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
no logging buffered
!
crypto pki trustpoint self-signed-cert
enrollment selfsigned
ip-address 10.1.254.246
revocation-check crl
rsakeypair self-signed-cert
!
!
crypto pki certificate chain self-signed-cert
certificate self-signed 01
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key {removed} address 69.29.x.x
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
mode transport
crypto ipsec transform-set hisec esp-3des esp-md5-hmac
!
crypto ipsec profile DMVPN
set transform-set hisec
!
crypto ipsec profile SDM_Profile1
set transform-set ESP-3DES-SHA
!
no ip source-route
!
!
ip cef
!
!
no ip bootp server
ip domain name {removed}
ip name-server 10.1.x.x
ip name-server 10.1.x.x
!
multilink bundle-name authenticated
vpdn enable
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh version 1
!
!
bba-group pppoe global
!
!
interface Tunnel0
bandwidth 1000
ip address 10.10.1.4 255.255.0.0
no ip redirects
ip mtu 1440
ip nhrp authentication {removed}
ip nhrp map multicast dynamic
ip nhrp map 10.10.1.3 69.29.x.x
ip nhrp map multicast 69.29.x.x
ip nhrp network-id 1
ip nhrp holdtime 360
ip nhrp nhs 10.10.1.3
ip nhrp cache non-authoritative
ip tcp adjust-mss 1360
delay 1000
tunnel source FastEthernet1
tunnel mode gre multipoint
tunnel key 0
tunnel protection ipsec profile DMVPN
!
interface FastEthernet0
description Primary Connection
ip address 10.1.254.246 255.255.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
description ADSL$FW_OUTSIDE$$ES_WAN$$ETH-WAN$
no ip address
ip verify unicast reverse-path
no ip redirects
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
interface Dialer0
description $FW_OUTSIDE$
mtu 1492
bandwidth 10000
ip address 64.91.x.x 255.255.255.252
ip nat outside
ip irdp
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password 7
ppp pap sent-username password 7
!
router eigrp 2
network 10.1.0.0 0.0.255.255
network 10.10.1.0 0.0.0.255
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source list Outmap interface Dialer0 overload
!
ip access-list extended Outmap
remark SDM_ACL Category=2
remark permit 10.1 traffic out to internet
permit ip 10.1.0.0 0.0.255.255 any
remark implicit deny
deny ip any any
end
Main facility configuration
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
crypto pki trustpoint TP-self-signed-
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-
revocation-check none
rsakeypair TP-self-signed-
!
!
crypto pki certificate chain TP-self-signed-
certificate self-signed 01
quit
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
crypto isakmp key {removed} address 64.91.x.x 255.255.255.252
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-3DES-SHA1 esp-3des esp-sha-hmac
mode transport
crypto ipsec transform-set hisec esp-3des esp-md5-hmac
!
crypto ipsec profile DMVPN
!
crypto ipsec profile SDM_Profile1
set transform-set ESP-3DES-SHA1
!
crypto ipsec profile SDM_Profile2
set transform-set ESP-3DES-SHA
!
crypto ipsec profile citybrew
set transform-set hisec
!
no ip source-route
!
!
ip cef
!
!
no ip bootp server
ip domain name {removed}
ip name-server x.x.x.x
ip name-server x.x.x.x
!
multilink bundle-name authenticated
vpdn enable
!
!
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh authentication-retries 2
!
!
!
interface Tunnel0
bandwidth 1000
ip address 10.10.1.3 255.255.255.0
no ip redirects
ip mtu 1492
ip nhrp authentication {removed}
ip nhrp map multicast dynamic
ip nhrp network-id 1
ip nhrp holdtime 360
ip nhrp cache non-authoritative
ip tcp adjust-mss 1360
delay 1000
tunnel source FastEthernet1
tunnel mode gre multipoint
tunnel key 0
tunnel protection ipsec profile DMVPN
!
interface Null0
no ip unreachables
Remote Facility config
version 12.4
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
service password-encryption
service sequence-numbers
!
hostname LAX-R4
!
boot-start-marker
boot-end-marker
!
security authentication failure rate 3 log
security passwords min-length 6
no logging buffered
!
crypto pki trustpoint self-signed-cert
enrollment selfsigned
ip-address 10.1.254.246
revocation-check crl
rsakeypair self-signed-cert
!
!
crypto pki certificate chain self-signed-cert
certificate self-signed 01
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key {removed} address 69.29.x.x
!
!
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
mode transport
crypto ipsec transform-set hisec esp-3des esp-md5-hmac
!
crypto ipsec profile DMVPN
set transform-set hisec
!
crypto ipsec profile SDM_Profile1
set transform-set ESP-3DES-SHA
!
no ip source-route
!
!
ip cef
!
!
no ip bootp server
ip domain name {removed}
ip name-server 10.1.x.x
ip name-server 10.1.x.x
!
multilink bundle-name authenticated
vpdn enable
!
ip tcp synwait-time 10
ip ssh time-out 60
ip ssh version 1
!
!
bba-group pppoe global
!
!
interface Tunnel0
bandwidth 1000
ip address 10.10.1.4 255.255.0.0
no ip redirects
ip mtu 1440
ip nhrp authentication {removed}
ip nhrp map multicast dynamic
ip nhrp map 10.10.1.3 69.29.x.x
ip nhrp map multicast 69.29.x.x
ip nhrp network-id 1
ip nhrp holdtime 360
ip nhrp nhs 10.10.1.3
ip nhrp cache non-authoritative
ip tcp adjust-mss 1360
delay 1000
tunnel source FastEthernet1
tunnel mode gre multipoint
tunnel key 0
tunnel protection ipsec profile DMVPN
!
interface FastEthernet0
description Primary Connection
ip address 10.1.254.246 255.255.0.0
ip nat inside
ip virtual-reassembly
duplex auto
speed auto
!
interface FastEthernet1
description ADSL$FW_OUTSIDE$$ES_WAN$$ETH-WAN$
no ip address
ip verify unicast reverse-path
no ip redirects
ip nat outside
ip virtual-reassembly
duplex auto
speed auto
pppoe enable group global
pppoe-client dial-pool-number 1
interface Dialer0
description $FW_OUTSIDE$
mtu 1492
bandwidth 10000
ip address 64.91.x.x 255.255.255.252
ip nat outside
ip irdp
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname
ppp chap password 7
ppp pap sent-username password 7
!
router eigrp 2
network 10.1.0.0 0.0.255.255
network 10.10.1.0 0.0.0.255
no auto-summary
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
!
ip http server
ip http authentication local
no ip http secure-server
ip nat inside source list Outmap interface Dialer0 overload
!
ip access-list extended Outmap
remark SDM_ACL Category=2
remark permit 10.1 traffic out to internet
permit ip 10.1.0.0 0.0.255.255 any
remark implicit deny
deny ip any any
end