Hi all! Please bare with me as I think I am quite a ways off here. I have searched the info in these forums and could not solve this issue on my own, so please feel free to offer any useful input. In any event I am attempting to connect my 2514 to my Pix 501 (which is connected to my cable modem and working). I just need some help with the config for the 2514. What I have to do right now to connect to the internet (to post this thread for example) is simply connect my switch directly to the 501. So I don't think I have any config issues with the 501. Anwyay, I want to connect the 2514 to the 501 and connect my LAN switch to the 2514. I think I am confused as to the config of E0 since that interface is connected to the 501 as opposed to the cable modem. What ip address should I be assigning that interface? Also, what kind of static routes should I have? As you can see from my config, I plugged in a static route with the next hop address of the 501, but since I can't even ping the 501 from the 2514, that obviously doesn't work. Any help is appreciated!!
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Router
!
boot system flash 1:aaa0850.bin
no logging console
!
ip subnet-zero
!
!
!
interface Ethernet0
ip address 10.0.0.1 255.255.255.0
no ip directed-broadcast
ip nat outside
no ip route-cache
no ip mroute-cache
no cdp enable
!
interface Ethernet1
ip address 192.168.1.10 255.255.255.0
no ip directed-broadcast
ip nat inside
no ip route-cache
no ip mroute-cache
!
interface Serial0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
transport input all
line vty 0 4
login
!
end
Current configuration:
!
version 12.0
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
service udp-small-servers
service tcp-small-servers
!
hostname Router
!
boot system flash 1:aaa0850.bin
no logging console
!
ip subnet-zero
!
!
!
interface Ethernet0
ip address 10.0.0.1 255.255.255.0
no ip directed-broadcast
ip nat outside
no ip route-cache
no ip mroute-cache
no cdp enable
!
interface Ethernet1
ip address 192.168.1.10 255.255.255.0
no ip directed-broadcast
ip nat inside
no ip route-cache
no ip mroute-cache
!
interface Serial0
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
no fair-queue
!
interface Serial1
no ip address
no ip directed-broadcast
no ip route-cache
no ip mroute-cache
shutdown
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.1
!
!
line con 0
exec-timeout 0 0
transport input none
line aux 0
transport input all
line vty 0 4
login
!
end