Hi there,
I have the following scenario...
Internet (ADSL) -> Cisco 837 -> Lan 192.168.1.0
This all works fine, internet access, web server access etc. I also have the Cisco 837 connected to a Pix 501 which in turn connects to a seperate LAN in our building 172.20.4.0. I have the Pix 501 setup as a VPN server, from any client on the 192.168.1.0 network I can connect through the Pix onto my second LAN, obtain an address and it all works fine.
However, when I try to VPN from the internet through the Cisco 837, It just does not connect at all. I believe I need to port forward (NAT) on the 837 to the Pix box?? Here is my config, can anybody tell me if I am missing something obvious?
WWADSL#sh run
Building configuration...
Current configuration : 2650 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname WWADSL
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$RLjO$.otKlniZBscACswq85As7.
!
username admin password 0 *****
no aaa new-model
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.251
ip dhcp excluded-address 192.168.1.111
ip dhcp excluded-address 192.168.1.100
ip dhcp excluded-address 192.168.1.80
!
ip dhcp pool WWCLIENTS
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.251
dns-server 194.72.0.114 62.6.40.162
!
!
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.251 255.255.255.0
ip nat inside
ip virtual-reassembly
no cdp enable
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname B002913@hg40.btclick.com
ppp chap password 0 *******
ppp pap sent-username B002913@hg40.btclick.com password 0 rustlers1
ppp ipcp dns request
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 110 interface Dialer0 overload
ip nat inside source static udp 192.168.1.100 10000 interface Dialer0 10000
ip nat inside source static tcp 192.168.1.100 10000 interface Dialer0 10000
ip nat inside source static udp 192.168.1.100 4500 interface Dialer0 4500
ip nat inside source static esp 192.168.1.100 interface Dialer0
ip nat inside source static udp 192.168.1.100 500 interface Dialer0 500
ip nat inside source static tcp 192.168.1.80 25 interface Dialer0 25
ip nat inside source static tcp 192.168.1.80 80 interface Dialer0 80
!
!
access-list 1 permit any
access-list 110 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
login local
transport preferred all
transport input telnet ssh
transport output none
!
scheduler max-task-time 5000
end
WWADSL#
Regards
John
I have the following scenario...
Internet (ADSL) -> Cisco 837 -> Lan 192.168.1.0
This all works fine, internet access, web server access etc. I also have the Cisco 837 connected to a Pix 501 which in turn connects to a seperate LAN in our building 172.20.4.0. I have the Pix 501 setup as a VPN server, from any client on the 192.168.1.0 network I can connect through the Pix onto my second LAN, obtain an address and it all works fine.
However, when I try to VPN from the internet through the Cisco 837, It just does not connect at all. I believe I need to port forward (NAT) on the 837 to the Pix box?? Here is my config, can anybody tell me if I am missing something obvious?
WWADSL#sh run
Building configuration...
Current configuration : 2650 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname WWADSL
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$RLjO$.otKlniZBscACswq85As7.
!
username admin password 0 *****
no aaa new-model
ip subnet-zero
!
!
ip dhcp excluded-address 192.168.1.251
ip dhcp excluded-address 192.168.1.111
ip dhcp excluded-address 192.168.1.100
ip dhcp excluded-address 192.168.1.80
!
ip dhcp pool WWCLIENTS
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.251
dns-server 194.72.0.114 62.6.40.162
!
!
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.251 255.255.255.0
ip nat inside
ip virtual-reassembly
no cdp enable
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap pap callin
ppp chap hostname B002913@hg40.btclick.com
ppp chap password 0 *******
ppp pap sent-username B002913@hg40.btclick.com password 0 rustlers1
ppp ipcp dns request
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
no ip http server
no ip http secure-server
ip nat inside source list 110 interface Dialer0 overload
ip nat inside source static udp 192.168.1.100 10000 interface Dialer0 10000
ip nat inside source static tcp 192.168.1.100 10000 interface Dialer0 10000
ip nat inside source static udp 192.168.1.100 4500 interface Dialer0 4500
ip nat inside source static esp 192.168.1.100 interface Dialer0
ip nat inside source static udp 192.168.1.100 500 interface Dialer0 500
ip nat inside source static tcp 192.168.1.80 25 interface Dialer0 25
ip nat inside source static tcp 192.168.1.80 80 interface Dialer0 80
!
!
access-list 1 permit any
access-list 110 permit ip 192.168.1.0 0.0.0.255 any
dialer-list 1 protocol ip permit
no cdp run
!
control-plane
!
!
line con 0
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
login local
transport preferred all
transport input telnet ssh
transport output none
!
scheduler max-task-time 5000
end
WWADSL#
Regards
John