Hi,
I currently have a cable modem with a Linksys Cable/DSL router using NAT to share my internet connection. For some reason the Linksys unit keeps freezing. I have a Cisco 2611 running IOS Version 12.2(5d). I want to configure the 2611 to pretty much do the same thing the Linksys is doing so I can use it to replace the Linksys unit. I tried this config that I gathered from a few different sources but it doesn't work. I am really new to the IOS CLI and understand most of the commands but not all of them. Anyway when I do a "show ip interface brief" command I get the following output:
Cisco2611c#show ip interface brief
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 unassigned YES NVRAM up up
Ethernet0/1 192.168.1.1 YES NVRAM up up
I am assuming that the IP address for E0/0 would change when it acquires an IP from my cable provider's DHCP server. When I run the command it tells me unassigned so I am a guessing that interface is not getting an address. This is my current config. Can anyone tell me where I am making my mistakes or give me the exact code that would work for me in my situation. If possible maybe a brief description of what each section of code is actually doing. I really appreciate any help. Thanks in advance....!
Cisco2611c#show run
Building configuration...
Current configuration : 864 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco2611c
!
enable secret 5 $1$5KZ8$xUcOUIY8pQp1WKPmpz3gO90
!
ip subnet-zero
!
!
ip name-server 24.29.99.81 <--- My ISP's DNS
ip name-server 24.29.99.82 <--- My ISP's DNS
ip name-server 24.29.99.28 <--- My ISP's DNS
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool HOME
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 24.29.99.81 24.29.99.82 24.29.99.28
lease 0 2
!
!
!
!
interface Ethernet0/0
ip address dhcp
ip nat outside
half-duplex
!
interface Ethernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
half-duplex
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
no ip http server
ip pim bidir-enable
!
access-list 1 permit any
!
line con 0
line aux 0
line vty 0 4
password
login
!
no scheduler allocate
end
I currently have a cable modem with a Linksys Cable/DSL router using NAT to share my internet connection. For some reason the Linksys unit keeps freezing. I have a Cisco 2611 running IOS Version 12.2(5d). I want to configure the 2611 to pretty much do the same thing the Linksys is doing so I can use it to replace the Linksys unit. I tried this config that I gathered from a few different sources but it doesn't work. I am really new to the IOS CLI and understand most of the commands but not all of them. Anyway when I do a "show ip interface brief" command I get the following output:
Cisco2611c#show ip interface brief
Interface IP-Address OK? Method Status Protocol
Ethernet0/0 unassigned YES NVRAM up up
Ethernet0/1 192.168.1.1 YES NVRAM up up
I am assuming that the IP address for E0/0 would change when it acquires an IP from my cable provider's DHCP server. When I run the command it tells me unassigned so I am a guessing that interface is not getting an address. This is my current config. Can anyone tell me where I am making my mistakes or give me the exact code that would work for me in my situation. If possible maybe a brief description of what each section of code is actually doing. I really appreciate any help. Thanks in advance....!
Cisco2611c#show run
Building configuration...
Current configuration : 864 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco2611c
!
enable secret 5 $1$5KZ8$xUcOUIY8pQp1WKPmpz3gO90
!
ip subnet-zero
!
!
ip name-server 24.29.99.81 <--- My ISP's DNS
ip name-server 24.29.99.82 <--- My ISP's DNS
ip name-server 24.29.99.28 <--- My ISP's DNS
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool HOME
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 24.29.99.81 24.29.99.82 24.29.99.28
lease 0 2
!
!
!
!
interface Ethernet0/0
ip address dhcp
ip nat outside
half-duplex
!
interface Ethernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
half-duplex
!
ip nat inside source list 1 interface Ethernet0/0 overload
ip classless
no ip http server
ip pim bidir-enable
!
access-list 1 permit any
!
line con 0
line aux 0
line vty 0 4
password
login
!
no scheduler allocate
end