localbuilt
Technical User
Need some help. I have been tasked to change the switch port-channel. The requirements are to change settings from LACP/Etherchannel mode to PaGP mode. The problem is that this is production and I don't have a lab to test. I'm not sure how it would behave if I start reconfiguring one by one and I'm afraid there would be a recalculation of routing if the channel is broken. Question 1. How do I smoothly change the settings so that no production impact. 2. what will happen when one link is a different mode?
3. Are any configs I need to do for this change other than "channel-group 2 mode desirable"
below are the config details on my scenerio.
SWA# sh int po2
Port-channel2 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 000f.2462.a34b (bia 000f.2462.a348)
Description: SWB
MTU 1500 bytes, BW 8000000 Kbit, DLY 10 usec,
reliability 255/255, txload 8/255, rxload 39/255
Encapsulation ARPA, loopback not set
Full-duplex, 1000Mb/s
input flow-control is off, output flow-control is unsupported
Members in this channel: Gi2/45 Gi2/46 Gi2/47 Gi2/48 Gi3/45 Gi3/46 Gi3/47 Gi3/48
SWA#sh run int g2/45
Building configuration...
Current configuration : 251 bytes
!
interface GigabitEthernet2/45
description swB
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 120,122,124,126,324,401,402,501-504,700
switchport mode trunk
channel-group 2 mode on
end
SWB#sh int po2
Port-channel2 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 000f.f77e.2dac (bia 000f.f77e.2dac)
Description: SWA
MTU 1500 bytes, BW 8000000 Kbit, DLY 10 usec,
reliability 255/255, txload 23/255, rxload 8/255
Encapsulation ARPA, loopback not set
Full-duplex, 1000Mb/s
input flow-control is off, output flow-control is unsupported
Members in this channel: Gi2/45 Gi2/46 Gi2/47 Gi2/48 Gi3/45 Gi3/46 Gi3/47 Gi3/48
ARP type: ARPA, ARP Timeout 04:00:00
SWB#sh run int g2/45
Building configuration...
Current configuration : 251 bytes
!
interface GigabitEthernet2/45
description SWA
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 120,122,124,126,324,401,402,501-504,700
switchport mode trunk
channel-group 2 mode on
3. Are any configs I need to do for this change other than "channel-group 2 mode desirable"
below are the config details on my scenerio.
SWA# sh int po2
Port-channel2 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 000f.2462.a34b (bia 000f.2462.a348)
Description: SWB
MTU 1500 bytes, BW 8000000 Kbit, DLY 10 usec,
reliability 255/255, txload 8/255, rxload 39/255
Encapsulation ARPA, loopback not set
Full-duplex, 1000Mb/s
input flow-control is off, output flow-control is unsupported
Members in this channel: Gi2/45 Gi2/46 Gi2/47 Gi2/48 Gi3/45 Gi3/46 Gi3/47 Gi3/48
SWA#sh run int g2/45
Building configuration...
Current configuration : 251 bytes
!
interface GigabitEthernet2/45
description swB
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 120,122,124,126,324,401,402,501-504,700
switchport mode trunk
channel-group 2 mode on
end
SWB#sh int po2
Port-channel2 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 000f.f77e.2dac (bia 000f.f77e.2dac)
Description: SWA
MTU 1500 bytes, BW 8000000 Kbit, DLY 10 usec,
reliability 255/255, txload 23/255, rxload 8/255
Encapsulation ARPA, loopback not set
Full-duplex, 1000Mb/s
input flow-control is off, output flow-control is unsupported
Members in this channel: Gi2/45 Gi2/46 Gi2/47 Gi2/48 Gi3/45 Gi3/46 Gi3/47 Gi3/48
ARP type: ARPA, ARP Timeout 04:00:00
SWB#sh run int g2/45
Building configuration...
Current configuration : 251 bytes
!
interface GigabitEthernet2/45
description SWA
no ip address
switchport
switchport trunk encapsulation dot1q
switchport trunk allowed vlan 120,122,124,126,324,401,402,501-504,700
switchport mode trunk
channel-group 2 mode on