I have a situation where I have two routers on different sites One is at a remote depot and one is at our central site Router A is a Cisco 800 series and is remote and Router B is a Cisco 4000 series with ISDN modules and is on the Hub site.
The problem is that I have configured them to Use ISDN dial up with CHAP authentication. The problem being that I can dial up from the Hub site to the remote site and I get a ping however when a PC at the remote site attempts to connect the connection starts up (i.e. the Channel light illuminates) but there is no ping. It would seem that the chap password authentication is failing one way and I cannot see why. I have included the two configs below hopefully someone out there will be able to see something I can't?
ROUTER A - REMOTE ROUTER
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cabanasj
!
logging buffered 8192 debugging
enable secret 5 $1$vqHD$J40GTqvHKlNKAndlzZB5Q1
enable password 7 140713181F13253920
!
username cabanasj password 7 094F4F0B180B160101
username haydock2 password 7 0503071625434D02
!
!
!
!
!
pots country GB
ip subnet-zero
no ip source-route
!
isdn switch-type basic-net3
isdn voice-call-failure 0
!
!
!
interface Ethernet0
ip address 192.110.24.1 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
ppp authentication chap pap callin
ppp chap hostname cabanasj
ppp multilink
!
interface Dialer1
description RCN
ip address 192.110.98.2 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
encapsulation ppp
no ip split-horizon
dialer remote-name haydock2
dialer pool 1
dialer idle-timeout 300
dialer string ############# class DialClass
dialer hold-queue 10
dialer load-threshold 10 either
dialer-group 1
pulse-time 0
ppp authentication chap pap callin
ppp chap hostname cabanasj
ppp chap password 7 0007120405550A1505
ppp pap sent-username cabanasj password 7 0508070D20424F1A13
ppp multilink
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.110.1.0 255.255.255.0 192.110.98.1
!
!
map-class dialer DialClass
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
!
time-range TIME
periodic daily 0:00 to 23:59
!
end
ROUTER B - HUB ROUTER
Building configuration...
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname haydock2
!
enable secret 5 $1$C3x/$YuVrS3ZraJ2RE7JDeqgrc0
enable password password
!
username wythenshawe password 7 120F0C1A0604
username central password 7 070C24425A1B1809
username cabanasj password 7 04580A040E2F4D5D03
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0c99.3892
isdn switch-type basic-net3
!
interface Ethernet0
description Ethernet i/f @ Haydock2
ip address 192.110.1.2 255.255.255.0
media-type 10BaseT
ipx network 1
ipx output-sap-filter 1000
!
interface Serial0
description Kilostream to Chertsey 2503
ip address 192.110.15.1 255.255.255.0
bandwidth 64
ipx network 15
ipx output-sap-filter 1000
no fair-queue
!
interface Serial1
description Kilostream to Glasgow 2503
ip address 192.110.16.1 255.255.255.0
ipx network 16
ipx output-sap-filter 1000
no fair-queue
!
interface Serial2
description Support from Datel
ip address 100.0.0.2 255.0.0.0
no fair-queue
!
interface Serial3
no ip address
shutdown
!
interface BRI0
description Dial-up connection from Cabana Central
ip address 192.110.94.1 255.255.255.0
encapsulation ppp
bandwidth 64
dialer-group 1
no fair-queue
ppp authentication chap
!
interface BRI1
description Dail-up connection from Cabana SJ
ip address 192.110.98.1 255.255.255.0
encapsulation ppp
bandwidth 64
dialer map ip 192.110.98.2 name cabanasj ############
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname cabanasj
ppp chap password 7 121A041513050D1720
!
!
interface BRI2
no ip address
encapsulation ppp
shutdown
!
interface BRI3
no ip address
shutdown
!
router rip
network 192.110.1.0
network 192.110.15.0
network 192.110.16.0
network 192.110.94.0
network 192.110.20.0
network 192.110.96.0
network 192.110.22.0
network 10.0.0.0
network 100.0.0.0
network 192.110.98.0
network 192.110.24.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.110.1.253
ip route 10.0.0.0 255.255.0.0 100.0.0.1
ip route 192.110.20.0 255.255.255.0 192.110.94.2
ip route 192.110.22.0 255.255.255.0 192.110.96.2
ip route 192.110.24.0 255.255.255.0 192.110.98.2
access-list 1000 permit FFFFFFFF 4
access-list 1000 permit FFFFFFFF 278
access-list 1000 permit FFFFFFFF 26B
access-list 1000 permit FFFFFFFF 237
access-list 1000 permit FFFFFFFF 107
access-list 1000 deny FFFFFFFF
!
!
!
snmp-server community public RO
snmp-server enable traps isdn
snmp-server enable traps config
snmp-server enable traps bgp
snmp-server enable traps frame-relay
dialer-list 1 protocol ip permit
alias exec preston telnet 192.110.4.1
alias exec stockpack telnet 192.110.6.1
alias exec wythenshawe telnet 192.110.2.1
alias exec vimtobackup telnet 192.110.2.2
alias exec chertsey telnet 192.110.5.1
alias exec solent telnet 192.110.3.1
alias exec glasgow telnet 192.110.8.1
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password password
login
!
end
Cheers
Nichols (still a novice but learning slowly)
The problem is that I have configured them to Use ISDN dial up with CHAP authentication. The problem being that I can dial up from the Hub site to the remote site and I get a ping however when a PC at the remote site attempts to connect the connection starts up (i.e. the Channel light illuminates) but there is no ping. It would seem that the chap password authentication is failing one way and I cannot see why. I have included the two configs below hopefully someone out there will be able to see something I can't?
ROUTER A - REMOTE ROUTER
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname cabanasj
!
logging buffered 8192 debugging
enable secret 5 $1$vqHD$J40GTqvHKlNKAndlzZB5Q1
enable password 7 140713181F13253920
!
username cabanasj password 7 094F4F0B180B160101
username haydock2 password 7 0503071625434D02
!
!
!
!
!
pots country GB
ip subnet-zero
no ip source-route
!
isdn switch-type basic-net3
isdn voice-call-failure 0
!
!
!
interface Ethernet0
ip address 192.110.24.1 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
!
interface BRI0
no ip address
no ip directed-broadcast
encapsulation ppp
dialer pool-member 1
isdn switch-type basic-net3
ppp authentication chap pap callin
ppp chap hostname cabanasj
ppp multilink
!
interface Dialer1
description RCN
ip address 192.110.98.2 255.255.255.0
no ip directed-broadcast
no ip proxy-arp
encapsulation ppp
no ip split-horizon
dialer remote-name haydock2
dialer pool 1
dialer idle-timeout 300
dialer string ############# class DialClass
dialer hold-queue 10
dialer load-threshold 10 either
dialer-group 1
pulse-time 0
ppp authentication chap pap callin
ppp chap hostname cabanasj
ppp chap password 7 0007120405550A1505
ppp pap sent-username cabanasj password 7 0508070D20424F1A13
ppp multilink
!
no ip http server
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route 192.110.1.0 255.255.255.0 192.110.98.1
!
!
map-class dialer DialClass
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
!
time-range TIME
periodic daily 0:00 to 23:59
!
end
ROUTER B - HUB ROUTER
Building configuration...
Current configuration:
!
version 11.1
service udp-small-servers
service tcp-small-servers
!
hostname haydock2
!
enable secret 5 $1$C3x/$YuVrS3ZraJ2RE7JDeqgrc0
enable password password
!
username wythenshawe password 7 120F0C1A0604
username central password 7 070C24425A1B1809
username cabanasj password 7 04580A040E2F4D5D03
ip subnet-zero
no ip domain-lookup
ipx routing 0000.0c99.3892
isdn switch-type basic-net3
!
interface Ethernet0
description Ethernet i/f @ Haydock2
ip address 192.110.1.2 255.255.255.0
media-type 10BaseT
ipx network 1
ipx output-sap-filter 1000
!
interface Serial0
description Kilostream to Chertsey 2503
ip address 192.110.15.1 255.255.255.0
bandwidth 64
ipx network 15
ipx output-sap-filter 1000
no fair-queue
!
interface Serial1
description Kilostream to Glasgow 2503
ip address 192.110.16.1 255.255.255.0
ipx network 16
ipx output-sap-filter 1000
no fair-queue
!
interface Serial2
description Support from Datel
ip address 100.0.0.2 255.0.0.0
no fair-queue
!
interface Serial3
no ip address
shutdown
!
interface BRI0
description Dial-up connection from Cabana Central
ip address 192.110.94.1 255.255.255.0
encapsulation ppp
bandwidth 64
dialer-group 1
no fair-queue
ppp authentication chap
!
interface BRI1
description Dail-up connection from Cabana SJ
ip address 192.110.98.1 255.255.255.0
encapsulation ppp
bandwidth 64
dialer map ip 192.110.98.2 name cabanasj ############
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname cabanasj
ppp chap password 7 121A041513050D1720
!
!
interface BRI2
no ip address
encapsulation ppp
shutdown
!
interface BRI3
no ip address
shutdown
!
router rip
network 192.110.1.0
network 192.110.15.0
network 192.110.16.0
network 192.110.94.0
network 192.110.20.0
network 192.110.96.0
network 192.110.22.0
network 10.0.0.0
network 100.0.0.0
network 192.110.98.0
network 192.110.24.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.110.1.253
ip route 10.0.0.0 255.255.0.0 100.0.0.1
ip route 192.110.20.0 255.255.255.0 192.110.94.2
ip route 192.110.22.0 255.255.255.0 192.110.96.2
ip route 192.110.24.0 255.255.255.0 192.110.98.2
access-list 1000 permit FFFFFFFF 4
access-list 1000 permit FFFFFFFF 278
access-list 1000 permit FFFFFFFF 26B
access-list 1000 permit FFFFFFFF 237
access-list 1000 permit FFFFFFFF 107
access-list 1000 deny FFFFFFFF
!
!
!
snmp-server community public RO
snmp-server enable traps isdn
snmp-server enable traps config
snmp-server enable traps bgp
snmp-server enable traps frame-relay
dialer-list 1 protocol ip permit
alias exec preston telnet 192.110.4.1
alias exec stockpack telnet 192.110.6.1
alias exec wythenshawe telnet 192.110.2.1
alias exec vimtobackup telnet 192.110.2.2
alias exec chertsey telnet 192.110.5.1
alias exec solent telnet 192.110.3.1
alias exec glasgow telnet 192.110.8.1
!
line con 0
exec-timeout 0 0
line aux 0
line vty 0 4
password password
login
!
end
Cheers
Nichols (still a novice but learning slowly)