Hello,
I recently setup Cisco IOS VPN and I am having some trouble. I am able to get remote VPN clients to successfully connect and get an IP address however they can not communicate with anything across the tunnel. Also I checked the router running VPN IOS and there is an "Incomplete" mac address listed for the IP of the remote client when I do a "show arp":
RTR01#show arp | i 192.168.1
FastEthernet0/0.1
Internet 192.168.1.231 0 Incomplete ARPA
Here is my IOS VPN configuration:
username test password test
!
!
crypto isakmp policy 3
encr 3des
authentication pre-share
group 2
!
! NOTE ADDED BELOW ENTRY PER A SUGGESTION BUT DID NOT MAKE A DIFFERENCE
!
crypto isakmp invalid-spi-recovery
!
!
crypto isakmp client configuration group VPNGROUP
key VPNKEY
dns x.x.x.x y.y.y.y
domain mydomain.com
pool ippool
crypto ipsec transform-set myset esp-3des esp-sha-hmac
!
crypto dynamic-map dynmap 10
set transform-set myset
crypto map clientmap client authentication list userauthen
crypto map clientmap isakmp authorization list groupauthor
crypto map clientmap client configuration address respond
crypto map clientmap 10 ipsec-isakmp dynamic dynmap
!
interface FastEthernet0/1
desc TO CABLE MODEM ISP
ip address dhcp
crypto map clientmap
!
!
ip local pool ippool 192.168.1.230 192.168.1.240
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
One thing I might add is when I watch on the statistics window on the client I see 0 bytes received but bytes transmitting does increment (also seeing packets encrypted incrementing, and also discarded / bypassed).
I am running IOS version 12.4(10) and have tried Cisco VPN clients 4.8, and various versions of 5.x. All have the same issue. OS is Microsoft Windows XP SP3 (do not have a way to test on anything else at the moment).
Thanks for any input!
-Rainman
I recently setup Cisco IOS VPN and I am having some trouble. I am able to get remote VPN clients to successfully connect and get an IP address however they can not communicate with anything across the tunnel. Also I checked the router running VPN IOS and there is an "Incomplete" mac address listed for the IP of the remote client when I do a "show arp":
RTR01#show arp | i 192.168.1
FastEthernet0/0.1
Internet 192.168.1.231 0 Incomplete ARPA
Here is my IOS VPN configuration:
username test password test
!
!
crypto isakmp policy 3
encr 3des
authentication pre-share
group 2
!
! NOTE ADDED BELOW ENTRY PER A SUGGESTION BUT DID NOT MAKE A DIFFERENCE
!
crypto isakmp invalid-spi-recovery
!
!
crypto isakmp client configuration group VPNGROUP
key VPNKEY
dns x.x.x.x y.y.y.y
domain mydomain.com
pool ippool
crypto ipsec transform-set myset esp-3des esp-sha-hmac
!
crypto dynamic-map dynmap 10
set transform-set myset
crypto map clientmap client authentication list userauthen
crypto map clientmap isakmp authorization list groupauthor
crypto map clientmap client configuration address respond
crypto map clientmap 10 ipsec-isakmp dynamic dynmap
!
interface FastEthernet0/1
desc TO CABLE MODEM ISP
ip address dhcp
crypto map clientmap
!
!
ip local pool ippool 192.168.1.230 192.168.1.240
ip nat inside source list 1 interface FastEthernet0/1 overload
!
access-list 1 permit 192.168.1.0 0.0.0.255
One thing I might add is when I watch on the statistics window on the client I see 0 bytes received but bytes transmitting does increment (also seeing packets encrypted incrementing, and also discarded / bypassed).
I am running IOS version 12.4(10) and have tried Cisco VPN clients 4.8, and various versions of 5.x. All have the same issue. OS is Microsoft Windows XP SP3 (do not have a way to test on anything else at the moment).
Thanks for any input!
-Rainman