TheProvider
IS-IT--Management
- Feb 2, 2011
- 22
Please would some one be able to assist with a dial peer configuration for the below scenario.
The current setup currently has a vwic2-2mft,
It has a SIP trunk which is used for incoming and outgoing calls and port 0 of the wvic has an isdn 30 uplink into a toshiba telephone system. This setup works great.
We now have and ISDN30 from BT which we will be placing into port 1 of the vwic.
Now without going into details, our sip ITSP has a divert on failure feature which will divert to ddis on the bt isdn 30.
SO I have 2 needs, incoming calls from BT need to pass 6 digits to the ISDN30 uplink to the toshiba, also the other requirement is if the SIP trunk is to go down I want the calls to route via the BT ISDN30.
Therefore I am in desperate need of some assistance sorting the translation rules and dial peer out.
I am a CCIP and have avaya Voice ACA certification however despite loads of dial peer research I am unable to acheieve what I am after.
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
no ipv6 cef
ip source-route
ip cef
!
!
ip name-server 8.8.8.8 (for testting)
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
no local-bypass
!
!
!
voice service voip
fax protocol pass-through g711alaw
sip
outbound-proxy dns:***SIP ITSP DNS NAME***
sip-profiles 1
!
voice class codec 711
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice class sip-profiles 1
request ANY sip-header Cisco-Guid remove
response ANY sip-header Cisco-Guid remove
request ANY sip-header Remote-Party-ID modify "@.*>" "@***SIP ITSP DNS NAME***>"
response ANY sip-header Remote-Party-ID modify "@.*>" "@***SIP ITSP DNS NAME***>"
!
!
!
voice translation-rule 1
rule 1 /0/ /44/
rule 2 /^0/ /44/
!
!
voice translation-profile Correct_Outwards
translate calling 1
!
controller E1 0/0/0
pri-group timeslots 1-16
!
!
class-map match-any ef
match ip dscp ef
class-map match-any af31
match ip dscp af31
match access-group 160
!
!
policy-map SIPVoice
class ef
priority 1840
class af31
bandwidth 100
policy-map output
class class-default
shape average 7000000
service-policy SIPVoice
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed 100
!
interface GigabitEthernet0/0.4093
description *** 10Mbps BT ***
bandwidth 10000
encapsulation dot1Q 4093
ip address x x x x 255.255.255.254
service-policy output output
!
interface GigabitEthernet0/1
description *** Uplink to Customer Switch ***
no ip address
duplex full
speed 1000
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving
isdn protocol-emulate network
isdn incoming-voice voice
isdn sending-complete
no cdp enable
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 gi0/0
!
!
voice-port 0/0/0:15
cptone GB
timeouts interdigit 5
!
!
mgcp fax t38 ecm
!
!
dial-peer voice 100 voip
translation-profile outgoing Correct_Outwards
huntstop
preference 2
max-conn 30
destination-pattern .T
progress_ind setup enable 3
session protocol sipv2
session target sip-server
voice-class codec 711
dtmf-relay rtp-nte
no vad
!
dial-peer voice 1 pots
huntstop
preference 1
destination-pattern 44[0-9]
direct-inward-dial
port 0/0/0:15
forward-digits 4
no sip-register
!
!
gateway
timer receive-rtp 1200
!
sip-ua
credentials username "username" password "password" realm xxx.com
authentication username "username" password "password" realm xxx.com
set pstn-cause 47 sip-status 486
retry invite 2
retry response 3
retry bye 3
retry prack 6
timers expires 300000
registrar dns:dns name expires 3600
sip-server dns:dns name
connection-reuse
host-registrar
!
!
!
gatekeeper
shutdown
The current setup currently has a vwic2-2mft,
It has a SIP trunk which is used for incoming and outgoing calls and port 0 of the wvic has an isdn 30 uplink into a toshiba telephone system. This setup works great.
We now have and ISDN30 from BT which we will be placing into port 1 of the vwic.
Now without going into details, our sip ITSP has a divert on failure feature which will divert to ddis on the bt isdn 30.
SO I have 2 needs, incoming calls from BT need to pass 6 digits to the ISDN30 uplink to the toshiba, also the other requirement is if the SIP trunk is to go down I want the calls to route via the BT ISDN30.
Therefore I am in desperate need of some assistance sorting the translation rules and dial peer out.
I am a CCIP and have avaya Voice ACA certification however despite loads of dial peer research I am unable to acheieve what I am after.
network-clock-participate wic 0
network-clock-select 1 E1 0/0/0
!
no ipv6 cef
ip source-route
ip cef
!
!
ip name-server 8.8.8.8 (for testting)
!
!
!
!
isdn switch-type primary-net5
!
!
!
voice-card 0
dspfarm
dsp services dspfarm
no local-bypass
!
!
!
voice service voip
fax protocol pass-through g711alaw
sip
outbound-proxy dns:***SIP ITSP DNS NAME***
sip-profiles 1
!
voice class codec 711
codec preference 1 g711ulaw
codec preference 2 g711alaw
codec preference 3 g729r8
!
voice class sip-profiles 1
request ANY sip-header Cisco-Guid remove
response ANY sip-header Cisco-Guid remove
request ANY sip-header Remote-Party-ID modify "@.*>" "@***SIP ITSP DNS NAME***>"
response ANY sip-header Remote-Party-ID modify "@.*>" "@***SIP ITSP DNS NAME***>"
!
!
!
voice translation-rule 1
rule 1 /0/ /44/
rule 2 /^0/ /44/
!
!
voice translation-profile Correct_Outwards
translate calling 1
!
controller E1 0/0/0
pri-group timeslots 1-16
!
!
class-map match-any ef
match ip dscp ef
class-map match-any af31
match ip dscp af31
match access-group 160
!
!
policy-map SIPVoice
class ef
priority 1840
class af31
bandwidth 100
policy-map output
class class-default
shape average 7000000
service-policy SIPVoice
!
interface GigabitEthernet0/0
no ip address
duplex auto
speed 100
!
interface GigabitEthernet0/0.4093
description *** 10Mbps BT ***
bandwidth 10000
encapsulation dot1Q 4093
ip address x x x x 255.255.255.254
service-policy output output
!
interface GigabitEthernet0/1
description *** Uplink to Customer Switch ***
no ip address
duplex full
speed 1000
!
interface Serial0/0/0:15
no ip address
encapsulation hdlc
isdn switch-type primary-net5
isdn overlap-receiving
isdn protocol-emulate network
isdn incoming-voice voice
isdn sending-complete
no cdp enable
!
!
ip forward-protocol nd
!
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 gi0/0
!
!
voice-port 0/0/0:15
cptone GB
timeouts interdigit 5
!
!
mgcp fax t38 ecm
!
!
dial-peer voice 100 voip
translation-profile outgoing Correct_Outwards
huntstop
preference 2
max-conn 30
destination-pattern .T
progress_ind setup enable 3
session protocol sipv2
session target sip-server
voice-class codec 711
dtmf-relay rtp-nte
no vad
!
dial-peer voice 1 pots
huntstop
preference 1
destination-pattern 44[0-9]
direct-inward-dial
port 0/0/0:15
forward-digits 4
no sip-register
!
!
gateway
timer receive-rtp 1200
!
sip-ua
credentials username "username" password "password" realm xxx.com
authentication username "username" password "password" realm xxx.com
set pstn-cause 47 sip-status 486
retry invite 2
retry response 3
retry bye 3
retry prack 6
timers expires 300000
registrar dns:dns name expires 3600
sip-server dns:dns name
connection-reuse
host-registrar
!
!
!
gatekeeper
shutdown