Tariq Habaybeh
Programmer
Hi everyone, I'm seeking for your urgent help,
We have a small office and we got new router from Cisco which is C881WD-E-K9. And I'm not so into router configuration and CLI of Cisco. Let me tell you what we have, we have cable internet connection with static IP, the static IP has also default Gateway, Primary DNS and Secondary DNS IPs. Below is the show run command result:
I need to know how to connect it to the internet and configure the wireless connection. and I will appreciate your assistance.
We have a small office and we got new router from Cisco which is C881WD-E-K9. And I'm not so into router configuration and CLI of Cisco. Let me tell you what we have, we have cable internet connection with static IP, the static IP has also default Gateway, Primary DNS and Secondary DNS IPs. Below is the show run command result:
Code:
yourname#sh run
Building configuration...
Current configuration : 5952 bytes
!
! Last configuration change at 13:04:34 UTC Fri Sep 28 2018 by admin
version 15.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname yourname
!
boot-start-marker
boot-end-marker
!
aqm-register-fnf
!
logging buffered 51200 warnings
!
no aaa new-model
service-module wlan-ap 0 bootimage autonomous
!
crypto pki trustpoint TP-self-signed-2108123872
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2108123872
revocation-check none
rsakeypair TP-self-signed-2108123872
!
!
crypto pki certificate chain TP-self-signed-2108123872
certificate self-signed 01
3082022B 30820194 A0030201 02020101 300D0609 2A864886 F70D0101 05050030
31312F30 2D060355 04031326 494F532D 53656C66 2D536967 6E65642D 43657274
69666963 6174652D 32313038 31323338 3732301E 170D3138 30393238 31323437
32365A17 0D323030 31303130 30303030 305A3031 312F302D 06035504 03132649
4F532D53 656C662D 5369676E 65642D43 65727469 66696361 74652D32 31303831
32333837 3230819F 300D0609 2A864886 F70D0101 01050003 818D0030 81890281
8100F0D8 C94617AD 5254A6F9 A1457E1F 2C983B2C 1DF437BF 274D2D18 4D174011
D043938A 42F5C74A DC199276 60A8F362 50A4E8C4 DA835BD7 FA3F8413 B4FABD50
673F8A1D C799859F FB498BBA B2737032 A17C00F2 7E2EF8FD 965F234F 8831287A
55D7089C 8FB6CDBA 6917FC04 DC8634B2 B924AE5C A5030856 65693304 C1AE8B38
232B0203 010001A3 53305130 0F060355 1D130101 FF040530 030101FF 301F0603
551D2304 18301680 14DC3C5B 90E8E645 F2BFCDC4 4BF75298 F409AFFA BF301D06
03551D0E 04160414 DC3C5B90 E8E645F2 BFCDC44B F75298F4 09AFFABF 300D0609
2A864886 F70D0101 05050003 818100E4 0A7D4BF4 82D25C72 52C969F4 199D0C85
B3A6121F 31786EBB B59D682F 8914D37C F1ACB480 39903A38 6907F945 3C03A5DE
BEE060FB 35E63DF1 A1E58686 74B10A08 E4D36005 73CBC8FC 3063C26F D700AE3A
CD0A06C4 A6B9C6D2 F5AD1B67 9A2622B5 9412F06D 70405F4E 0B8ED77A D51B6A95
F7912377 8F9B1445 66FDA48D 676F49
quit
!
!
!
!
!
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 83.164.197.49
!
ip dhcp pool ccp-pool
import all
network 10.10.10.0 255.255.255.248
default-router 83.164.197.49
dns-server 83.164.192.4 83.164.192.5
lease 0 2
!
!
!
ip domain name yourdomain.com
ip name-server 83.164.192.4
ip name-server 83.164.193.5
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
license udi pid C881WD-E-K9 sn FCZ190892TJ
!
!
username admin privilege 15 secret 5 $1$q/e1$MUBMbwyz3Go9Hi90iSUGv0
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
description PrimaryWANDesc_
ip address 83.164.197.50 255.255.255.252
ip nat outside
ip virtual-reassembly in
duplex auto
speed auto
!
interface Wlan-GigabitEthernet0
description Internal switch interface connecting to the embedded AP
switchport mode trunk
no ip address
!
interface wlan-ap0
description Service module interface to manage the embedded AP
ip unnumbered Vlan1
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$
ip address 10.10.10.1 255.255.255.248
ip tcp adjust-mss 1452
!
ip forward-protocol nd
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
!
!
ip nat inside source list nat-list interface FastEthernet4 overload
ip route 0.0.0.0 0.0.0.0 FastEthernet4
!
no cdp run
!
access-list 23 permit 10.10.10.0 0.0.0.7
!
control-plane
!
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
banner exec ^C
% Password expiration warning.
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device
and it provides the default username "cisco" for one-time use. If you have
already used the username "cisco" to login to the router and your IOS image
supports the "one-time" user option, then this username has already expired.
You will not be able to login to the router with this username after you exit
this session.
It is strongly suggested that you create a new username with a privilege level
of 15 using the following command.
username <myuser> privilege 15 secret 0 <mypassword>
Replace <myuser> and <mypassword> with the username and password you
want to use.
-----------------------------------------------------------------------
^C
banner login ^C
-----------------------------------------------------------------------
Cisco Configuration Professional (Cisco CP) is installed on this device.
This feature requires the one-time use of the username "cisco" with the
password "cisco". These default credentials have a privilege level of 15.
YOU MUST USE CISCO CP or the CISCO IOS CLI TO CHANGE THESE
PUBLICLY-KNOWN CREDENTIALS
Here are the Cisco IOS commands.
username <myuser> privilege 15 secret 0 <mypassword>
no username cisco
Replace <myuser> and <mypassword> with the username and password you want
to use.
IF YOU DO NOT CHANGE THE PUBLICLY-KNOWN CREDENTIALS, YOU WILL
NOT BE ABLE TO LOG INTO THE DEVICE AGAIN AFTER YOU HAVE LOGGED OFF.
For more information about Cisco CP please follow the instructions in the
QUICK START GUIDE for your router or go to [URL unfurl="true"]http://www.cisco.com/go/ciscocp[/URL]
-----------------------------------------------------------------------
^C
!
line con 0
login local
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
access-class 23 in
privilege level 15
login local
transport input telnet ssh
line vty 5 15
access-class 23 in
privilege level 15
login local
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end
I need to know how to connect it to the internet and configure the wireless connection. and I will appreciate your assistance.