We are using Cisco 877 ADSL routers at remote sites connecting back to a Cisco 2851 using GRE tunnels. At seemingly random intervals the 877 routers will crash and we loose contact with them and have to power cycle them. Has anyone else come across this problem and found a solution?
The 877 have IOS version 12.4.24(T).
This is the config
Current configuration : 4363 bytes
!
! No configuration change since last restart
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname x
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 x
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2647445651
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2647445651
revocation-check none
rsakeypair TP-self-signed-2647445651
!
!
crypto pki certificate chain TP-self-signed-2647445651
certificate self-signed 01
quit
dot11 syslog
ip source-route
ip dhcp excluded-address x.x.x.x
!
!
ip cef
ip domain name x.x.x.x
ip name-server x.x.x.x
ip name-server x.x.x.x
ntp server x.x.x.x
ntp server x.x.x.x
!
!
!
!
!
!
crypto isakmp policy 10
encr 3des
authentication pre-share
crypto isakmp key x address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set 3des-set esp-3des esp-sha-hmac
!
crypto ipsec profile mgre_ipsec
set security-association lifetime seconds 7200
set transform-set 3des-set
!
!
archive
log config
hidekeys
!
!
!
!
!
interface Tunnel100
description x end of tunnel
bandwidth 2000
ip address x.x.x.x x.x.x.x
no ip redirects
ip nhrp authentication x
ip nhrp map multicast dynamic
ip nhrp map multicast x.x.x.x
ip nhrp map x.x.x.x x.x.x.x
ip nhrp network-id 99
ip nhrp holdtime 300
ip nhrp nhs x.x.x.x
delay 1000
tunnel source ATM0.1
tunnel mode gre multipoint
tunnel key 10000
tunnel protection ipsec profile mgre_ipsec
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
description Be* Adsl connection
mtu 1500
ip address x.x.x.x x.x.x.x
no ip proxy-arp
atm route-bridged ip
pvc 0/101
oam-pvc manage
encapsulation aal5snap
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description ethernet
ip address x.x.x.x x.x.x.x
ip tcp adjust-mss 1452
!
ip default-gateway x.x.x.x
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Tunnel100
ip route x.x.x.x x.x.x.x x.x.x.x
ip route x.x.x.x x.x.x.x x.x.x.x
!
scheduler max-task-time 5000
end
The 877 have IOS version 12.4.24(T).
This is the config
Current configuration : 4363 bytes
!
! No configuration change since last restart
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname x
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
logging buffered 51200 warnings
enable secret 5 x
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2647445651
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2647445651
revocation-check none
rsakeypair TP-self-signed-2647445651
!
!
crypto pki certificate chain TP-self-signed-2647445651
certificate self-signed 01
quit
dot11 syslog
ip source-route
ip dhcp excluded-address x.x.x.x
!
!
ip cef
ip domain name x.x.x.x
ip name-server x.x.x.x
ip name-server x.x.x.x
ntp server x.x.x.x
ntp server x.x.x.x
!
!
!
!
!
!
crypto isakmp policy 10
encr 3des
authentication pre-share
crypto isakmp key x address 0.0.0.0 0.0.0.0
!
!
crypto ipsec transform-set 3des-set esp-3des esp-sha-hmac
!
crypto ipsec profile mgre_ipsec
set security-association lifetime seconds 7200
set transform-set 3des-set
!
!
archive
log config
hidekeys
!
!
!
!
!
interface Tunnel100
description x end of tunnel
bandwidth 2000
ip address x.x.x.x x.x.x.x
no ip redirects
ip nhrp authentication x
ip nhrp map multicast dynamic
ip nhrp map multicast x.x.x.x
ip nhrp map x.x.x.x x.x.x.x
ip nhrp network-id 99
ip nhrp holdtime 300
ip nhrp nhs x.x.x.x
delay 1000
tunnel source ATM0.1
tunnel mode gre multipoint
tunnel key 10000
tunnel protection ipsec profile mgre_ipsec
!
interface ATM0
no ip address
no atm ilmi-keepalive
!
interface ATM0.1 point-to-point
description Be* Adsl connection
mtu 1500
ip address x.x.x.x x.x.x.x
no ip proxy-arp
atm route-bridged ip
pvc 0/101
oam-pvc manage
encapsulation aal5snap
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description ethernet
ip address x.x.x.x x.x.x.x
ip tcp adjust-mss 1452
!
ip default-gateway x.x.x.x
ip forward-protocol nd
ip route 0.0.0.0 0.0.0.0 Tunnel100
ip route x.x.x.x x.x.x.x x.x.x.x
ip route x.x.x.x x.x.x.x x.x.x.x
!
scheduler max-task-time 5000
end