I am having great difficulty getting a web server working with my router.
The web server is connected directly into the cisco and has a private ip address of 192.168.1.3
the router ip address is 192.168.1.5
The web server gateway is also 192.168.1.5
Can someone have a look at my script and point me in the right direction. I'm a newbie to this kind of stuff. Ive been at this router for a week now and searched high and low for the answer. As for as I can see I only need the following: -
ip nat inside source static tcp 192.168.1.3 80 2.2.2.2 80 extendable
This doesnt seem to work. I'm probably missing something really silly or obvious to you guys.
I replaced my isp's real static ip given to me with 2.2.2.2 for security reasons.
Thanks
Building configuration...
Current configuration : 7105 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
aaa session-id common
!
resource policy
!
ip dhcp excluded-address 192.168.1.5 255.255.255.0
!
!
ip cef
ip inspect name DEFAULT100 cuseeme
ip inspect name DEFAULT100 ftp
ip inspect name DEFAULT100 h323
ip inspect name DEFAULT100 icmp
ip inspect name DEFAULT100 rcmd
ip inspect name DEFAULT100 realaudio
ip inspect name DEFAULT100 rtsp
ip inspect name DEFAULT100 esmtp
ip inspect name DEFAULT100 sqlnet
ip inspect name DEFAULT100 streamworks
ip inspect name DEFAULT100 tftp
ip inspect name DEFAULT100 tcp
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 vdolive
ip domain name yourdomain.com
ip name-server 158.152.1.43
ip name-server 158.152.1.58
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$
no snmp trap link-status
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
ip address 192.168.1.5 255.255.255.0
ip access-group 100 in
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
description $FW_OUTSIDE$
ip address 2.2.2.2 255.255.255.248
ip access-group 101 in
ip inspect DEFAULT100 out
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname ***************************.co.uk
ppp chap password 0 ****************
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.3 80 2.2.2.2 80 extendable
!
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 10 remark anything
access-list 10 remark SDM_ACL Category=1
access-list 10 permit any
access-list 23 permit 3.3.3.3
access-list 23 remark SDM_ACL Category=16
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 100 remark auto generated by Cisco SDM Express firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny ip 2.2.2.2 0.0.0.7 any
access-list 100 deny ip host 255.255.255.255 any
access-list 100 deny ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 remark auto generated by Cisco SDM Express firewall configuration
access-list 101 remark SDM_ACL Category=1
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq telnet
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq 22
access-list 101 permit tcp host 3.3.3.3 host 2.2.2.2 eq 22
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq www
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq 443
access-list 101 permit tcp host 3.3.3.3 host 2.2.2.2 eq 443
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq cmd
access-list 101 permit tcp host 3.3.3.3 host 2.2.2.2 eq cmd
access-list 101 deny udp any host 2.2.2.2 eq snmp
access-list 101 deny ip 192.168.1.0 0.0.0.255 any
access-list 101 permit icmp any host 2.2.2.2 echo-reply
access-list 101 permit icmp any host 2.2.2.2 time-exceeded
access-list 101 permit icmp any host 2.2.2.2 unreachable
access-list 101 deny ip 10.0.0.0 0.255.255.255 any
access-list 101 deny ip 172.16.0.0 0.15.255.255 any
access-list 101 deny ip 192.168.0.0 0.0.255.255 any
access-list 101 deny ip 127.0.0.0 0.255.255.255 any
access-list 101 deny ip host 255.255.255.255 any
access-list 101 deny ip host 0.0.0.0 any
access-list 101 deny ip any any
access-list 102 remark SDM_ACL Category=1
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit ip host 3.3.3.3 any
dialer-list 1 protocol ip permit
no cdp run
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class 102 in
transport input telnet ssh
!
scheduler max-task-time 5000
end
The web server is connected directly into the cisco and has a private ip address of 192.168.1.3
the router ip address is 192.168.1.5
The web server gateway is also 192.168.1.5
Can someone have a look at my script and point me in the right direction. I'm a newbie to this kind of stuff. Ive been at this router for a week now and searched high and low for the answer. As for as I can see I only need the following: -
ip nat inside source static tcp 192.168.1.3 80 2.2.2.2 80 extendable
This doesnt seem to work. I'm probably missing something really silly or obvious to you guys.
I replaced my isp's real static ip given to me with 2.2.2.2 for security reasons.
Thanks
Building configuration...
Current configuration : 7105 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
aaa new-model
!
!
aaa authentication login default local
aaa authorization exec default local
!
aaa session-id common
!
resource policy
!
ip dhcp excluded-address 192.168.1.5 255.255.255.0
!
!
ip cef
ip inspect name DEFAULT100 cuseeme
ip inspect name DEFAULT100 ftp
ip inspect name DEFAULT100 h323
ip inspect name DEFAULT100 icmp
ip inspect name DEFAULT100 rcmd
ip inspect name DEFAULT100 realaudio
ip inspect name DEFAULT100 rtsp
ip inspect name DEFAULT100 esmtp
ip inspect name DEFAULT100 sqlnet
ip inspect name DEFAULT100 streamworks
ip inspect name DEFAULT100 tftp
ip inspect name DEFAULT100 tcp
ip inspect name DEFAULT100 udp
ip inspect name DEFAULT100 vdolive
ip domain name yourdomain.com
ip name-server 158.152.1.43
ip name-server 158.152.1.58
!
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
description $ES_WAN$
no snmp trap link-status
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
description $ETH-SW-LAUNCH$$INTF-INFO-HWIC 4ESW$$FW_INSIDE$
ip address 192.168.1.5 255.255.255.0
ip access-group 100 in
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1452
!
interface Dialer0
description $FW_OUTSIDE$
ip address 2.2.2.2 255.255.255.248
ip access-group 101 in
ip inspect DEFAULT100 out
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname ***************************.co.uk
ppp chap password 0 ****************
!
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
ip http access-class 23
ip http authentication local
ip http secure-server
ip http timeout-policy idle 60 life 86400 requests 10000
ip nat inside source list 1 interface Dialer0 overload
ip nat inside source static tcp 192.168.1.3 80 2.2.2.2 80 extendable
!
access-list 1 remark INSIDE_IF=Vlan1
access-list 1 remark SDM_ACL Category=2
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 10 remark anything
access-list 10 remark SDM_ACL Category=1
access-list 10 permit any
access-list 23 permit 3.3.3.3
access-list 23 remark SDM_ACL Category=16
access-list 23 permit 192.168.1.0 0.0.0.255
access-list 100 remark auto generated by Cisco SDM Express firewall configuration
access-list 100 remark SDM_ACL Category=1
access-list 100 deny ip 2.2.2.2 0.0.0.7 any
access-list 100 deny ip host 255.255.255.255 any
access-list 100 deny ip 127.0.0.0 0.255.255.255 any
access-list 100 permit ip any any
access-list 101 remark auto generated by Cisco SDM Express firewall configuration
access-list 101 remark SDM_ACL Category=1
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq telnet
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq 22
access-list 101 permit tcp host 3.3.3.3 host 2.2.2.2 eq 22
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq www
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq 443
access-list 101 permit tcp host 3.3.3.3 host 2.2.2.2 eq 443
access-list 101 permit tcp 192.168.1.0 0.0.0.255 host 2.2.2.2 eq cmd
access-list 101 permit tcp host 3.3.3.3 host 2.2.2.2 eq cmd
access-list 101 deny udp any host 2.2.2.2 eq snmp
access-list 101 deny ip 192.168.1.0 0.0.0.255 any
access-list 101 permit icmp any host 2.2.2.2 echo-reply
access-list 101 permit icmp any host 2.2.2.2 time-exceeded
access-list 101 permit icmp any host 2.2.2.2 unreachable
access-list 101 deny ip 10.0.0.0 0.255.255.255 any
access-list 101 deny ip 172.16.0.0 0.15.255.255 any
access-list 101 deny ip 192.168.0.0 0.0.255.255 any
access-list 101 deny ip 127.0.0.0 0.255.255.255 any
access-list 101 deny ip host 255.255.255.255 any
access-list 101 deny ip host 0.0.0.0 any
access-list 101 deny ip any any
access-list 102 remark SDM_ACL Category=1
access-list 102 permit ip 192.168.1.0 0.0.0.255 any
access-list 102 permit ip host 3.3.3.3 any
dialer-list 1 protocol ip permit
no cdp run
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
access-class 102 in
transport input telnet ssh
!
scheduler max-task-time 5000
end