rickrude11
IS-IT--Management
Hi Guys,
I bought a cisco 851w to replace my linksys router for my cable connection.
I am using one of those broadband speed testing sites to test my connection. When I plug the pc into the linksys router or directly to the cable modem, i get <> 24000kb/s. When I go through the cisco router I get 3000kb/s.
If I am using the cisco router, and download a file with 'down them all' firefox extension, which splits the file into multiple connections, it downloads at over 2MB/s (that is megabytes). So this means that the router is limiting bandwidth per connection or something ??
Any suggestions appreciated. Below is my config.
---------------------------------------------------------
I bought a cisco 851w to replace my linksys router for my cable connection.
I am using one of those broadband speed testing sites to test my connection. When I plug the pc into the linksys router or directly to the cable modem, i get <> 24000kb/s. When I go through the cisco router I get 3000kb/s.
If I am using the cisco router, and download a file with 'down them all' firefox extension, which splits the file into multiple connections, it downloads at over 2MB/s (that is megabytes). So this means that the router is limiting bandwidth per connection or something ??
Any suggestions appreciated. Below is my config.
---------------------------------------------------------
Code:
Current configuration : 4229 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname GW_Router
!
boot-start-marker
boot-end-marker
!
logging buffered 64000 debugging
enable secret 5 $$$$$$$$$$$$$$$$$$$$$$$$$$$
!
no aaa new-model
!
resource policy
!
clock timezone bris 10
ip subnet-zero
no ip dhcp use vrf connected
ip dhcp excluded-address 10.0.5.1 10.0.5.100
ip dhcp excluded-address 10.0.5.110 10.0.5.254
!
ip dhcp pool LAN1
import all
network 10.0.5.0 255.255.255.0
default-router 10.0.5.1
domain-name home.local
dns-server 4.2.2.2
lease 14
!
!
ip cef
ip inspect log drop-pkt
ip inspect name OUTBOUND udp
ip inspect name OUTBOUND bootpc
ip inspect name OUTBOUND bootps
ip inspect name OUTBOUND icmp
ip inspect name OUTBOUND ftp
ip inspect name OUTBOUND http
ip inspect name OUTBOUND https
ip inspect name OUTBOUND pop3
ip inspect name OUTBOUND ssh
ip inspect name OUTBOUND telnet
no ip domain lookup
ip domain name home.local
ip ssh version 2
!
!
!
username admin secret 5 $$$$$$$$$$$$$$$$$$$$$$$$$$
!
!
!
crypto isakmp policy 1
encr 3des
authentication pre-share
group 2
crypto isakmp key xxxxxxxxxxxxxx address x.x.x.x
!
crypto isakmp peer address x.x.x.x
!
!
crypto ipsec transform-set XXXXX esp-3des esp-sha-hmac
!
crypto map XXXXXMAP 10 ipsec-isakmp
set peer x.x.x.x
set transform-set XXXXX
match address XXXXX_LAN
!
!
!
interface Loopback1
ip address 10.10.10.1 255.255.255.0
!
interface FastEthernet0
spanning-tree portfast
!
interface FastEthernet1
spanning-tree portfast
!
interface FastEthernet2
spanning-tree portfast
!
interface FastEthernet3
spanning-tree portfast
!
interface FastEthernet4
ip address dhcp
ip access-group INCOMING in
ip inspect OUTBOUND out
ip nat outside
ip virtual-reassembly
ip tcp adjust-mss 1460
speed 100
full-duplex
no cdp enable
crypto map XXXXXMAP
!
interface Dot11Radio0
no ip address
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0
54.0
station-role root
!
interface Vlan1
ip address 10.0.5.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip classless
!
no ip http server
no ip http secure-server
ip nat inside source list NAT interface FastEthernet4 overload
ip nat inside source static tcp 10.0.5.102 56357 interface FastEthernet4 56357
ip nat inside source static udp 10.0.5.102 4882 interface FastEthernet4 4882
ip nat inside source static tcp 10.0.5.102 4992 interface FastEthernet4 4992
ip nat inside source static tcp 10.0.5.102 40000 x.x.x.x 40000 route-map
NO_NAT_FLIN extendable
!
ip access-list standard SSH_IN
permit x.x.x.0 0.0.0.255
permit x.x.x.0 0.0.0.255
permit 10.0.5.96 0.0.0.15
permit 172.16.32.0 0.0.0.255
permit x.x.x.0 0.0.0.255
!
ip access-list extended FLIN_TO_XXXXX
deny ip host 10.0.5.102 172.16.32.0 0.0.0.255
deny ip host 10.0.5.102 x.x.x.0 0.0.0.255
permit ip 10.0.5.0 0.0.0.255 any
remark DENIES NAT FOR FLIN TO XXXXX VIA TUNNEL
ip access-list extended INCOMING
permit tcp x.x.x.0 0.0.0.255 any eq 22
permit tcp x.x.x.0 0.0.0.255 any eq 3389
permit tcp x.x.x.0 0.0.0.255 any eq 40000
permit udp any any eq bootpc
permit udp any any eq bootps
permit tcp any any eq 56357
permit ip x.x.x.0 0.0.0.255 any
permit tcp host 172.16.32.40 any eq 40000
permit tcp any any eq 4992
permit udp any any eq 4882
ip access-list extended XXXXX_LAN
permit ip 10.0.5.0 0.0.0.255 172.16.32.0 0.0.0.255
permit ip 10.0.5.0 0.0.0.255 x.x.x.0 0.0.0.255
permit ip 10.0.5.0 0.0.0.255 host x.xx.x
ip access-list extended NAT
deny ip 10.0.5.0 0.0.0.255 x.x.x.0 0.0.0.255
deny ip 10.0.5.0 0.0.0.255 172.16.32.0 0.0.0.255
permit ip 10.0.5.0 0.0.0.255 any
!
route-map NO_NAT_FLIN permit 10
match ip address FLIN_TO_XXXXX
!
!
control-plane
!
banner login ^C
**************************************
WARNING: UNAUTHORISED ACCESS PROHIBITED.
LOG OUT IMMEDIATELY.
**************************************
^C
!
line con 0
exec-timeout 60 0
logging synchronous
no modem enable
line aux 0
line vty 0 4
access-class SSH_IN in
exec-timeout 30 0
logging synchronous
login local
!
scheduler max-task-time 5000
end