Ok, So, relatively new to Cisco hardware here (yes, laugh now ;-) ) but I'm not new to networking or it's concepts!
I bought an 851W and factory defaulted the system using:
router(config)# config-register 0x2102
router#write erase
router#reload
And this did a great job, totally factory default!
So much so it's now just a router with nothing but console access!!
So, I start to config the router (by terminal) to try
to get it up and running so I can access it using SDM 2.5
to do the nitty-gritty.
(I fugue I should really learn this CLI stuff and not
rely on a Web GUI cause I'm gonna need CLI some day again)
SO.. With that all said..
Here is the problem:
1) I cannot get the router to issue LAN clients ip addresses via DHCP.
I have extrapolated my configuration for others that have observed on the net, keeping in mind, this is my 1st!.
Can anyone tell me were I went wrong and what I need
to fix to get DHCP up so i can run the SDM application??
Current configuration : 3403 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 ** removed (by markelbcm) for security **
enable password ** removed (by markelbcm) for security **
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2942469495
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2942469495
revocation-check none
rsakeypair TP-self-signed-2942469495
!
!
crypto pki certificate chain TP-self-signed-2942469495
certificate self-signed 01
3082023E ** removed (by markelbcm) for security ** ED653672 82F5
quit
dot11 syslog
no ip subnet-zero
no ip routing
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.100.1 192.168.100.20
!
ip dhcp pool LAN
import all
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
!
!
no ip cef
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
username rooty privilege 15 secret 5 ** removed (by markelbcm) for security **
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
ip address dhcp
no ip route-cache
shutdown
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
no ip address
no ip route-cache
shutdown
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 192.168.100.1 255.255.255.0
ip access-group 100 in
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
snmp-server community public RO
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
password vterm
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end
Thank you all! I think (also) I got the https server
running - I'm assuming that with it running, the SDM 2.5 setup/running (from CD or Flash) will 'just work'. I also conformed the SDM files are on the flash memory..
Thanks!
Jason
I bought an 851W and factory defaulted the system using:
router(config)# config-register 0x2102
router#write erase
router#reload
And this did a great job, totally factory default!
So much so it's now just a router with nothing but console access!!
So, I start to config the router (by terminal) to try
to get it up and running so I can access it using SDM 2.5
to do the nitty-gritty.
(I fugue I should really learn this CLI stuff and not
rely on a Web GUI cause I'm gonna need CLI some day again)
SO.. With that all said..
Here is the problem:
1) I cannot get the router to issue LAN clients ip addresses via DHCP.
I have extrapolated my configuration for others that have observed on the net, keeping in mind, this is my 1st!.
Can anyone tell me were I went wrong and what I need
to fix to get DHCP up so i can run the SDM application??
Current configuration : 3403 bytes
!
version 12.4
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
enable secret 5 ** removed (by markelbcm) for security **
enable password ** removed (by markelbcm) for security **
!
no aaa new-model
!
crypto pki trustpoint TP-self-signed-2942469495
enrollment selfsigned
subject-name cn=IOS-Self-Signed-Certificate-2942469495
revocation-check none
rsakeypair TP-self-signed-2942469495
!
!
crypto pki certificate chain TP-self-signed-2942469495
certificate self-signed 01
3082023E ** removed (by markelbcm) for security ** ED653672 82F5
quit
dot11 syslog
no ip subnet-zero
no ip routing
no ip dhcp use vrf connected
ip dhcp excluded-address 192.168.100.1 192.168.100.20
!
ip dhcp pool LAN
import all
network 192.168.100.0 255.255.255.0
default-router 192.168.100.1
!
!
no ip cef
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
username rooty privilege 15 secret 5 ** removed (by markelbcm) for security **
!
!
archive
log config
hidekeys
!
!
!
bridge irb
!
!
interface FastEthernet0
!
interface FastEthernet1
shutdown
!
interface FastEthernet2
shutdown
!
interface FastEthernet3
shutdown
!
interface FastEthernet4
ip address dhcp
no ip route-cache
shutdown
duplex auto
speed auto
!
interface Dot11Radio0
no ip address
no ip route-cache
shutdown
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Vlan1
no ip address
no ip route-cache
shutdown
bridge-group 1
bridge-group 1 spanning-disabled
!
interface BVI1
ip address 192.168.100.1 255.255.255.0
ip access-group 100 in
ip nat inside
ip virtual-reassembly
!
ip forward-protocol nd
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
snmp-server community public RO
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
privilege level 15
password vterm
login local
transport input telnet ssh
!
scheduler max-task-time 5000
end
Thank you all! I think (also) I got the https server
running - I'm assuming that with it running, the SDM 2.5 setup/running (from CD or Flash) will 'just work'. I also conformed the SDM files are on the flash memory..
Thanks!
Jason