directlyconnected
Technical User
I've been at this all day, trying different things. Here's the output of sh run, deb ppp authentication and debug ppp negotiation. I notice that it fails to negotiate with peer (is that me?), but I cannot figure out why. Help!!!
sh run
Building configuration...
Current configuration : 1766 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Hudson
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
ip subnet-zero
!
!
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool Hudson
import all
network 10.0.0.0 255.0.0.0
dns-server 10.0.0.1
!
!
ip cef
ip name-server 68.94.156.1
ip name-server 68.94.157.1
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
ip address 10.0.0.1 255.0.0.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 0/35
oam-pvc manage
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
shutdown
dialer pool 1
ppp authentication chap
ppp chap hostname (username)
ppp chap password 0 (password)
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
no login
transport input telnet
!
scheduler max-task-time 5000
end
Now here's ppp authentication...
debug ppp authenticatio
*Nov 28 02:11:53.659: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
*Nov 28 02:11:53.671: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 02:11:53.791: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0n
*Nov 28 02:11:53.795: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
PPP authentication debugging is on
Hudson#
*Nov 28 02:12:15.963: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
*Nov 28 02:12:15.971: Vi1 PPP: Using dialer call direction
*Nov 28 02:12:15.971: Vi1 PPP: Treating connection as a callout
*Nov 28 02:12:15.971: Vi1 PPP: Authorization required
*Nov 28 02:12:15.975: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 02:12:16.087: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
*Nov 28 02:12:16.091: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 02:12:38.343: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
*Nov 28 02:12:38.343: Vi1 PPP: Using dialer call direction
*Nov 28 02:12:38.343: Vi1 PPP: Treating connection as a callout
*Nov 28 02:12:38.347: Vi1 PPP: Authorization required
*Nov 28 02:12:38.347: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 02:12:38.463: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
*Nov 28 02:12:38.471: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
And finally ppp negotiation (actually, lack thereof!)
Hudson#debug ppp neg
Hudson#debug ppp negotiation
PPP protocol negotiation debugging is on
Hudson#
*Nov 28 02:14:07.567: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
*Nov 28 02:14:07.567: Vi1 PPP: Phase is DOWN, Setup
*Nov 28 02:14:07.567: Vi1 PPP: Using dialer call direction
*Nov 28 02:14:07.567: Vi1 PPP: Treating connection as a callout
*Nov 28 02:14:07.567: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Nov 28 02:14:07.567: Vi1 LCP: O CONFREQ [Closed] id 1 len 15
*Nov 28 02:14:07.571: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.571: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.571: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 02:14:07.583: Vi1 LCP: I CONFREJ [REQsent] id 1 len 9
*Nov 28 02:14:07.587: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.587: Vi1 LCP: O CONFREQ [REQsent] id 2 len 15
*Nov 28 02:14:07.587: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.587: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.603: Vi1 LCP: I CONFREJ [REQsent] id 2 len 9
*Nov 28 02:14:07.603: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.603: Vi1 LCP: O CONFREQ [REQsent] id 3 len 15
*Nov 28 02:14:07.603: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.603: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.615: Vi1 LCP: I CONFREJ [REQsent] id 3 len 9
*Nov 28 02:14:07.615: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.615: Vi1 LCP: O CONFREQ [REQsent] id 4 len 15
*Nov 28 02:14:07.619: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.619: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.631: Vi1 LCP: I CONFREJ [REQsent] id 4 len 9
*Nov 28 02:14:07.631: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.631: Vi1 LCP: O CONFREQ [REQsent] id 5 len 15
*Nov 28 02:14:07.631: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.635: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.647: Vi1 LCP: I CONFREJ [REQsent] id 5 len 9
*Nov 28 02:14:07.647: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.647: Vi1 LCP: O CONFREQ [REQsent] id 6 len 15
*Nov 28 02:14:07.647: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.647: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.663: Vi1 LCP: I CONFREJ [REQsent] id 6 len 9
*Nov 28 02:14:07.663: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.663: Vi1 LCP: O CONFREQ [REQsent] id 7 len 15
*Nov 28 02:14:07.663: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.663: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.679: Vi1 LCP: I CONFREJ [REQsent] id 7 len 9
*Nov 28 02:14:07.679: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.679: Vi1 LCP: O CONFREQ [REQsent] id 8 len 15
*Nov 28 02:14:07.679: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.679: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.691: Vi1 LCP: I CONFREJ [REQsent] id 8 len 9
*Nov 28 02:14:07.691: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.695: Vi1 LCP: O CONFREQ [REQsent] id 9 len 15
*Nov 28 02:14:07.695: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.695: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.707: Vi1 LCP: I CONFREJ [REQsent] id 9 len 9
*Nov 28 02:14:07.707: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.707: Vi1 LCP: O CONFREQ [REQsent] id 10 len 15
*Nov 28 02:14:07.707: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.707: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.727: Vi1 LCP: I CONFREJ [REQsent] id 10 len 9
*Nov 28 02:14:07.727: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.727: Vi1 LCP: Failed to negotiate with peer
*Nov 28 02:14:07.727: Vi1 PPP: Sending Acct Event[Down] id[16]
*Nov 28 02:14:07.727: Vi1 LCP: State is Closed
*Nov 28 02:14:07.727: Vi1 PPP: Phase is DOWN
*Nov 28 02:14:07.727: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
*Nov 28 02:14:07.731: Vi1 PPP: Block vaccess from being freed [0x40]
*Nov 28 02:14:07.731: Vi1 PPP: Unlocked by [0x40] Still Locked by [0x0]
*Nov 28 02:14:07.735: Vi1 PPP: Free previously blocked vaccess
*Nov 28 02:14:07.735: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
Long post, I know---any ideas???
sh run
Building configuration...
Current configuration : 1766 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Hudson
!
boot-start-marker
boot-end-marker
!
logging buffered 51200 warnings
!
no aaa new-model
ip subnet-zero
!
!
ip dhcp excluded-address 10.0.0.1
!
ip dhcp pool Hudson
import all
network 10.0.0.0 255.0.0.0
dns-server 10.0.0.1
!
!
ip cef
ip name-server 68.94.156.1
ip name-server 68.94.157.1
ip ips po max-events 100
no ftp-server write-enable
!
!
!
!
!
!
!
interface Ethernet0
ip address 10.0.0.1 255.0.0.0
ip nat inside
ip virtual-reassembly
ip tcp adjust-mss 1412
hold-queue 100 out
!
interface ATM0
no ip address
no atm ilmi-keepalive
dsl operating-mode auto
!
interface ATM0.1 point-to-point
pvc 0/35
oam-pvc manage
pppoe-client dial-pool-number 1
!
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer0
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
shutdown
dialer pool 1
ppp authentication chap
ppp chap hostname (username)
ppp chap password 0 (password)
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer0
!
ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer0 overload
!
access-list 1 permit 10.0.0.0 0.255.255.255
dialer-list 1 protocol ip permit
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
no login
transport input telnet
!
scheduler max-task-time 5000
end
Now here's ppp authentication...
debug ppp authenticatio
*Nov 28 02:11:53.659: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
*Nov 28 02:11:53.671: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 02:11:53.791: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0n
*Nov 28 02:11:53.795: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
PPP authentication debugging is on
Hudson#
*Nov 28 02:12:15.963: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
*Nov 28 02:12:15.971: Vi1 PPP: Using dialer call direction
*Nov 28 02:12:15.971: Vi1 PPP: Treating connection as a callout
*Nov 28 02:12:15.971: Vi1 PPP: Authorization required
*Nov 28 02:12:15.975: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 02:12:16.087: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
*Nov 28 02:12:16.091: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
*Nov 28 02:12:38.343: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
*Nov 28 02:12:38.343: Vi1 PPP: Using dialer call direction
*Nov 28 02:12:38.343: Vi1 PPP: Treating connection as a callout
*Nov 28 02:12:38.347: Vi1 PPP: Authorization required
*Nov 28 02:12:38.347: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 02:12:38.463: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
*Nov 28 02:12:38.471: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
And finally ppp negotiation (actually, lack thereof!)
Hudson#debug ppp neg
Hudson#debug ppp negotiation
PPP protocol negotiation debugging is on
Hudson#
*Nov 28 02:14:07.567: %DIALER-6-BIND: Interface Vi1 bound to profile Di0
*Nov 28 02:14:07.567: Vi1 PPP: Phase is DOWN, Setup
*Nov 28 02:14:07.567: Vi1 PPP: Using dialer call direction
*Nov 28 02:14:07.567: Vi1 PPP: Treating connection as a callout
*Nov 28 02:14:07.567: Vi1 PPP: Phase is ESTABLISHING, Active Open
*Nov 28 02:14:07.567: Vi1 LCP: O CONFREQ [Closed] id 1 len 15
*Nov 28 02:14:07.571: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.571: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.571: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to up
*Nov 28 02:14:07.583: Vi1 LCP: I CONFREJ [REQsent] id 1 len 9
*Nov 28 02:14:07.587: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.587: Vi1 LCP: O CONFREQ [REQsent] id 2 len 15
*Nov 28 02:14:07.587: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.587: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.603: Vi1 LCP: I CONFREJ [REQsent] id 2 len 9
*Nov 28 02:14:07.603: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.603: Vi1 LCP: O CONFREQ [REQsent] id 3 len 15
*Nov 28 02:14:07.603: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.603: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.615: Vi1 LCP: I CONFREJ [REQsent] id 3 len 9
*Nov 28 02:14:07.615: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.615: Vi1 LCP: O CONFREQ [REQsent] id 4 len 15
*Nov 28 02:14:07.619: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.619: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.631: Vi1 LCP: I CONFREJ [REQsent] id 4 len 9
*Nov 28 02:14:07.631: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.631: Vi1 LCP: O CONFREQ [REQsent] id 5 len 15
*Nov 28 02:14:07.631: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.635: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.647: Vi1 LCP: I CONFREJ [REQsent] id 5 len 9
*Nov 28 02:14:07.647: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.647: Vi1 LCP: O CONFREQ [REQsent] id 6 len 15
*Nov 28 02:14:07.647: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.647: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.663: Vi1 LCP: I CONFREJ [REQsent] id 6 len 9
*Nov 28 02:14:07.663: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.663: Vi1 LCP: O CONFREQ [REQsent] id 7 len 15
*Nov 28 02:14:07.663: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.663: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.679: Vi1 LCP: I CONFREJ [REQsent] id 7 len 9
*Nov 28 02:14:07.679: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.679: Vi1 LCP: O CONFREQ [REQsent] id 8 len 15
*Nov 28 02:14:07.679: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.679: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.691: Vi1 LCP: I CONFREJ [REQsent] id 8 len 9
*Nov 28 02:14:07.691: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.695: Vi1 LCP: O CONFREQ [REQsent] id 9 len 15
*Nov 28 02:14:07.695: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.695: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.707: Vi1 LCP: I CONFREJ [REQsent] id 9 len 9
*Nov 28 02:14:07.707: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.707: Vi1 LCP: O CONFREQ [REQsent] id 10 len 15
*Nov 28 02:14:07.707: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.707: Vi1 LCP: MagicNumber 0x117E733A (0x0506117E733A)
*Nov 28 02:14:07.727: Vi1 LCP: I CONFREJ [REQsent] id 10 len 9
*Nov 28 02:14:07.727: Vi1 LCP: AuthProto CHAP (0x0305C22305)
*Nov 28 02:14:07.727: Vi1 LCP: Failed to negotiate with peer
*Nov 28 02:14:07.727: Vi1 PPP: Sending Acct Event[Down] id[16]
*Nov 28 02:14:07.727: Vi1 LCP: State is Closed
*Nov 28 02:14:07.727: Vi1 PPP: Phase is DOWN
*Nov 28 02:14:07.727: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di0
*Nov 28 02:14:07.731: Vi1 PPP: Block vaccess from being freed [0x40]
*Nov 28 02:14:07.731: Vi1 PPP: Unlocked by [0x40] Still Locked by [0x0]
*Nov 28 02:14:07.735: Vi1 PPP: Free previously blocked vaccess
*Nov 28 02:14:07.735: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down
Long post, I know---any ideas???