Hi All-
I am a newbie on cisco 831...I've spent days combing the forums and have finally got the router doing basic service via some cli and SDM Express (SDM). I now need to set up NAT port forwarding however I can't do it via SDM because I think when I did some cli configuring I configured some NAT. What do I need to do to re-enable SDM to control NAT config - Here is my config...
Using 2670 out of 131072 bytes
!
! Last configuration change at 13:07:59 PCTime Sat Aug 28 2010
! NVRAM config last updated at 13:08:02 PCTime Sat Aug 28 2010
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname bwsannex
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$HOpq$R1E9LonGX/6UwZNycs1fA1
enable password garfield
!
username admin privilege 15 secret 5 $1$PvwS$rTxDq4P63L5EU00WfI.Iu.
clock timezone PCTime -5
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
no aaa new-model
ip subnet-zero
no ip source-route
no ip routing
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.151 192.168.1.254
!
ip dhcp pool DHCPpoolLan_0
network 10.0.0.0 255.255.255.0
dns-server 192.168.1.100
netbios-name-server 10.1.1.2 10.1.1.3
default-router 10.1.1.1
!
ip dhcp pool bwsannex
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
!
no ip domain lookup
ip ips po max-events 100
no ftp-server write-enable
!
no ip route-cache
duplex auto
no cdp enable
!
no ip route-cache
duplex auto
no cdp enable
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
no cdp enable
!
interface Ethernet1
description internet$ES_WAN$
ip address dhcp
no ip redirects
ip nat outside
ip virtual-reassembly
no ip route-cache
duplex auto
no cdp enable
!interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex full
speed 100
!
interface FastEthernet3
no ip address
duplex full
speed 100
!
interface FastEthernet4
no ip address
duplex full
speed 100
!
ip classless
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip nat inside source list 1 interface Ethernet1 overload
ip nat inside source list 100 interface Ethernet1 overload
ip nat inside source static tcp 192.168.1.100 1600 interface Ethernet1 1600
ip nat inside source static tcp 192.168.1.100 900 interface Ethernet1 900
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 100 remark SDM_ACL Category=2
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
access-list 101 deny tcp any 192.168.1.0 0.0.0.255
access-list 101 permit ip any any
snmp-server community public RO
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
privilege level 15
password sra48192
login local
transport preferred all
transport input telnet ssh
transport output all
!
scheduler max-task-time 5000
end
thank you for you help!
best-
scott
I am a newbie on cisco 831...I've spent days combing the forums and have finally got the router doing basic service via some cli and SDM Express (SDM). I now need to set up NAT port forwarding however I can't do it via SDM because I think when I did some cli configuring I configured some NAT. What do I need to do to re-enable SDM to control NAT config - Here is my config...
Using 2670 out of 131072 bytes
!
! Last configuration change at 13:07:59 PCTime Sat Aug 28 2010
! NVRAM config last updated at 13:08:02 PCTime Sat Aug 28 2010
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname bwsannex
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$HOpq$R1E9LonGX/6UwZNycs1fA1
enable password garfield
!
username admin privilege 15 secret 5 $1$PvwS$rTxDq4P63L5EU00WfI.Iu.
clock timezone PCTime -5
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
no aaa new-model
ip subnet-zero
no ip source-route
no ip routing
!
!
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.151 192.168.1.254
!
ip dhcp pool DHCPpoolLan_0
network 10.0.0.0 255.255.255.0
dns-server 192.168.1.100
netbios-name-server 10.1.1.2 10.1.1.3
default-router 10.1.1.1
!
ip dhcp pool bwsannex
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
!
!
no ip domain lookup
ip ips po max-events 100
no ftp-server write-enable
!
no ip route-cache
duplex auto
no cdp enable
!
no ip route-cache
duplex auto
no cdp enable
!
!
!
!
!
!
!
interface Ethernet0
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly
no ip route-cache
no cdp enable
!
interface Ethernet1
description internet$ES_WAN$
ip address dhcp
no ip redirects
ip nat outside
ip virtual-reassembly
no ip route-cache
duplex auto
no cdp enable
!interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex full
speed 100
!
interface FastEthernet3
no ip address
duplex full
speed 100
!
interface FastEthernet4
no ip address
duplex full
speed 100
!
ip classless
!
ip http server
ip http authentication local
ip http secure-server
ip http timeout-policy idle 600 life 86400 requests 10000
!
ip nat inside source list 1 interface Ethernet1 overload
ip nat inside source list 100 interface Ethernet1 overload
ip nat inside source static tcp 192.168.1.100 1600 interface Ethernet1 1600
ip nat inside source static tcp 192.168.1.100 900 interface Ethernet1 900
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 100 remark SDM_ACL Category=2
access-list 100 permit ip 192.168.1.0 0.0.0.255 any
access-list 101 deny tcp any 192.168.1.0 0.0.0.255
access-list 101 permit ip any any
snmp-server community public RO
!
!
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
control-plane
!
!
line con 0
exec-timeout 0 0
logging synchronous
no modem enable
transport preferred all
transport output all
line aux 0
transport preferred all
transport output all
line vty 0 4
privilege level 15
password sra48192
login local
transport preferred all
transport input telnet ssh
transport output all
!
scheduler max-task-time 5000
end
thank you for you help!
best-
scott