Hi, I have a Cisco 831 (12.2(8r)YN) That im using to EzVpn into my job's concentrator. The tunnel is only used by my Cisco Ip Phone (7960) to reach our CCM.
The problem is that once or twice every day the phone drops its connection to the CCM. Upon further investigation i notice that I no longer can ping IPs on the other side of the VPN. Though i can still access the web.
When checking the log of the router its clear that the router has not noticed that the VPN is down. Rebooting the router / running clear crypto ipsec client solves the problem.
Any ideas / suggestions are appreciated.
Relevant parts of the config:
ip dhcp pool LAN
network xxxx xxxx
next-server xxx
default-router xxx
dns-server xxx
lease 7
!
!
no ip domain lookup
ip domain name xxxx
no ip bootp server
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
crypto isakmp keepalive 10 periodic
!
!
!
!
!
crypto ipsec client ezvpn lab-ipphone
connect auto
group yyyy key xxxxxxxxxx
mode network-extension
peer xxxxxxx
username xxxxx password xxxxxxx
!
!
!
!
interface Ethernet0
description *** LAN ***
ip address xxxxx xxxxxx
no ip proxy-arp
ip tcp adjust-mss 1452
no cdp enable
crypto ipsec client ezvpn lab-ipphone inside
hold-queue 100 out
!
interface Ethernet1
description *** Internet Interface ***
bandwidth 256
no ip address
duplex auto
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
description DSL
bandwidth 256
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username xxxxxxx password 7 xxxxxxxx
crypto ipsec client ezvpn lab-ipphone
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route xxx 255.255.0.0 Dialer1
ip route xxx 255.255.255.128 Dialer1
ip route xxx 255.255.255.255 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 102 interface Dialer1 overload
!
!
access-list 102 permit ip xxxxxx 0.0.0.15 any
dialer-list 1 protocol ip permit
no cdp run
!
!
control-plane
The problem is that once or twice every day the phone drops its connection to the CCM. Upon further investigation i notice that I no longer can ping IPs on the other side of the VPN. Though i can still access the web.
When checking the log of the router its clear that the router has not noticed that the VPN is down. Rebooting the router / running clear crypto ipsec client solves the problem.
Any ideas / suggestions are appreciated.
Relevant parts of the config:
ip dhcp pool LAN
network xxxx xxxx
next-server xxx
default-router xxx
dns-server xxx
lease 7
!
!
no ip domain lookup
ip domain name xxxx
no ip bootp server
ip audit notify log
ip audit po max-events 100
no ftp-server write-enable
!
!
!
!
crypto isakmp keepalive 10 periodic
!
!
!
!
!
crypto ipsec client ezvpn lab-ipphone
connect auto
group yyyy key xxxxxxxxxx
mode network-extension
peer xxxxxxx
username xxxxx password xxxxxxx
!
!
!
!
interface Ethernet0
description *** LAN ***
ip address xxxxx xxxxxx
no ip proxy-arp
ip tcp adjust-mss 1452
no cdp enable
crypto ipsec client ezvpn lab-ipphone inside
hold-queue 100 out
!
interface Ethernet1
description *** Internet Interface ***
bandwidth 256
no ip address
duplex auto
pppoe enable
pppoe-client dial-pool-number 1
no cdp enable
!
interface FastEthernet1
no ip address
duplex auto
speed auto
!
interface FastEthernet2
no ip address
duplex auto
speed auto
!
interface FastEthernet3
no ip address
duplex auto
speed auto
!
interface FastEthernet4
no ip address
duplex auto
speed auto
!
interface Dialer1
description DSL
bandwidth 256
ip address negotiated
no ip redirects
no ip unreachables
no ip proxy-arp
ip mtu 1492
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication pap callin
ppp pap sent-username xxxxxxx password 7 xxxxxxxx
crypto ipsec client ezvpn lab-ipphone
!
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip route xxx 255.255.0.0 Dialer1
ip route xxx 255.255.255.128 Dialer1
ip route xxx 255.255.255.255 Dialer1
!
no ip http server
no ip http secure-server
ip nat inside source list 102 interface Dialer1 overload
!
!
access-list 102 permit ip xxxxxx 0.0.0.15 any
dialer-list 1 protocol ip permit
no cdp run
!
!
control-plane