Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Cisco 827 ADSL Configuration Help, lost carrier. Transceiver problem?

Status
Not open for further replies.

cherisc

ISP
Dec 9, 2004
71
0
0
US
When this router is hooked up to the DSL line, we can't get past the router. I have a little experience with Cisco's, but none with configuring them for DSL. Any Suggestions?

Here is my Current configuration:
!
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
enable secret 5 .
!
username XXX password 0 xxxxxxxxxxx
!
!
!
!
ip subnet-zero
no ip finger
ip name-server xxx.xxx.xxx.xxx
ip name-server xxx.xxx.xxx.xxx
!
ip dhcp pool CLIENT
import all
network 192.168.0.0 255.255.255.0
default-router 192.168.0.52
!
!
!
!
interface Ethernet0
ip address 192.168.0.52 255.255.255.0
no ip directed-broadcast
ip nat inside
no ip mroute-cache
!
interface ATM0
no ip address
no ip directed-broadcast
ip nat outside
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/35
!
pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
bundle-enable
hold-queue 224 in
!
interface Dialer0
ip address negotiated
no ip directed-broadcast
ip nat outside
encapsulation ppp
dialer pool 1
!
interface Dialer1
ip address negotiated
no ip directed-broadcast
ip mtu 1492
ip nat outside
encapsulation ppp
dialer remote-name redback
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname xxxxxxxx
ppp pap sent-username xxxxxxxx password x xxxxxxxxxxxxxxxxxx
ppp ipcp dns request
ppp ipcp wins request
!
ip nat inside source list 1 interface Dialer0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server
!
access-list 1 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit
!
line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
length 0
!
scheduler max-task-time 5000

I am receiving this Error frequently:
00:28:14: %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

When this router is hooked up to the DSL line, we can't get past the router. I have a little experience with Cisco's, but none with configuring them for DSL. Any Suggestions?
 
I am going tomorrow to use the following configuration on the Cisco 827 ADSL Router with IOS Version 12.1, any suggestions?


no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption

hostname Router

enable secret x xxxxxxxxxxxxxxxxxxxxxxxxxxxxx.

username xxx password 0 xxxxxxxxxxx

ip subnet-zero
no ip finger
ip name-server xxx.xxx.xxx.xxx
ip name-server xxx.xxx.xxx.xxx

ip dhcp pool CLIENT
import all
network 192.168.0.0 255.255.255.0
default-router 192.168.0.52

interface Ethernet0
ip address 192.168.0.52 255.255.255.0
no ip directed-broadcast
ip nat inside
no ip mroute-cache

interface ATM0
no ip address
no ip directed-broadcast
ip nat outside
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/35
protocol pppoe

pvc 8/35
encapsulation pppoe
dialer pool-member 1

bundle-enable
hold-queue 224 in

no interface Dialer0

interface Dialer1
ip address negotiated
no ip directed-broadcast
ip mtu 1492
ip nat outside
encapsulation ppp
no dialer remote-name
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname xxxxxxxx
ppp chap password xxxxxxxx
ppp pap sent-username xxxxxxxx password xxxxxxxx
ppp ipcp dns request
ppp ipcp wins request

ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
ip http server

access-list 1 permit ip 192.168.0.0 0.0.0.255 any
dialer-list 1 protocol ip permit

line con 0
exec-timeout 120 0
transport input none
stopbits 1
line vty 0 4
exec-timeout 0 0
login local
length 0
 
You need to know if the router is seeing the ADSL signal. Use the command "sh dsl int atm0" to check. If that's all good then try a ping from the router to some remote IP address.

Chris.


**********************
Chris A.C, CCNA, CCSA
**********************
 
Check your ADSL line connection. I was getting this last year and changing the cable fixed this. Let me know how this goes. I may have some old configs you can look at.



Eric - A+, Net+, INet+ CCNA next week.
Network Admin/Helpdesk II
 
Thank you ChrisAC. I did try to ping a remote ip and did not get an answer, and DNS is not working. I reverted back to the old Westell Modem for now, tomorrow I'm going to attempt this again. I'll let you know how it goes.

In the mean time, can someone explain to me what the command "dialer remote-name redback" means? I have an idea what "dialer remote-name" means, but I'm confused to why so many configurations use the name "redback".

Another question, Should the PAP and CHAP username and passwords be the same one that was issued by our ISP?

One more question: It appears that we have version 12.1. Are there free upgrades that we can get? I notice that some commands do not work that other people have posted on the Internet for this setup.

Thanks in advance...
 
OK, Here's the deal.

I had the router up, and I turned on the debug dialer command. I am getting the error: cannot place call no dialer string set. Please help!! It shouldn't need a dialer string!! I'll post the config shortly.
 
Current configuration:

version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption

hostname Router

enable secret x xxxxxxxxxxxxxxxxxxxxxxxxxxxxx.

ip subnet-zero
ip name-server xxx.xxx.xxx.xxx
ip name-server xxx.xxx.xxx.xxx
ip dhcp excluded-address 192.168.0.52
ip dhcp excluded-address 192.168.0.32

ip dhcp pool CLIENT
import all
network 192.168.0.0 255.255.255.0
default-router 192.168.0.52


interface Ethernet0
ip address 192.168.0.52 255.255.255.0
no ip directed-broadcast
ip nat inside
no ip mroute-cache

interface ATM0
no ip address
no ip directed-broadcast
ip nat outside
no ip mroute-cache
no atm ilmi-keepalive
pvc 0/35

pvc 8/35
dialer pool-member 1
protocol ppp dialer
dialer pool-member 1

bundle-enable
hold-queue 224 in

interface Dialer1
ip address negotiated
no ip directed-broadcast
ip mtu 1492
ip nat outside
encapsulation ppp
dialer remote-name redback
dialer pool 1
dialer-group 1
ppp authentication pap chap callin
ppp chap hostname xxxxxxxx
ppp chap password x xxxxxxxxxxxxxxxxxx
ppp ipcp dns request
ppp ipcp wins request

ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server

access-list 1 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit

line con 0
transport input none
stopbits 1
line vty 0 4
login

scheduler max-task-time 5000
end
 
Can I recommend the following changes:

interface ATM0
no ip nat outside
no pvc 0/35
pvc 8/35
encapsulation aal5mux ppp dialer

interface Dialer1
no dialer remote-name redback
ppp authentication chap



Get your config looking something like:

version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption

hostname Router

enable secret x xxxxxxxxxxxxxxxxxxxxxxxxxxxxx.

ip subnet-zero
ip name-server xxx.xxx.xxx.xxx
ip name-server xxx.xxx.xxx.xxx
ip dhcp excluded-address 192.168.0.52
ip dhcp excluded-address 192.168.0.32

ip dhcp pool CLIENT
import all
network 192.168.0.0 255.255.255.0
default-router 192.168.0.52


interface Ethernet0
ip address 192.168.0.52 255.255.255.0
no ip directed-broadcast
ip nat inside
no ip mroute-cache

interface ATM0
no ip address
no ip directed-broadcast
no ip mroute-cache
no atm ilmi-keepalive

pvc 8/35
encapsulation aal5mux ppp dialer
dialer pool-member 1

bundle-enable
hold-queue 224 in

interface Dialer1
ip address negotiated
no ip directed-broadcast
ip mtu 1492
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap
ppp chap hostname xxxxxxxx
ppp chap password x xxxxxxxxxxxxxxxxxx
ppp ipcp dns request
ppp ipcp wins request

ip nat inside source list 1 interface Dialer1 overload
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
no ip http server

access-list 1 permit 192.168.0.0 0.0.0.255
dialer-list 1 protocol ip permit

line con 0
transport input none
stopbits 1
line vty 0 4
login

scheduler max-task-time 5000
end
 
I made the changes that KiscoKid suggested with no success. My configuration looks exactly like the one above and I am getting the same errors with the debug dialer turned on. I also tried using the cable that shipped with the router, and that made no difference.

I found this on the Cisco web site: I will try to get a crossover cable made or purchased. It's worth a try.

Any other suggestions would be very helpful. I copied the show interface and show ver commands, but I left the floppy on site. I will try to post them in the morning.

Thanks.
 
What result do you get from a "sh dsl int atm0"? If it's trained up then it's not a cable problem.

Chris.

**********************
Chris A.C, CCNA, CCSA
**********************
 
When I try to issue the "show dsl ..." command, it says the dsl part is invalid. When I try to ping a remote IP address from the router, it gets no response. When debug dialer is on, it says "cannot place call no dialer string set" each time something like a ping tries to get out of the dsl interface.
 
Here is a show ver:

Cisco Internetwork Operating System Software
IOS (tm) C827 Software (C827-Y6-M), Version 12.1(1)XB, EARLY DEPLOYMENT RELEASE SOFTWARE (fc1)
Copyright (c) 1986-2000 by cisco Systems, Inc.
Compiled Mon 10-Apr-00 13:21 by phanguye
Image text-base: 0x80013170, data-base: 0x805699A8

ROM: System Bootstrap, Version 12.1(1r)XB1, RELEASE SOFTWARE (fc1)

Cisco827 uptime is 27 minutes
System returned to ROM by power-on
System image file is "flash:c827-y6-mz.121-1.XB"

CISCO C827 (MPC855T) processor (revision 0x501) with 15360K/1024K bytes of memory.
Processor board ID JAD04400G5K (724114576), with hardware revision 0000
CPU rev number 5
Bridging software.
1 Ethernet/IEEE 802.3 interface(s)
1 ATM network interface(s)
128K bytes of non-volatile configuration memory.
8192K bytes of processor board System flash (Read/Write)

 
Do a "sh ip int brief" and post the results.

Chris.

**********************
Chris A.C, CCNA, CCSA
**********************
 
I doubt that IOS image supports what you are trying to do. I just hopped into Cisco Software Advisor and to support the features you are intereted in (Dialer Profiles, NAT and PPPoA etc), Cisco is citing a minimum of 12.2(13).

Do you have a Smartnet agreement with Cisco to perform an IOS upgrade?
 
This indicates there is a problem with the ethernet port...

00:28:14: %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?


The ADSL configuration I use:

interface ATM0
no ip address
load-interval 30
no atm ilmi-keepalive
bundle-enable
dsl operating-mode auto
!
interface ATM0.38 point-to-point
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
interface Dialer1
ip address negotiated
ip nat outside
encapsulation ppp
dialer pool 1
dialer-group 1
ppp authentication chap pap callin
ppp chap hostname my-account@isp.com
ppp chap password my-password
!
ip route 0.0.0.0 0.0.0.0 Dialer1
!
dialer-list 1 protocol ip permit


I have some ACL's and Firewall features configured but to get the ADSL line up that is all you should need.

HTH

Andy
 
The "00:28:14: %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?" error only occurs if I physically disconnect the dsl line from the cisco. I'm faced with the problem of getting the adsl line to communicate with the ISP. I still get the "cannot place call no dialer string set" error with debug dialer turned on. The ISP is no help, they will only support their own issued modems (and I'm about to purchase one of their modems and a different firewall).

I did try to use the Cisco Quick Start CD that came with the Router. That was able to communicate with the Router, send commands to it, then I lost the connection. The Quick Start program changed the enable secret password and I couldn't find the password in the documentation. With the Quick Start, it only asked for the VPI/VCI numbers and username and password for the DSL. It configured the Router IP address to 10.0.0.1. I just could not communicate with it after that. I had to reset the password and try again with the command line. I gave up on using that program.

I'm at the end of the line, I'm thinking about selling the thing on ebay.

We do not have a Smartnet agreement with Cisco and we do not intend to purchase one (it would be cheaper to get an ISP issued modem and a different hardware firewall).

Before I do that, I would like to give this another try. I plan to try again on Tuesday.

I'm still open for more suggesions.

Thanks in advance.
 
I think that without an IOS upgrade you're not going to get this working.

Chris.

**********************
Chris A.C, CCNA, CCSA
**********************
 
I have purchased a smartnet agreement. I am going to attempt to upgrade the IOS after I get the agreement. I have never upgraded a cisco router, and any suggestions would be great. I will keep posted on how that goes and I'll let everyone know when I get the router working.

Thank you
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top