Phobos1821
MIS
I have three vlans on the switches in our network.
Vlans
1 (10.0.0.0/24)
10 (192.168.1.0/24)
20 (192.168.2.0/24)
The 3750 has ip routing enabled, and vlan interfaces with ip addresses to route traffic. All traffic is allowed between all VLANS. I want to restrict VLAN1 from all but a few management PC's (Mainly due to being able to telnet / ssh / http into the switches) to protect them from tampering. I attempted to create a simple ACL, and throw it on the VLAN1's interface inbound to prevent the traffic. This denys ALL traffic whatsoever.
Here's the confusing part. If i put the same ACL on the OUBOUND interface of VLAN1, it works. It restricts traffic to all but my specified computers. My only problem here is bandwidth loss. It allows a half communication all the way to the device, and almost all the way back before filtering it. Anybody have any ideas?
Here is the sample config.
SHO IP ROUTE
Gateway of last resort is 192.168.1.1 to network 0.0.0.0
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Vlan1
C 192.168.1.0/24 is directly connected, Vlan10
C 192.168.2.0/24 is directly connected, Vlan20
S* 0.0.0.0/0 [1/0] via 192.168.1.1
CONFIG
!
interface Vlan1
ip address 10.0.0.2 255.255.255.0
ip access-group 101 in
ip access-group 1 out
end
interface Vlan10
ip address 192.168.1.2 255.255.255.0
end
!
interface Vlan20
ip address 192.168.2.2 255.255.255.0
ip helper-address 192.168.1.68
ip helper-address 192.168.1.67
end
access-list 1 permit 192.168.1.67
access-list 1 permit 192.168.1.89
access-list 1 permit 192.168.1.41
access-list 1 permit 192.168.1.45
access-list 1 permit 192.168.1.58
access-list 1 permit 192.168.1.30
Vlans
1 (10.0.0.0/24)
10 (192.168.1.0/24)
20 (192.168.2.0/24)
The 3750 has ip routing enabled, and vlan interfaces with ip addresses to route traffic. All traffic is allowed between all VLANS. I want to restrict VLAN1 from all but a few management PC's (Mainly due to being able to telnet / ssh / http into the switches) to protect them from tampering. I attempted to create a simple ACL, and throw it on the VLAN1's interface inbound to prevent the traffic. This denys ALL traffic whatsoever.
Here's the confusing part. If i put the same ACL on the OUBOUND interface of VLAN1, it works. It restricts traffic to all but my specified computers. My only problem here is bandwidth loss. It allows a half communication all the way to the device, and almost all the way back before filtering it. Anybody have any ideas?
Here is the sample config.
SHO IP ROUTE
Gateway of last resort is 192.168.1.1 to network 0.0.0.0
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Vlan1
C 192.168.1.0/24 is directly connected, Vlan10
C 192.168.2.0/24 is directly connected, Vlan20
S* 0.0.0.0/0 [1/0] via 192.168.1.1
CONFIG
!
interface Vlan1
ip address 10.0.0.2 255.255.255.0
ip access-group 101 in
ip access-group 1 out
end
interface Vlan10
ip address 192.168.1.2 255.255.255.0
end
!
interface Vlan20
ip address 192.168.2.2 255.255.255.0
ip helper-address 192.168.1.68
ip helper-address 192.168.1.67
end
access-list 1 permit 192.168.1.67
access-list 1 permit 192.168.1.89
access-list 1 permit 192.168.1.41
access-list 1 permit 192.168.1.45
access-list 1 permit 192.168.1.58
access-list 1 permit 192.168.1.30