Hello all, once again I've managed to hit a road block and this is gonna be a pain to explain.
I just added a Cisco 3640 to my home lab and now I'm trying to get my lab on the internet for test purposes. But I seem to be having problems getting everything working properly. Hers the setup ..
DSL modem....3640 f0
3640 s0....cisco 2620 (this is providing the trunking for VLAN
2620 f0....Cisco 2924 switch----vlans
OK, so the dsl modem is proving DHCP to fo on the router, so i got that set up. s0 on the 3640 is going to s0 on the 2620 and i got the switch connected to the f0. THe fact that the internet is DHCP makes this a little more difficult
I need help config this thing with dns and nat or whatever. I have a windows server with DNS on one of the VLANS. the hosts can ping the server fine but since the server cant get to the internet to resolve dns, nothing is working although i can ping websites ONLY from the 3640.
3640 SHOW
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco3640
!
logging rate-limit console 10 except errors
enable secret
!
ip subnet-zero
!
!
no ip finger
ip name-server 192.168.1.4
ip name-server 71.x.x.x
ip name-server 76.x.x.x
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.0
ip nat inside
encapsulation ppp
service-module t1 clock source internal
service-module t1 timeslots 1-24
!
router rip
network 10.0.0.0
network 74.0.0.0
!
ip nat inside source list 7 interface FastEthernet0/0 overload
ip classless
no ip http server
!
access-list 7 permit 10.1.1.1
access-list 7 permit any
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
----------------------------------------------------------
Cisco3640#
2620 SHOW
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco2600
!
enable secret
enable password
!
!
!
!
!
ip subnet-zero
ip domain-name Home.local
ip name-server 192.168.1.4
!
!
!
!
!
gateway
!
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
encapsulation ppp
service-module t1 timeslots 1-24
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
network 192.168.10.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
line 33 48
line aux 0
line vty 0 4
password
login
!
ntp clock-period 17180634
ntp server 192.168.1.4
end
Cisco2600#
I just added a Cisco 3640 to my home lab and now I'm trying to get my lab on the internet for test purposes. But I seem to be having problems getting everything working properly. Hers the setup ..
DSL modem....3640 f0
3640 s0....cisco 2620 (this is providing the trunking for VLAN
2620 f0....Cisco 2924 switch----vlans
OK, so the dsl modem is proving DHCP to fo on the router, so i got that set up. s0 on the 3640 is going to s0 on the 2620 and i got the switch connected to the f0. THe fact that the internet is DHCP makes this a little more difficult
I need help config this thing with dns and nat or whatever. I have a windows server with DNS on one of the VLANS. the hosts can ping the server fine but since the server cant get to the internet to resolve dns, nothing is working although i can ping websites ONLY from the 3640.
3640 SHOW
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname Cisco3640
!
logging rate-limit console 10 except errors
enable secret
!
ip subnet-zero
!
!
no ip finger
ip name-server 192.168.1.4
ip name-server 71.x.x.x
ip name-server 76.x.x.x
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
duplex auto
speed auto
!
interface Serial0/0
ip address 10.1.1.1 255.255.255.0
ip nat inside
encapsulation ppp
service-module t1 clock source internal
service-module t1 timeslots 1-24
!
router rip
network 10.0.0.0
network 74.0.0.0
!
ip nat inside source list 7 interface FastEthernet0/0 overload
ip classless
no ip http server
!
access-list 7 permit 10.1.1.1
access-list 7 permit any
!
line con 0
transport input none
line aux 0
line vty 0 4
login
!
end
----------------------------------------------------------
Cisco3640#
2620 SHOW
version 12.1
no service single-slot-reload-enable
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Cisco2600
!
enable secret
enable password
!
!
!
!
!
ip subnet-zero
ip domain-name Home.local
ip name-server 192.168.1.4
!
!
!
!
!
gateway
!
!
interface FastEthernet0/0
ip address 192.168.1.2 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.2
encapsulation dot1Q 2
ip address 192.168.2.1 255.255.255.0
!
interface FastEthernet0/0.3
encapsulation dot1Q 3
ip address 192.168.3.1 255.255.255.0
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface Serial0/0
ip address 10.1.1.2 255.255.255.0
encapsulation ppp
service-module t1 timeslots 1-24
!
router rip
version 2
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
network 192.168.10.0
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.1.1.1
ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
!
line con 0
line 33 48
line aux 0
line vty 0 4
password
login
!
ntp clock-period 17180634
ntp server 192.168.1.4
end
Cisco2600#