Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Westi on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Cisco 3550 mls qos trust cos question

Status
Not open for further replies.

joopdog

MIS
Jun 30, 2002
28
US
We've just installed a new IP phone system (Panasonic)

I created a new VLAN, VLAN 11. The subnet is 192.168.11.0/24.
I created the Vlan on our Cisco 3550 switch.

! Cisco 3550 - Vlan on Ports 16, 17, 18
config t
int range f0/16 - 18
description New Panasonic Phone System
switchport access vlan 11
switchport mode access


! Cisco 3550 - Creates Trunk Ports on 19, 20, 21
config t
int range f0/19 - 21
description VLAN TRUNKs
switchport trunk encapsulation dot1q
switchport mode trunk

I can ping all Vlans, and all nodes. IP Routing is enabled.

The 3550 switch is trunked to our Cisco SLM224P switch.
I configured the SLM224P switch to tag the Vlans. It's working.

I also have two other Vlans.

Everything works. All voice traffic is getting to the PBX.

How do I enable or use Qos in the Cisco 3550 switch?

I was thinking of the following:
mls qos trust cos
auto qos voip trust



! Cisco 3550 - Vlan on Ports 16, 17, 18
config t
int range f0/16 - 18
description New Panasonic Phone System
switchport access vlan 11
mls qos trust cos
switchport mode access


! Cisco 3550 - Creates Trunk Ports on 19, 20, 21
config t
int range f0/19 - 21
description VLAN TRUNKs
switchport trunk encapsulation dot1q
mls qos trust cos
auto qos voip trust

switchport mode trunk

Will this work?

Any help would be appreciated.

Thanks

 
you need to enable qos globally so be sure to be in priv mode and enter mls qos. your config that you posted looks fine, just be sure to add the auto qos voip trust on the access ports also and not just the trunk ports.

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
Sh run
interface FastEthernet0/16
description New Panasonic Phone System
switchport access vlan 11
switchport mode access
mls qos trust cos
auto qos voip trust
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
!
interface FastEthernet0/17
description New Panasonic Phone System
switchport access vlan 11
switchport mode access
mls qos trust cos
auto qos voip trust
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
!
interface FastEthernet0/18
description New Panasonic Phone System
switchport access vlan 11
switchport mode access
mls qos trust cos
auto qos voip trust
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
!
interface FastEthernet0/19
description VLAN TRUNKs
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mls qos trust cos
auto qos voip trust
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
!
interface FastEthernet0/20
description VLAN TRUNKs
switchport trunk encapsulation dot1q
switchport mode trunk
mls qos trust cos
auto qos voip trust
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
!
interface FastEthernet0/21
description VLAN TRUNKs
switchport trunk encapsulation dot1q
switchport mode trunk
mls qos trust cos
auto qos voip trust
wrr-queue bandwidth 10 20 70 1
wrr-queue min-reserve 1 5
wrr-queue min-reserve 2 6
wrr-queue min-reserve 3 7
wrr-queue min-reserve 4 8
wrr-queue cos-map 1 0 1
wrr-queue cos-map 2 2 4
wrr-queue cos-map 3 3 6 7
wrr-queue cos-map 4 5
priority-queue out
!

==--=====----=-=-=-----=====--==

 
What about the use of...
switchport nonegotiate

Any problems using this command?

Will this help improve voice network?

Any help would be appreciated.

Thanks
 
it will turn off DTP so it while it isn't going to improve anything with the voice itself, it will not try to establish a trunk link with the node on the other end of the line using DTP. it is best practice.

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
OK I used the command.
config t
int f0/19
switchport trunk encapsulation dot1q
switchport mode trunk
switchport nonegotiate
mls qos trust cos
auto qos voip trust
exit

Cisco3550#sh int f0/19 sw
Name: Fa0/19
Switchport: Enabled
Administrative Mode: trunk
Operational Mode: trunk
Administrative Trunking Encapsulation: dot1q
Operational Trunking Encapsulation: dot1q
Negotiation of Trunking: Off
Access Mode VLAN: 1 (default)
Trunking Native Mode VLAN: 1 (default)
Administrative Native VLAN tagging: enabled
Voice VLAN: none
Administrative private-vlan host-association: none
Administrative private-vlan mapping: none
Administrative private-vlan trunk native VLAN: none
Administrative private-vlan trunk Native VLAN tagging: enabled
Administrative private-vlan trunk encapsulation: dot1q
Administrative private-vlan trunk normal VLANs: none
Administrative private-vlan trunk private VLANs: none
Operational private-vlan: none
Trunking VLANs Enabled: ALL
Pruning VLANs Enabled: 2-1001
Capture Mode Disabled
Capture VLANs Allowed: ALL

Protected: false
Unknown unicast blocked: disabled
Unknown multicast blocked: disabled
Appliance trust: none
Cisco3550#
==--==
Port 19 is trunked to Cisco SLM224P.
==--==
On the Cisco 3550 I have two more trunked ports. Ports 20 and 21. I'll run the command on these ports as well.
Port 20 connected thru fibre converter to SLM224P switch (another building).
Port 21 connected to a Cisco 2950 (a test switch).


 
Yes, they do.
We have the Panasonic KX-TDE100 phone system. And the KX-NT343 phones.

Everything works great.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top