Hi
apologies if this is in the wrong forum, I was torn between the Voip one and here
I have recently installed a cisco 300 series 48 port switch in one of our branch offices. The switch is configured with 2 vlans VLAN 8 for data and VLAN 9 for voice. We are using Mitel 5312 IP phones which are configured with static values(no DHCP server)
Interfaces 2-48 have been configured as trunk ports with a native vlan 8 for data and to allow vlan 9 for voip. When connecting the phone to the switch everything works great, the phone connects to the PBX and all is good. If I then connect a PC to the back of the phone the PC is unable to communicate with the DHCP server and assigns itself an APIPA.
If I take the phone out of the equation and plug the PC directly into the switch it works fine DHCP assigns the PC the correct details and all is good.
The following is from the running config on the switch:
!
vlan database
vlan 8-9
exit
voice vlan id 9
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
voice vlan oui-table add 08000f Mitel_phone_____________
ip dhcp server
ip dhcp excluded-address 192.168.8.1 192.168.8.10
ip dhcp excluded-address 192.168.8.100 192.168.8.254
ip dhcp pool network DATA
address low 192.168.8.10 high 192.168.8.99 255.255.255.0
domain-name arrow.local
default-router 192.168.8.1
dns-server 192.168.1.11 192.168.1.11
exit
hostname SW01
username admin1 password encrypted 3b9cfcfbffc6b3ed92c7524f07bc895953dee627 privilege 15
username admin2 password encrypted e5574bb3200daf77312b095f1c39aba9878f40bb privilege 15
ip ssh server
ip telnet server
!
interface vlan 8
name DATA
ip address 192.168.8.254 255.255.255.0
no ip address dhcp
!
interface vlan 9
name VOIP
!
interface fastethernet1
switchport trunk allowed vlan add 8-9
!
interface fastethernet2
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet3
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type unknown
!
interface fastethernet4
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet5
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet6
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet7
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet8
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet9
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet10
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet11
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet12
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet13
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet14
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet15
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 9
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
I tested this before I left the office and did not encounter this issue myself. However the thin clients have been installed in the new office and they are experiencing the issue.
Does anyone have any thoughts to guide me in the right direction? It looks to me like the macro is not applying correctly based on fe3 and fe15. Can I disable this 'auto detect' option and manually tell the switch which vlan to use(I thought I had done this by setting the native vlan).
Normally I would use the following command on the specific interfaces
switchport access vlan 8
switchport voice vlan 9
but the switchport voice command is not recognised.
Thanks
Sokaar
apologies if this is in the wrong forum, I was torn between the Voip one and here
I have recently installed a cisco 300 series 48 port switch in one of our branch offices. The switch is configured with 2 vlans VLAN 8 for data and VLAN 9 for voice. We are using Mitel 5312 IP phones which are configured with static values(no DHCP server)
Interfaces 2-48 have been configured as trunk ports with a native vlan 8 for data and to allow vlan 9 for voip. When connecting the phone to the switch everything works great, the phone connects to the PBX and all is good. If I then connect a PC to the back of the phone the PC is unable to communicate with the DHCP server and assigns itself an APIPA.
If I take the phone out of the equation and plug the PC directly into the switch it works fine DHCP assigns the PC the correct details and all is good.
The following is from the running config on the switch:
!
vlan database
vlan 8-9
exit
voice vlan id 9
voice vlan oui-table add 0001e3 Siemens_AG_phone________
voice vlan oui-table add 00036b Cisco_phone_____________
voice vlan oui-table add 00096e Avaya___________________
voice vlan oui-table add 000fe2 H3C_Aolynk______________
voice vlan oui-table add 0060b9 Philips_and_NEC_AG_phone
voice vlan oui-table add 00d01e Pingtel_phone___________
voice vlan oui-table add 00e075 Polycom/Veritel_phone___
voice vlan oui-table add 00e0bb 3Com_phone______________
voice vlan oui-table add 08000f Mitel_phone_____________
ip dhcp server
ip dhcp excluded-address 192.168.8.1 192.168.8.10
ip dhcp excluded-address 192.168.8.100 192.168.8.254
ip dhcp pool network DATA
address low 192.168.8.10 high 192.168.8.99 255.255.255.0
domain-name arrow.local
default-router 192.168.8.1
dns-server 192.168.1.11 192.168.1.11
exit
hostname SW01
username admin1 password encrypted 3b9cfcfbffc6b3ed92c7524f07bc895953dee627 privilege 15
username admin2 password encrypted e5574bb3200daf77312b095f1c39aba9878f40bb privilege 15
ip ssh server
ip telnet server
!
interface vlan 8
name DATA
ip address 192.168.8.254 255.255.255.0
no ip address dhcp
!
interface vlan 9
name VOIP
!
interface fastethernet1
switchport trunk allowed vlan add 8-9
!
interface fastethernet2
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet3
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type unknown
!
interface fastethernet4
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet5
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet6
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet7
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet8
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet9
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet10
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet11
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet12
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet13
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet14
switchport trunk allowed vlan add 9
switchport trunk native vlan 8
!
interface fastethernet15
storm-control broadcast enable
storm-control broadcast level 10
storm-control include-multicast
port security max 10
port security mode max-addresses
port security discard trap 60
spanning-tree portfast
switchport trunk allowed vlan add 9
macro description ip_phone_desktop
!next command is internal.
macro auto smartport dynamic_type ip_phone_desktop
!
I tested this before I left the office and did not encounter this issue myself. However the thin clients have been installed in the new office and they are experiencing the issue.
Does anyone have any thoughts to guide me in the right direction? It looks to me like the macro is not applying correctly based on fe3 and fe15. Can I disable this 'auto detect' option and manually tell the switch which vlan to use(I thought I had done this by setting the native vlan).
Normally I would use the following command on the specific interfaces
switchport access vlan 8
switchport voice vlan 9
but the switchport voice command is not recognised.
Thanks
Sokaar