Hi all!
I have a small network with one router and three switches. They are put together in a typical router-on-a-stick way.
I'm trying to use my Cisco 2621XM router as an DHCP server for the network as well as a router.
The network functions fully when the clients are assigned static IPaddresses, but they can't get an IPaddress from the DHCP server.
I'm new to Cisco routers and any help setting up the DHCP function is wanted (writen for a newbie)
This is the "show run" from the router:
----------------------------------------------
Current configuration : 2455 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Hc7J$DhFroumJSlofTUuCFNtXR1
!
memory-size iomem 10
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 10.1.0.1 255.255.0.0
ip dhcp excluded-address 10.2.0.1 255.255.0.0
!
ip dhcp pool vlan11
network 10.1.0.0 255.255.0.0
dns-server 10.4.0.2
default-router 10.1.0.2
netbios-name-server 10.4.0.2
!
ip dhcp pool vlan12
network 10.2.0.0 255.255.0.0
dns-server 10.4.0.2
default-router 10.2.0.1
netbios-name-server 10.4.0.2
!
ip audit po max-events 100
no ftp-server write-enable
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet0/0.1
encapsulation dot1Q 11
ip address 10.1.0.1 255.255.0.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 12
ip address 10.2.0.1 255.255.0.0
!
!
interface Serial0/0
no ip address
shutdown
no fair-queue
no clns route-cache
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.0.0
duplex auto
speed auto
no clns route-cache
!
interface Serial0/1
no ip address
shutdown
no clns route-cache
!
router eigrp 10
network 10.0.0.0
auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.2
!
ip http server
no ip http secure-server
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
-------------------------------------
I have a small network with one router and three switches. They are put together in a typical router-on-a-stick way.
I'm trying to use my Cisco 2621XM router as an DHCP server for the network as well as a router.
The network functions fully when the clients are assigned static IPaddresses, but they can't get an IPaddress from the DHCP server.
I'm new to Cisco routers and any help setting up the DHCP function is wanted (writen for a newbie)
This is the "show run" from the router:
----------------------------------------------
Current configuration : 2455 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
enable secret 5 $1$Hc7J$DhFroumJSlofTUuCFNtXR1
!
memory-size iomem 10
no network-clock-participate slot 1
no network-clock-participate wic 0
no aaa new-model
ip subnet-zero
ip cef
!
!
ip dhcp excluded-address 10.1.0.1 255.255.0.0
ip dhcp excluded-address 10.2.0.1 255.255.0.0
!
ip dhcp pool vlan11
network 10.1.0.0 255.255.0.0
dns-server 10.4.0.2
default-router 10.1.0.2
netbios-name-server 10.4.0.2
!
ip dhcp pool vlan12
network 10.2.0.0 255.255.0.0
dns-server 10.4.0.2
default-router 10.2.0.1
netbios-name-server 10.4.0.2
!
ip audit po max-events 100
no ftp-server write-enable
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
no clns route-cache
!
interface FastEthernet0/0.1
encapsulation dot1Q 11
ip address 10.1.0.1 255.255.0.0
!
interface FastEthernet0/0.2
encapsulation dot1Q 12
ip address 10.2.0.1 255.255.0.0
!
!
interface Serial0/0
no ip address
shutdown
no fair-queue
no clns route-cache
!
interface FastEthernet0/1
ip address 10.0.0.1 255.255.0.0
duplex auto
speed auto
no clns route-cache
!
interface Serial0/1
no ip address
shutdown
no clns route-cache
!
router eigrp 10
network 10.0.0.0
auto-summary
!
ip classless
ip route 0.0.0.0 0.0.0.0 10.0.0.2
!
ip http server
no ip http secure-server
!
!
line con 0
line aux 0
line vty 0 4
!
!
end
-------------------------------------