fthomas1973
MIS
I am totally at my wits end on what is wrong with my router's config. I am using a 2621 with 2 serial, 3 fast ethernet. one serial line connects to Sprint Internet access, the other serial connects to a local provider for internet access. I FE interface has a subnet of sprint addresses, another FE has the local provider's subnet of addresses, and the last FE has a non-routable subnet (10.10.10.0/29) that connects to my internal network via a PIX515. I can reach a mail server with a Sprint address that is behind the PIX and is translated. I also have a static route on the 2621 pointing to the mail server to the non-routable subnet interface. However, if I try to reach a webserver that has an ip address of the other provider behind the firewall by using a static on the 2621 it does not reach the webserver. I think I am doing something basic incorrectly and some input would be great! below is my config
!
version 12.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname Inet
!
enable secret 5
enable password 7
!
ip subnet-zero
!
!
!
!
!
!
interface FastEthernet0/0
description local provider's subnet
ip address lll.lll.lll.lll 255.255.255.240
speed auto
full-duplex
!
interface Serial0/0
description SPRINT Internet Circuit
bandwidth 1536
ip address sss.sss.sss.sss 255.255.255.252
no ip redirects
ip nat outside
no ip mroute-cache
no fair-queue
!
interface FastEthernet0/1
description Sprint subnet
ip address sss.sss.sss.sss 255.255.255.240
speed auto
full-duplex
!
interface Serial0/1
description Internet Access to local provider
ip address lll.lll.lll.lll 255.255.255.224
no ip redirects
ip nat outside
encapsulation frame-relay IETF
no ip mroute-cache
no fair-queue
service-module t1 timeslots 1-4
!
interface FastEthernet1/0
description inside private subnet
ip address 10.10.10.1 255.255.255.248
ip nat inside
speed auto
full-duplex
!
ip nat inside source route-map nat-localprovider interface Serial0/1 overload
ip nat inside source route-map nat-sprint interface Serial0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 sss.sss.sss.sss
ip route 0.0.0.0 0.0.0.0 lll.lll.lll.lll 2
ip route sss.sss.sss.sss 255.255.255.255 10.10.10.2
ip route sss.sss.sss.sss 255.255.255.255 10.10.10.2
ip route lll.lll.lll.lll 255.255.255.255 10.10.10.2
no ip http server
ip pim bidir-enable
!
access-list 13 permit 10.10.10.2
route-map nat-localprovider permit 10
match ip address 13
match interface Serial0/1
!
route-map nat-sprint permit 10
match ip address 13
match interface Serial0/0
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
password x
login
!
end
!
version 12.2
service timestamps debug datetime localtime
service timestamps log datetime localtime
service password-encryption
!
hostname Inet
!
enable secret 5
enable password 7
!
ip subnet-zero
!
!
!
!
!
!
interface FastEthernet0/0
description local provider's subnet
ip address lll.lll.lll.lll 255.255.255.240
speed auto
full-duplex
!
interface Serial0/0
description SPRINT Internet Circuit
bandwidth 1536
ip address sss.sss.sss.sss 255.255.255.252
no ip redirects
ip nat outside
no ip mroute-cache
no fair-queue
!
interface FastEthernet0/1
description Sprint subnet
ip address sss.sss.sss.sss 255.255.255.240
speed auto
full-duplex
!
interface Serial0/1
description Internet Access to local provider
ip address lll.lll.lll.lll 255.255.255.224
no ip redirects
ip nat outside
encapsulation frame-relay IETF
no ip mroute-cache
no fair-queue
service-module t1 timeslots 1-4
!
interface FastEthernet1/0
description inside private subnet
ip address 10.10.10.1 255.255.255.248
ip nat inside
speed auto
full-duplex
!
ip nat inside source route-map nat-localprovider interface Serial0/1 overload
ip nat inside source route-map nat-sprint interface Serial0/0 overload
ip classless
ip route 0.0.0.0 0.0.0.0 sss.sss.sss.sss
ip route 0.0.0.0 0.0.0.0 lll.lll.lll.lll 2
ip route sss.sss.sss.sss 255.255.255.255 10.10.10.2
ip route sss.sss.sss.sss 255.255.255.255 10.10.10.2
ip route lll.lll.lll.lll 255.255.255.255 10.10.10.2
no ip http server
ip pim bidir-enable
!
access-list 13 permit 10.10.10.2
route-map nat-localprovider permit 10
match ip address 13
match interface Serial0/1
!
route-map nat-sprint permit 10
match ip address 13
match interface Serial0/0
!
!
line con 0
line aux 0
line vty 0 4
exec-timeout 0 0
password x
login
!
end