Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations Mike Lewis on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Cisco 2621 Configuration help

Status
Not open for further replies.

Tegguy92

Technical User
Mar 26, 2011
41
0
0
US
First of all please let me admit I am brand new to cisco and am trying my hardest to learn. I have tried searching and been trying stuff for a couple days now but I have a Cisco 2621 router running off a cable modem and I can't seem to be able to get internet access or ping to work. I am unsure about the configuration of the DNS servers. Any help you can offer that would be appreciated. The configuration below is my current config. I do get an IP address when plugged into my modem. One isn't listed now because i'm plugged into my netgear router.Thank You

Using 1336 out of 29688 bytes
!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Router
!
!
clock timezone east -4
ip subnet-zero
!
!
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.101
ip dhcp excluded-address 192.168.1.109
ip dhcp excluded-address 192.168.1.108
ip dhcp excluded-address 192.168.1.148 192.168.1.151
!
ip dhcp pool DHCP_POOL
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
domain-name ciscolab.local
!
ip dhcp pool I7_PC
host 192.168.1.101 255.255.255.0
dns-server 65.32.5.111 65.32.5.112
lease infinite
!
ip dhcp pool DL380-NIC-1
host 192.168.1.108 255.255.255.0
dns-server 65.32.5.111 65.32.5.112
lease infinite
!
ip dhcp pool DL380-NIC-2
host 192.168.1.109 255.255.255.0
dns-server 65.32.5.111 65.32.5.112
lease infinite
!
prompt Cisco_Router
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
speed auto
full-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
duplex auto
speed auto
!
ip classless
no ip http server
ip pim bidir-enable
!
!
dial-peer cor custom
!
!
!
!
line con 0
password ********
login
line aux 0
line vty 0 4
password ********
login
!
end
 
You need to add NAT statements to get it to work.

int f0/0
ip nat outside

int f0/1
ip nat inside

then you need...

access-list x permit 192.168.1.0 0.0.0.255

and

ip nat inside source list x interface f0/0 overload


The overload statement configures PAT. Hope it helps!
 
Thank you for the help I have added the commands so it now looks like.

no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1 192.168.1.99
ip dhcp excluded-address 192.168.1.101
ip dhcp excluded-address 192.168.1.109
ip dhcp excluded-address 192.168.1.108
ip dhcp excluded-address 192.168.1.148 192.168.1.151
!
ip dhcp pool DHCP_POOL
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
domain-name ciscolab.local
!
ip dhcp pool I7_PC
host 192.168.1.101 255.255.255.0
dns-server 65.32.5.111 65.32.5.112
lease infinite
!
ip dhcp pool DL380-NIC-1
host 192.168.1.108 255.255.255.0
dns-server 65.32.5.111 65.32.5.112
lease infinite
!
ip dhcp pool DL380-NIC-2
host 192.168.1.109 255.255.255.0
dns-server 65.32.5.111 65.32.5.112
lease infinite
!
prompt Cisco_Router
call rsvp-sync
!
!
!
!
!
!
!
!
interface FastEthernet0/0
ip address dhcp
ip nat outside
speed auto
full-duplex
!
interface Serial0/0
no ip address
shutdown
!
interface FastEthernet0/1
ip address 192.168.1.1 255.255.255.0
ip nat inside
duplex auto
speed auto
!
ip nat inside source list 1 interface FastEthernet0/0 overload
ip classless
no ip http server
ip pim bidir-enable
!
access-list 1 permit 192.168.1.0 0.0.0.255

However when I try to ping I still get the message
"ping google.co
01:49:36: %SYS-5-CONFIG_I: Configured from console by consolem
Translating "google.com"...domain server (255.255.255.255)
% Unrecognized host or address, or protocol not running."

Also on the DNS servers will the router automatically get them from DHCP on fe0/0 or do I need to specify them for fe0/1? Currently I have them setup for the static pools but not the DHCP pool. Also i'm trying to ping from the router not the computer
 
Also when I pull an Ip over DHCP I pull a 10.x.x.x when plugged into the cisco but when hooked into my netgear and I goto whatismyip.com I pull a 188.x.x.x is this a problem? Seems odd to me
 
Going to whatismyip.com will show your public IP, the one from your ISP. This is how you connect to the rest of the world. It has nothing to do with your internal network. As for why you are pulling a 10.X.X.X address when plugged into your switch is past me. You don't have a static IP addressed to you computer do you? Just a thought.
 
No I use DHCP from my cable modem to my Router.
 
Is it possible that your cable modem is also acting as a DHCP server and using the 10.X.X.X scheme?
 
You have to add nameservers on the Router if you want to ping to something via IP from the router itself, this is different from the nameserver setup for the PCs. I usually turn this off with "no ip domain-lookup" because everytime you mistype a command it's going to try to look it up and fail.

But if you need DNS on the router itself for pinging google and such you need to put

ip name-server x.x.x.x
ip name-server y.y.y.y

x and y being primary and backup DNS.

When you have an IP on your router from DHCP on f0/0, can you run a "sho ip int brief" and post it?
 
Cisco_Routersho ip int brief
Interface IP-Address OK? Method Status Protocol
FastEthernet0/0 10.54.238.27 YES DHCP up up
Serial0/0 unassigned YES NVRAM administratively down down
FastEthernet0/1 192.168.1.1 YES NVRAM up down
 
To get a route out to the internet run:

ip route 0.0.0.0 0.0.0.0 dhcp


It is interesting that your cable modem is handing you a private address though.
 
I tried using the command exactly as you typed and it says invalid marker at the H
 
Ahhh, I use that command on my little remote 851 routers for VPNs for folks, but IOS is not always IOS with Cisco.

Try doing an ip route 0.0.0.0 0.0.0.0 and a question mark and see what options you have.

Otherwise, I'm sure you're always going to have the same gateway there anyway so you could just configure it that way, you'd have to know the IP address of your next hope and then do

ip route 0.0.0.0 0.0.0.0 nexthop

I was only saying use the dhcp since it seemed easier than you having to determine the address of your gateway.
 
This is what I get when I do ip router with the question mark

#ip route 0.0.0.0 0.0.0.0 ?
A.B.C.D Forwarding router's address
Async Async interface
BVI Bridge-Group Virtual Interface
CTunnel CTunnel interface
Dialer Dialer interface
FastEthernet FastEthernet IEEE 802.3
Lex Lex interface
Loopback Loopback interface
Multilink Multilink-group interface
Null Null interface
Serial Serial
Tunnel Tunnel interface
Vif PGM Multicast Host interface
Virtual-Template Virtual Template interface
Virtual-TokenRing Virtual TokenRing

I looked through the list but couldn't figure out which one I need to use
 
Also I just pulled up status on my netgear router and here is what it shows.

IP Address 184.88.96.32
Subnet Mask 255.255.248.0
Default Gateway 184.88.96.1
DHCP Server 10.54.224.1
DNS Server 65.32.5.111
65.32.5.112
 
Do you reach your netgear router to configure it at 10.54.224.1?

if so:

ip route 0.0.0.0 0.0.0.0 10.54.224.1
 
Do you reach your netgear router to configure it at 10.54.224.1?

if so:

ip route 0.0.0.0 0.0.0.0 10.54.224.1

I don't quite understand what your asking. just for extra info If I plug my cisco into my netgear I don't get an IP address
 
Sorry it seemed odd that the Cisco router pulls the IP

Cisco_Routersho ip int briefInterface IP-Address OK? Method Status ProtocolFastEthernet0/0 10.54.238.27 YES DHCP up up

And your Netgear is handing out addresses in the 10.54. range, so I was thinking you were plugging your Cisco in behind the Netgear.

If you pull a 184.x.x.x with the netgear, and when you plug in the Cisco in the exact same way you pull 10.54.238.27 ... I am not sure what to tell you at that point.

If you got the 184.88.96.32 address on your cisco you would configure the gateway as

ip route 0.0.0.0 0.0.0.0 184.88.96.1

But you don't pull that IP, so obviously that statement wouldn't work, I am completely lost as to why you would pull a 10 address on one device and a 184 on the other.

Try plugging a PC directly into the handoff and pull DHCP and see what you get?

 
Ok so now it gets even stranger when plugged directly into my computer I pull a 97.102.x.x with a DHCP server of 10.x.x.x

I'm completely lost now
 
Does anyone have any ideas? Should I call my ISP and ask them? I don't think I have any issues in my configuration.
 
The easiest thing to do at this point I think would be to request a static IP from your ISP.

Then you wouldn't have any of these issues.
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top