It depends on what you're trying to achieve. If you're connecting to a frame relay or LL network, you'll definitely need another interface, typically a serial port to connect to your service provider. You can then define which interfaces belongs to the "outside" (or unsecure) and the "inside". (the secure network)
Using just one F0/0 port would require you to configure sub-interfaces and use trunking (ie. isl or 802.1q), and terminate this to another trunk-capable device such as a switch. This setup is also known as a "router-on-a-stick". You can then define which logical sub-interface belongs to the inside and outside network.
Ex.
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.1
description Connects to the Internet
encapsulation isl 1
ip address 201.25.23.3 255.255.255.240
no ip redirects
ip nat outside
!
interface FastEthernet0/0.2
description Connects to the LAN
encapsulation isl 2
ip address 192.168.10.254 255.255.255.0
no ip redirects
ip nat inside
!
ip nat inside source list NATpool interface FastEthernet0/0.1 overload
!
ip access-list standard NATpool
permit 192.168.10.0 0.0.0.255
! Orlando Palomar Jr
CCIE# 11206, CCNP
CIPT Operations Specialist
Phil-Data Business Systems, Inc.
This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
By continuing to use this site, you are consenting to our use of cookies.