Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations biv343 on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

Cisco 2600 load balance T1

Status
Not open for further replies.

msimonxx

Programmer
Dec 2, 2008
3
I'm trying to get load balancing working (actually just internet access from the LAN would be a great start) on an old cisco 2600. Below is my config...I can ping from the router itself, but no luck from a host on the lan....i'm sure there all kinds of issues with the config as i'm a programmer not a network guy....i'm fumbling around....ugh

the isp is cogent if that helps any

rain2600#show run
Building configuration...

Current configuration : 1181 bytes
!
version 12.1
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
no service dhcp
!
hostname rain2600
!
logging buffered 4096 informational
enable secret 5 xxx
!
!
!
!
!
ip subnet-zero
ip cef
ip domain-name rainmaker.local
ip name-server 66.28.0.45
ip name-server 66.28.0.61
!
!
!
interface FastEthernet0/0
ip address 10.1.10.3 255.255.255.0
duplex auto
speed auto
!
interface Serial0/0
ip address 38.x.x.x 255.255.255.252
no ip redirects
no ip proxy-arp
ip load-sharing per-packet
encapsulation ppp
no ip mroute-cache
no peer neighbor-route
no fair-queue
no cdp enable
!
interface Serial0/1
ip address 38.x.x.x 255.255.255.252
no ip redirects
ip load-sharing per-packet
encapsulation ppp
no ip mroute-cache
no peer neighbor-route
no cdp enable
!
ip classless
ip route 0.0.0.0 0.0.0.0 Serial0/0
ip route 0.0.0.0 0.0.0.0 Serial0/1
no ip http server
!
dialer-list 1 protocol ip permit
dialer-list 1 protocol ipx permit
snmp-server community public RO
!
line con 0
transport input none
line aux 0
line vty 0 4
password xxxx
login
!
end

rain2600#
 
I'm going to assume that your addressing is correct on the serial links so the next thing to do is configure NAT for the internal network.
Code:
Router(config)# int f0/0
Router(config-if)# ip nat inside
Router(config)# int s0/0
Router(config-if)# ip nat outside
Router(config)# int s0/1
Router(config-if)# ip nat outside
Router(config)# access-list 1 permit 10.1.10.0 0.0.0.255
Router(config)# ip nat inside source list 1 interface s0/0 overload
Router(config)# ip nat inside source list 1 interface s0/1 overload

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
this doesn't work because i can't translate access-list 1 to two interfaces....i was however able to get it to work using route-map

i have another problem though...and that is that i can't use the vpn over the load balanced t1's....

thanks for the replay
 
Is it a requirement that you load share?

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
that is the way the isp is setup....and i do need the extra bandwidth
 
Good enough. Here is what I would recommend. Call your ISP and see if they will bond your two connections together using MLPPP. If they would be willing to set that up you'll need to configure MLPPP on your side also (we can help you through the config if you want). Bundling with MLPPP will aggregate your bandwidth together so for example, instead of having two separate T1's each operating independently at 1.5 mbmps they would operate as a single 3meg connection. If one of the links drops for some reason then the only thing you would notice is a drop in bandwidth. With your current configuration if one of the links drops then you will have connectivity issues with some of your hosts, that is unless you implement techniques such as interface tracking with IP SLA's.

I hate all Uppercase... I don't want my groups to seem angry at me all the time! =)
- ColdFlame (vbscript forum)
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top