This is a snip from an L3 module in a Catalyst 4006. I'm trying to do a couple of things...
First, I'm trying to understand what the "interface port-channel" command infers?
Secondly, I'd like to add an additional subnet (172.24.3.0) to the same range of switch ports that are currently using the 172.24.2.0 subnet. Given the config of the L3 module below, could I simply do a config t, followed by
int port-channel1.2
and then add a secondary IP address as follows?
ip address 172.24.3.1 255.255.255.0 secondary
Would this give me the ability to use both 172.24.2.0 and 172.24.3.0 on the same range of ports and route between them?
-----------------------------------------
interface Port-channel1
no ip address
no ip directed-broadcast
no ip mroute-cache
hold-queue 300 in
!
interface Port-channel1.1
description User VLAN assigned to GigabitEthernet3&4
encapsulation dot1Q 1 native
ip address 172.24.1.1 255.255.255.0
ip helper-address 172.24.1.20
no ip redirects
no ip directed-broadcast
no ip mroute-cache
!
interface Port-channel1.2
encapsulation dot1Q 2
ip address 172.24.2.1 255.255.255.0
no ip redirects
no ip directed-broadcast
no ip mroute-cache
!
interface FastEthernet1
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
interface GigabitEthernet1
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
interface GigabitEthernet2
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
interface GigabitEthernet3
no ip address
no ip directed-broadcast
no ip mroute-cache
no negotiation auto
channel-group 1
!
interface GigabitEthernet4
no ip address
no ip directed-broadcast
no ip mroute-cache
no negotiation auto
channel-group 1
First, I'm trying to understand what the "interface port-channel" command infers?
Secondly, I'd like to add an additional subnet (172.24.3.0) to the same range of switch ports that are currently using the 172.24.2.0 subnet. Given the config of the L3 module below, could I simply do a config t, followed by
int port-channel1.2
and then add a secondary IP address as follows?
ip address 172.24.3.1 255.255.255.0 secondary
Would this give me the ability to use both 172.24.2.0 and 172.24.3.0 on the same range of ports and route between them?
-----------------------------------------
interface Port-channel1
no ip address
no ip directed-broadcast
no ip mroute-cache
hold-queue 300 in
!
interface Port-channel1.1
description User VLAN assigned to GigabitEthernet3&4
encapsulation dot1Q 1 native
ip address 172.24.1.1 255.255.255.0
ip helper-address 172.24.1.20
no ip redirects
no ip directed-broadcast
no ip mroute-cache
!
interface Port-channel1.2
encapsulation dot1Q 2
ip address 172.24.2.1 255.255.255.0
no ip redirects
no ip directed-broadcast
no ip mroute-cache
!
interface FastEthernet1
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
interface GigabitEthernet1
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
interface GigabitEthernet2
no ip address
no ip directed-broadcast
no ip mroute-cache
shutdown
!
interface GigabitEthernet3
no ip address
no ip directed-broadcast
no ip mroute-cache
no negotiation auto
channel-group 1
!
interface GigabitEthernet4
no ip address
no ip directed-broadcast
no ip mroute-cache
no negotiation auto
channel-group 1