I have configured "port-channels" on a Cisco 3660 router (IOS 12.4-5a) and a Catalyst 2950 switch (IOS 12.1-19).
I reset the configs to factory defaults and then applied just the commands to form an etherchannel between the two devices. The result is that neither device can ping the other.
For some reason, the CLI on the 3660 will only let me enter "channel-group <number>". It will not let me enter "mode", "auto", "desirable", etc. I can only assume that this means PAGP and LACP are not supported and that the above channel-group command is equivalent to "channel-group <number> mode on".
I temporarily removed the port-channels and defined an IP address directly on one of the router interfaces, and I was able to ping between the devices. This rules out an interface or cable issue.
Listed below are my device configs. Both devices report the port-channel as "up and up". My goal is to simply be able to ping between the devices.
Any help would be most appreciated!
Catalyst 2950
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
no logging console
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface Port-channel1
no ip address
duplex full
!
interface FastEthernet0/1
no ip address
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet0/2
no ip address
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet0/3
no ip address
!
<Config Truncated>
!
interface Vlan1
ip address 10.0.18.103 255.255.255.0
no ip route-cache
!
ip http server
!
!
line con 0
line vty 5 15
!
end
Cisco 3660
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 16000 debugging
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
no ip domain lookup
!
!
interface Port-channel1
ip address 10.0.18.100 255.255.255.0
full-duplex
hold-queue 0 in
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
channel-group 1
!
interface FastEthernet0/1
no ip address
speed 100
full-duplex
channel-group 1
!
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
!
end
Switch#show interface port-channel 1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 0011.218e.9d81 (bia 0011.218e.9d81)
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
Members in this channel: Fa0/1 Fa0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
34 packets input, 3328 bytes, 0 no buffer
Received 10 broadcasts (0 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 4 multicast, 0 pause input
0 input packets with dribble condition detected
115 packets output, 11050 bytes, 0 underruns
0 output errors, 0 collisions, 5 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
Router#show interface port-channel 1
Port-channel1 is up, line protocol is up
Hardware is FEChannel, address is 0002.162e.0000 (bia 0002.162e.0000)
Internet address is 10.0.18.100/24
MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
No. of active members in this channel: 2
Member 0 : FastEthernet0/0 , Full-duplex, 100Mb/s
Member 1 : FastEthernet0/1 , Full-duplex, 100Mb/s
No. of Non-active members in this channel: 0
Last input 00:00:14, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/80 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
20 packets output, 1319 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Switch#show etherchannel detail
Channel-group listing:
-----------------------
Group: 1
----------
Group state = L2
Ports: 2 Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol: -
Ports in the group:
-------------------
Port: Fa0/1
------------
Port state = Up Mstr In-Bndl
Channel group = 1 Mode = On/FEC Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -
Age of the port in the current state: 00d:00h:04m:47s
Port: Fa0/2
------------
Port state = Up Mstr In-Bndl
Channel group = 1 Mode = On/FEC Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -
Age of the port in the current state: 00d:00h:04m:34s
Port-channels in the group:
----------------------
Port-channel: Po1
------------
Age of the Port-channel = 00d:00h:10m:49s
Logical slot/port = 1/0 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = -
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Fa0/1 On/FEC 0
0 00 Fa0/2 On/FEC 0
Time since last port bundled: 00d:00h:04m:34s Fa0/2
Switch#
Switch#sho etherchannel port-channel ?
| Output modifiers
<cr>
Router#show etherchannel detail
Channel-group listing:
-----------------------
I reset the configs to factory defaults and then applied just the commands to form an etherchannel between the two devices. The result is that neither device can ping the other.
For some reason, the CLI on the 3660 will only let me enter "channel-group <number>". It will not let me enter "mode", "auto", "desirable", etc. I can only assume that this means PAGP and LACP are not supported and that the above channel-group command is equivalent to "channel-group <number> mode on".
I temporarily removed the port-channels and defined an IP address directly on one of the router interfaces, and I was able to ping between the devices. This rules out an interface or cable issue.
Listed below are my device configs. Both devices report the port-channel as "up and up". My goal is to simply be able to ping between the devices.
Any help would be most appreciated!
Catalyst 2950
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname Switch
!
no logging console
!
ip subnet-zero
!
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
interface Port-channel1
no ip address
duplex full
!
interface FastEthernet0/1
no ip address
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet0/2
no ip address
duplex full
speed 100
channel-group 1 mode on
!
interface FastEthernet0/3
no ip address
!
<Config Truncated>
!
interface Vlan1
ip address 10.0.18.103 255.255.255.0
no ip route-cache
!
ip http server
!
!
line con 0
line vty 5 15
!
end
Cisco 3660
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
logging buffered 16000 debugging
no logging console
!
no aaa new-model
!
resource policy
!
ip cef
no ip domain lookup
!
!
interface Port-channel1
ip address 10.0.18.100 255.255.255.0
full-duplex
hold-queue 0 in
!
interface FastEthernet0/0
no ip address
speed 100
full-duplex
channel-group 1
!
interface FastEthernet0/1
no ip address
speed 100
full-duplex
channel-group 1
!
!
ip http server
no ip http secure-server
!
control-plane
!
line con 0
line aux 0
line vty 0 4
!
!
end
Switch#show interface port-channel 1
Port-channel1 is up, line protocol is up (connected)
Hardware is EtherChannel, address is 0011.218e.9d81 (bia 0011.218e.9d81)
MTU 1500 bytes, BW 200000 Kbit, DLY 1000 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Full-duplex, 100Mb/s
input flow-control is off, output flow-control is off
Members in this channel: Fa0/1 Fa0/2
ARP type: ARPA, ARP Timeout 04:00:00
Last input never, output 00:00:01, output hang never
Last clearing of "show interface" counters never
Input queue: 0/75/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/40 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
34 packets input, 3328 bytes, 0 no buffer
Received 10 broadcasts (0 multicast)
0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog, 4 multicast, 0 pause input
0 input packets with dribble condition detected
115 packets output, 11050 bytes, 0 underruns
0 output errors, 0 collisions, 5 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier, 0 PAUSE output
0 output buffer failures, 0 output buffers swapped out
Router#show interface port-channel 1
Port-channel1 is up, line protocol is up
Hardware is FEChannel, address is 0002.162e.0000 (bia 0002.162e.0000)
Internet address is 10.0.18.100/24
MTU 1500 bytes, BW 200000 Kbit, DLY 100 usec,
reliability 255/255, txload 1/255, rxload 1/255
Encapsulation ARPA, loopback not set
Keepalive set (10 sec)
ARP type: ARPA, ARP Timeout 04:00:00
No. of active members in this channel: 2
Member 0 : FastEthernet0/0 , Full-duplex, 100Mb/s
Member 1 : FastEthernet0/1 , Full-duplex, 100Mb/s
No. of Non-active members in this channel: 0
Last input 00:00:14, output never, output hang never
Last clearing of "show interface" counters never
Input queue: 0/150/0/0 (size/max/drops/flushes); Total output drops: 0
Queueing strategy: fifo
Output queue: 0/80 (size/max)
5 minute input rate 0 bits/sec, 0 packets/sec
5 minute output rate 0 bits/sec, 0 packets/sec
0 packets input, 0 bytes
Received 0 broadcasts, 0 runts, 0 giants, 0 throttles
0 input errors, 0 CRC, 0 frame, 0 overrun, 0 ignored
0 watchdog
0 input packets with dribble condition detected
20 packets output, 1319 bytes, 0 underruns
0 output errors, 0 collisions, 0 interface resets
0 babbles, 0 late collision, 0 deferred
0 lost carrier, 0 no carrier
0 output buffer failures, 0 output buffers swapped out
Switch#show etherchannel detail
Channel-group listing:
-----------------------
Group: 1
----------
Group state = L2
Ports: 2 Maxports = 8
Port-channels: 1 Max Port-channels = 1
Protocol: -
Ports in the group:
-------------------
Port: Fa0/1
------------
Port state = Up Mstr In-Bndl
Channel group = 1 Mode = On/FEC Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -
Age of the port in the current state: 00d:00h:04m:47s
Port: Fa0/2
------------
Port state = Up Mstr In-Bndl
Channel group = 1 Mode = On/FEC Gcchange = -
Port-channel = Po1 GC = - Pseudo port-channel = Po1
Port index = 0 Load = 0x00 Protocol = -
Age of the port in the current state: 00d:00h:04m:34s
Port-channels in the group:
----------------------
Port-channel: Po1
------------
Age of the Port-channel = 00d:00h:10m:49s
Logical slot/port = 1/0 Number of ports = 2
GC = 0x00000000 HotStandBy port = null
Port state = Port-channel Ag-Inuse
Protocol = -
Ports in the Port-channel:
Index Load Port EC state No of bits
------+------+------+------------------+-----------
0 00 Fa0/1 On/FEC 0
0 00 Fa0/2 On/FEC 0
Time since last port bundled: 00d:00h:04m:34s Fa0/2
Switch#
Switch#sho etherchannel port-channel ?
| Output modifiers
<cr>
Router#show etherchannel detail
Channel-group listing:
-----------------------