kunz12
MIS
- Jan 17, 2007
- 42
Guys - below is the config of my lab router. Very simple config but I cannot SSH/Telnet/Ping my router IP address from outside. However, when I remove "ip nat outside" statement from Interface Gig 0/0, I can SSH/Telnet/Ping my router IP address from outside. However, when I do this, I can no longer connect to the Internet from my lab machine.
Any thoughts or ideas as to why this is happening? I even created a nat pool instead of overloading the Gig 0/0 interface address. That did not help.
Current configuration : 1512 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname LAB_ROUTER
!
boot-start-marker
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/3
enable secret 5 $1$cB1w$9gaXgVqJpJ9yJ48rAQLgJ/
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
ip domain name test.local
ip ssh time-out 30
!
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username ksarin password 7 13041511355D55797F
!
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
interface GigabitEthernet0/0
ip address 99.99.99.139 255.255.255.248
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/1.2
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 99.99.99.142
!
!
no ip http server
no ip http secure-server
ip nat pool NATPOOL 99.99.99.140 99.99.99.141 netmask 255.255.255.248
ip nat inside source list 111 pool NATPOOL overload
!
access-list 111 permit ip any any
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login local
terminal-type monitor
transport input telnet ssh
line vty 5 15
login local
terminal-type monitor
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end
Any thoughts or ideas as to why this is happening? I even created a nat pool instead of overloading the Gig 0/0 interface address. That did not help.
Current configuration : 1512 bytes
!
version 12.4
service config
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname LAB_ROUTER
!
boot-start-marker
boot-end-marker
!
! card type command needed for slot/vwic-slot 0/3
enable secret 5 $1$cB1w$9gaXgVqJpJ9yJ48rAQLgJ/
!
no aaa new-model
!
resource policy
!
!
!
ip cef
!
!
ip domain name test.local
ip ssh time-out 30
!
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
username ksarin password 7 13041511355D55797F
!
!
!
!
!
!
!
interface Loopback0
ip address 10.10.10.1 255.255.255.0
!
interface GigabitEthernet0/0
ip address 99.99.99.139 255.255.255.248
ip virtual-reassembly
duplex auto
speed auto
!
interface GigabitEthernet0/1
no ip address
duplex auto
speed auto
!
interface GigabitEthernet0/1.1
encapsulation dot1Q 10
ip address 192.168.10.1 255.255.255.0
!
interface GigabitEthernet0/1.2
encapsulation dot1Q 20
ip address 192.168.20.1 255.255.255.0
ip nat inside
ip virtual-reassembly
!
ip route 0.0.0.0 0.0.0.0 99.99.99.142
!
!
no ip http server
no ip http secure-server
ip nat pool NATPOOL 99.99.99.140 99.99.99.141 netmask 255.255.255.248
ip nat inside source list 111 pool NATPOOL overload
!
access-list 111 permit ip any any
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login local
terminal-type monitor
transport input telnet ssh
line vty 5 15
login local
terminal-type monitor
transport input telnet ssh
!
scheduler allocate 20000 1000
!
end