Hi Guys,
I have an ASA 5520 that is having issues. I have a 871 router connected to it successfully and the inside network can ping the network of that router, however it does not work vice-versa. I ran packet tracer and it looks like its failing at NAT Lookup.
The inside IP for the test is 10.80.139.1 (main inside router) and the router's IP is 10.80.75.1 .
Any ideas whats causing this?
Heres my ASA config:
!--- Use newest IOS and ASDM
boot system disk0:/asa821-k8.bin
asdm image disk0:/asdm-621.bin
!--- Local VPN Accounts
username test1 password Kg/Rgy23do7gPGTv encrypted
!
hostname MDCASA-CLLSeaChangeASA
domain-name suddenlink.cequel3.com
same-security-traffic permit intra-interface
sysopt connection permit-ipsec
crypto isakmp nat-traversal 30
!
names
name 10.80.64.0 RemoteSCSubnets
name 10.80.139.0 LocalSCSubnets
name 10.80.103.96 LocalEngSubnets
!--- Generate RSA Key
crypto key generate rsa modulus 1024
write mem
!
!
!
!
interface GigabitEthernet0/0
description Outside
nameif outside
ip address 208.180.78.15 255.255.255.0
no shut
!
interface GigabitEthernet0/1
description Inside
nameif inside
ip address 10.80.139.16 255.255.255.0
no shut
!
interface GigabitEthernet0/2
no shut
!
interface GigabitEthernet0/3
no shut
!
interface GigabitEthernet1/0
no shut
!
interface GigabitEthernet1/1
no shut
!
interface GigabitEthernet1/2
no shut
!
interface GigabitEthernet1/3
no shut
!
interface Management0/0
description Management
nameif management
ip address 10.80.111.90 255.255.252.0
no shut
!
webvpn
port 444
enable outside
!
!--- Allow Access to Web Interface
http server enable
http 10.80.100.0 255.255.252.0 management
http 10.80.139.0 255.255.255.0 inside
!
!--- Default Route
route outside 0.0.0.0 0.0.0.0 208.180.78.1 1
!--- Auto IP Pool for VPN Connections
ip local pool SC_RA_Pool 10.80.200.2-10.80.200.254 mask 255.255.255.0
!--- NAT
! These groups are used for a NAT translation exemption to allow the interal network to be able to communicate with the VPN Router subnets
! Even though they are the same we have to have 2 differently named groups otherwise the system will throw a warning and not allow the NAT exclusion
object-group network OGN_WAN_1
network-object LocalSCSubnets 255.255.255.0
network-object LocalEngSubnets 255.255.255.240
network-object RemoteSCSubnets 255.255.240.0
object-group network OGN_WAN_2
network-object LocalSCSubnets 255.255.255.0
network-object LocalEngSubnets 255.255.255.240
network-object RemoteSCSubnets 255.255.240.0
!
access-list inside_accessVPNSubnet extended permit ip object-group OGN_WAN_1 object-group OGN_WAN_2
!
global (outside) 1 interface
nat (inside) 0 access-list inside_accessVPNSubnet outside
nat (inside) 1 0.0.0.0 0.0.0.0
!--- Access Lists
access-list outside_allowIncomingTrafficFromVPNSubnet remark Allow traffic to come in from our remote VPN routers
access-list outside_allowIncomingTrafficFromVPNSubnet extended permit ip object-group OGN_WAN_1 object-group OGN_WAN_2
access-list outside_allowIncomingTrafficFromVPNSubnet remark Allow ICMP
access-list outside_allowIncomingTrafficFromVPNSubnet extended permit icmp any any echo-reply
access-list outside_allowIncomingTrafficFromVPNSubnet extended permit icmp any any time-exceeded
access-list outside_allowIncomingTrafficFromVPNSubnet extended permit icmp any any echo
access-list Split_Tunnel_List remark The corporate network behind the ASA.
access-list Split_Tunnel_List standard permit 10.80.139.0 255.255.255.0
access-list Split_Tunnel_List standard permit 10.80.103.64 255.255.255.240
access-group outside_allowIncomingTrafficFromVPNSubnet in interface outside
!--- VPN Server Items
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
group-policy DfltGrpPolicy attributes
password-storage enable
nem enable
group-policy SDLCLL-VPN831 internal
group-policy SDLCLL-VPN831 attributes
wins-server value 10.80.100.11
dns-server value 10.80.100.11 10.50.101.12
vpn-tunnel-protocol IPSec
default-domain value suddenlink.cequel3.com
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Split_Tunnel_List
tunnel-group SDLCLL-VPN831 type remote-access
tunnel-group SDLCLL-VPN831 general-attributes
address-pool SC_RA_Pool
default-group-policy SDLCLL-VPN831
tunnel-group SDLCLL-VPN831 ipsec-attributes
pre-shared-key PASSWORD
!
I have an ASA 5520 that is having issues. I have a 871 router connected to it successfully and the inside network can ping the network of that router, however it does not work vice-versa. I ran packet tracer and it looks like its failing at NAT Lookup.
The inside IP for the test is 10.80.139.1 (main inside router) and the router's IP is 10.80.75.1 .
Any ideas whats causing this?
Heres my ASA config:
!--- Use newest IOS and ASDM
boot system disk0:/asa821-k8.bin
asdm image disk0:/asdm-621.bin
!--- Local VPN Accounts
username test1 password Kg/Rgy23do7gPGTv encrypted
!
hostname MDCASA-CLLSeaChangeASA
domain-name suddenlink.cequel3.com
same-security-traffic permit intra-interface
sysopt connection permit-ipsec
crypto isakmp nat-traversal 30
!
names
name 10.80.64.0 RemoteSCSubnets
name 10.80.139.0 LocalSCSubnets
name 10.80.103.96 LocalEngSubnets
!--- Generate RSA Key
crypto key generate rsa modulus 1024
write mem
!
!
!
!
interface GigabitEthernet0/0
description Outside
nameif outside
ip address 208.180.78.15 255.255.255.0
no shut
!
interface GigabitEthernet0/1
description Inside
nameif inside
ip address 10.80.139.16 255.255.255.0
no shut
!
interface GigabitEthernet0/2
no shut
!
interface GigabitEthernet0/3
no shut
!
interface GigabitEthernet1/0
no shut
!
interface GigabitEthernet1/1
no shut
!
interface GigabitEthernet1/2
no shut
!
interface GigabitEthernet1/3
no shut
!
interface Management0/0
description Management
nameif management
ip address 10.80.111.90 255.255.252.0
no shut
!
webvpn
port 444
enable outside
!
!--- Allow Access to Web Interface
http server enable
http 10.80.100.0 255.255.252.0 management
http 10.80.139.0 255.255.255.0 inside
!
!--- Default Route
route outside 0.0.0.0 0.0.0.0 208.180.78.1 1
!--- Auto IP Pool for VPN Connections
ip local pool SC_RA_Pool 10.80.200.2-10.80.200.254 mask 255.255.255.0
!--- NAT
! These groups are used for a NAT translation exemption to allow the interal network to be able to communicate with the VPN Router subnets
! Even though they are the same we have to have 2 differently named groups otherwise the system will throw a warning and not allow the NAT exclusion
object-group network OGN_WAN_1
network-object LocalSCSubnets 255.255.255.0
network-object LocalEngSubnets 255.255.255.240
network-object RemoteSCSubnets 255.255.240.0
object-group network OGN_WAN_2
network-object LocalSCSubnets 255.255.255.0
network-object LocalEngSubnets 255.255.255.240
network-object RemoteSCSubnets 255.255.240.0
!
access-list inside_accessVPNSubnet extended permit ip object-group OGN_WAN_1 object-group OGN_WAN_2
!
global (outside) 1 interface
nat (inside) 0 access-list inside_accessVPNSubnet outside
nat (inside) 1 0.0.0.0 0.0.0.0
!--- Access Lists
access-list outside_allowIncomingTrafficFromVPNSubnet remark Allow traffic to come in from our remote VPN routers
access-list outside_allowIncomingTrafficFromVPNSubnet extended permit ip object-group OGN_WAN_1 object-group OGN_WAN_2
access-list outside_allowIncomingTrafficFromVPNSubnet remark Allow ICMP
access-list outside_allowIncomingTrafficFromVPNSubnet extended permit icmp any any echo-reply
access-list outside_allowIncomingTrafficFromVPNSubnet extended permit icmp any any time-exceeded
access-list outside_allowIncomingTrafficFromVPNSubnet extended permit icmp any any echo
access-list Split_Tunnel_List remark The corporate network behind the ASA.
access-list Split_Tunnel_List standard permit 10.80.139.0 255.255.255.0
access-list Split_Tunnel_List standard permit 10.80.103.64 255.255.255.240
access-group outside_allowIncomingTrafficFromVPNSubnet in interface outside
!--- VPN Server Items
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-SHA esp-aes esp-sha-hmac
crypto ipsec transform-set ESP-AES-256-MD5 esp-aes-256 esp-md5-hmac
crypto ipsec transform-set ESP-DES-MD5 esp-des esp-md5-hmac
crypto ipsec transform-set ESP-AES-256-SHA esp-aes-256 esp-sha-hmac
crypto ipsec transform-set ESP-AES-128-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-DES-SHA esp-des esp-sha-hmac
crypto ipsec transform-set ESP-AES-192-MD5 esp-aes-192 esp-md5-hmac
crypto ipsec transform-set ESP-AES-192-SHA esp-aes-192 esp-sha-hmac
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set pfs
crypto dynamic-map SYSTEM_DEFAULT_CRYPTO_MAP 65535 set transform-set ESP-AES-128-SHA ESP-AES-128-MD5 ESP-AES-192-SHA ESP-AES-192-MD5 ESP-AES-256-SHA ESP-AES-256-MD5 ESP-3DES-SHA ESP-3DES-MD5 ESP-DES-SHA ESP-DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic SYSTEM_DEFAULT_CRYPTO_MAP
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
crypto isakmp policy 65535
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
group-policy DfltGrpPolicy attributes
password-storage enable
nem enable
group-policy SDLCLL-VPN831 internal
group-policy SDLCLL-VPN831 attributes
wins-server value 10.80.100.11
dns-server value 10.80.100.11 10.50.101.12
vpn-tunnel-protocol IPSec
default-domain value suddenlink.cequel3.com
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Split_Tunnel_List
tunnel-group SDLCLL-VPN831 type remote-access
tunnel-group SDLCLL-VPN831 general-attributes
address-pool SC_RA_Pool
default-group-policy SDLCLL-VPN831
tunnel-group SDLCLL-VPN831 ipsec-attributes
pre-shared-key PASSWORD
!