I have a LAN that doing DMZ, which have two area: inside and Dmz. Those are server in two area. Inside has DNS, DHCP server. DMZ has Web, FTP server. Also, i has a CISCO 2800 router to connect Firwall between Inside area.
The problem is that Inside' s server cannot connect to DMZ's server. The firewall cannot routing.
Firewall Configuration:
hostname FireWall
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Ethernet0/0
nameif inside
security-level 0
ip address 172.16.4.2 255.255.254.0
!
interface Ethernet0/1
nameif dmz
security-level 0
ip address 172.16.2.1 255.255.254.0
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 0
ip address 192.168.1.1 255.255.254.0
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
access-list Inside_access_in extended permit tcp any any
access-list Inside_access_in extended permit ip any any
access-list Inside_access_in extended permit udp any any
access-list Inside_access_in extended permit icmp any any
access-list dmz_access_in extended permit tcp any any
access-list dmz_access_in extended permit ip any any
access-list dmz_access_in extended permit udp any any
access-list dmz_access_in extended permit icmp any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu dmz 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any dmz
asdm image disk0:/asdm603.bin
asdm history enable
arp timeout 14400
access-group Inside_access_in in interface inside
access-group dmz_access_in in interface dmz
!
router ospf 10
network 172.16.2.0 255.255.254.0 area 1
network 172.16.4.0 255.255.254.0 area 0
log-adj-changes
!
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect icmp
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9f899d4cf9fae8679cd73ca8be4a0f43
: end
The problem is that Inside' s server cannot connect to DMZ's server. The firewall cannot routing.
Firewall Configuration:
hostname FireWall
enable password 8Ry2YjIyt7RRXU24 encrypted
names
!
interface Ethernet0/0
nameif inside
security-level 0
ip address 172.16.4.2 255.255.254.0
!
interface Ethernet0/1
nameif dmz
security-level 0
ip address 172.16.2.1 255.255.254.0
!
interface Ethernet0/2
shutdown
no nameif
no security-level
no ip address
!
interface Ethernet0/3
shutdown
no nameif
no security-level
no ip address
!
interface Management0/0
nameif management
security-level 0
ip address 192.168.1.1 255.255.254.0
management-only
!
passwd 2KFQnbNIdI.2KYOU encrypted
ftp mode passive
access-list Inside_access_in extended permit tcp any any
access-list Inside_access_in extended permit ip any any
access-list Inside_access_in extended permit udp any any
access-list Inside_access_in extended permit icmp any any
access-list dmz_access_in extended permit tcp any any
access-list dmz_access_in extended permit ip any any
access-list dmz_access_in extended permit udp any any
access-list dmz_access_in extended permit icmp any any
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu dmz 1500
mtu management 1500
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any dmz
asdm image disk0:/asdm603.bin
asdm history enable
arp timeout 14400
access-group Inside_access_in in interface inside
access-group dmz_access_in in interface dmz
!
router ospf 10
network 172.16.2.0 255.255.254.0 area 1
network 172.16.4.0 255.255.254.0 area 0
log-adj-changes
!
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout uauth 0:05:00 absolute
dynamic-access-policy-record DfltAccessPolicy
http server enable
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
no crypto isakmp nat-traversal
telnet timeout 5
ssh timeout 5
console timeout 0
threat-detection basic-threat
threat-detection statistics access-list
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect icmp
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:9f899d4cf9fae8679cd73ca8be4a0f43
: end