The is a SoHo - Router and Cisco Phone deployment - Cisco Virtual Office. This code was supplied on the cisco website, im trying to understand how the QoS portion works (i have a good understand of VPN configs im just trying to wrap my head around how the Qos portion works here...)
crypto ipsec client ezvpn vpnserver
connect auto
group s3curehom3 key 6 Blaaa
mode network-extension
peer Blaaa
virtual-interface 1
username homeuser password Blaaaa
xauth userid mode local
(i get the crypto statement here, but not the line virtual-interface 1)
policy-map shaper
class class-default
shape average 600000 6000
service-policy voice_and_video (looks like a nested Policy Map, dont really get what this is doing)
policy-map voice_and_video
class voice
bandwidth 128
class call-setup
priority percent 5
class internetwork-control
priority percent 5
class video
priority 384
class class-default
fair-queue
random-detect
interface Virtual-Template1 type tunnel
no ip address
tunnel mode ipsec ipv4
service-policy output shaper
(what is virtual-tempate interface? Is that tied to virtual-interface 1 under the crypto section above?)
Router# sh ip int bri
Virtual-Access1 unassigned YES unset down down
Virtual-Access2 1.1.1.1 YES TFTP up up
Virtual-Template1 unassigned YES NVRAM down down
(why is Virtual-Tempate1 down? and where did Virtual-Access1 and 2 come from)
crypto ipsec client ezvpn vpnserver
connect auto
group s3curehom3 key 6 Blaaa
mode network-extension
peer Blaaa
virtual-interface 1
username homeuser password Blaaaa
xauth userid mode local
(i get the crypto statement here, but not the line virtual-interface 1)
policy-map shaper
class class-default
shape average 600000 6000
service-policy voice_and_video (looks like a nested Policy Map, dont really get what this is doing)
policy-map voice_and_video
class voice
bandwidth 128
class call-setup
priority percent 5
class internetwork-control
priority percent 5
class video
priority 384
class class-default
fair-queue
random-detect
interface Virtual-Template1 type tunnel
no ip address
tunnel mode ipsec ipv4
service-policy output shaper
(what is virtual-tempate interface? Is that tied to virtual-interface 1 under the crypto section above?)
Router# sh ip int bri
Virtual-Access1 unassigned YES unset down down
Virtual-Access2 1.1.1.1 YES TFTP up up
Virtual-Template1 unassigned YES NVRAM down down
(why is Virtual-Tempate1 down? and where did Virtual-Access1 and 2 come from)