I am using router1 to advertise 72.237.4.0 to two diffrent routers. I have the 67.*.*.* and the 4.*.*.*.
The 67 neighbor R3 can ping 72.237.4.1 but R4 cannot.. I see R4 as having a valid route "*" but not "*>". Here is some screenshots and the configs from R1,R3,R4.
Here is the GNS3 diagram..
R1 Config
R1#show run
Building configuration...
Current configuration : 1348 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 72.237.4.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 67.216.14.171 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 4.26.24.202 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 26808
no synchronization
bgp log-neighbor-changes
network 72.237.4.0 mask 255.255.255.0
neighbor 4.26.24.201 remote-as 3356
neighbor 67.216.14.169 remote-as 7828
no auto-summary
!
ip forward-protocol nd
ip route 72.237.4.0 255.255.255.0 Null0
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
Router3
R3#show run
Building configuration...
Current configuration : 1448 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 67.216.14.169 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
ip address 4.4.4.4 255.255.255.0
duplex auto
speed auto
!
interface Ethernet3/0
no ip address
shutdown
duplex half
!
interface Ethernet3/1
no ip address
shutdown
duplex half
!
interface Ethernet3/2
no ip address
shutdown
duplex half
!
interface Ethernet3/3
no ip address
shutdown
duplex half
!
router bgp 7828
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.5 remote-as 7828
neighbor 67.216.14.171 remote-as 26808
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
Router4
R4#show run
Building configuration...
Current configuration : 919 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 4.4.4.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 4.4.5.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 7828
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 7828
neighbor 4.4.4.4 next-hop-self
no auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end
Here is another screen shot of show ip bgp and show ip route
The 67 neighbor R3 can ping 72.237.4.1 but R4 cannot.. I see R4 as having a valid route "*" but not "*>". Here is some screenshots and the configs from R1,R3,R4.
Here is the GNS3 diagram..
R1 Config
R1#show run
Building configuration...
Current configuration : 1348 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R1
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
!
interface Loopback1
ip address 72.237.4.1 255.255.255.0
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 67.216.14.171 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 4.26.24.202 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 26808
no synchronization
bgp log-neighbor-changes
network 72.237.4.0 mask 255.255.255.0
neighbor 4.26.24.201 remote-as 3356
neighbor 67.216.14.169 remote-as 7828
no auto-summary
!
ip forward-protocol nd
ip route 72.237.4.0 255.255.255.0 Null0
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
Router3
R3#show run
Building configuration...
Current configuration : 1448 bytes
!
upgrade fpd auto
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R3
!
boot-start-marker
boot-end-marker
!
logging message-counter syslog
!
no aaa new-model
ip source-route
ip cef
!
!
!
!
no ipv6 cef
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
archive
log config
hidekeys
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 67.216.14.169 255.255.255.248
duplex auto
speed auto
!
interface FastEthernet1/1
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
ip address 4.4.4.4 255.255.255.0
duplex auto
speed auto
!
interface Ethernet3/0
no ip address
shutdown
duplex half
!
interface Ethernet3/1
no ip address
shutdown
duplex half
!
interface Ethernet3/2
no ip address
shutdown
duplex half
!
interface Ethernet3/3
no ip address
shutdown
duplex half
!
router bgp 7828
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.5 remote-as 7828
neighbor 67.216.14.171 remote-as 26808
no auto-summary
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
!
logging alarm informational
!
!
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
gatekeeper
shutdown
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
end
Router4
R4#show run
Building configuration...
Current configuration : 919 bytes
!
version 12.3
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname R4
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip subnet-zero
!
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
shutdown
duplex half
!
interface FastEthernet1/0
ip address 4.4.4.5 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet1/1
ip address 4.4.5.4 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet2/0
no ip address
shutdown
duplex auto
speed auto
!
interface FastEthernet2/1
no ip address
shutdown
duplex auto
speed auto
!
router bgp 7828
no synchronization
bgp log-neighbor-changes
neighbor 4.4.4.4 remote-as 7828
neighbor 4.4.4.4 next-hop-self
no auto-summary
!
ip classless
no ip http server
!
!
!
!
!
!
!
!
!
line con 0
stopbits 1
line aux 0
stopbits 1
line vty 0 4
login
!
!
end
Here is another screen shot of show ip bgp and show ip route