oneciscokid
Technical User
I'm trying to further my understanding of BGP and have reached a snag, I'm not sure if it's my configuration or if it's my understanding of it. I have three AS's; AS1, AS2, and AS3. AS1 is connected to AS2 which is connected to AS3. There are two computers, Computer1 is attached to E0 of Router1 and Computer2 is attached to E0 of Router3. From Computer1 I can ping Computer2 and E0 on Router3, from Computer2 I can ping Computer1 and E0 on Router1. Now from Computer1 I try to ping S1 on Router2 or S1 on Router3 I get Destination Host Unreachable. I can also ping S0 on Router2 it works fine. So if I try to ping the link between AS2 to AS3 I can't, same with Computer2 but reverse I can't ping the link between AS1 to AS2. Is this because of BGP or is there something up with my configuration? Any help is appreciated.
AS1 AS2 AS3
Router1 Router2 Router3
E0 S0----------------S0 S1-------------S1 E0---------Computer2
|
|
Computer1
Router1 Interfaces
e0 - 10.1.1.1
255.255.255.0
s0 - 192.168.2.1
255.255.255.0
Router2 Interfaces
Loopback0 - 10.20.20.1
255.255.255.0
s0 - 192.168.2.2 255.255.255.0
s1 - 192.168.3.2 255.255.255.0
Router3 Interfaces
Loopback0 - 10.30.30.1 255.255.255.0
Ethernet0 - 10.3.3.1 255.255.255.0
Serial1 - 192.168.3.1 255.255.255.0
I only copied over the important stuff I believe.
Router1 Configuration
---------------------
version 12.0
...
...
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router bgp 1
network 10.1.1.0 mask 255.255.255.0
neighbor 192.168.2.2 remote-as 2
neighbor 192.168.2.2 weight 5
!
ip classless
!
...
Router2 Configuration
----------------------
version 12.0
...
...
interface Loopback0
ip address 10.20.20.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0
ip address 10.2.2.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
ip address 192.168.3.2 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
autonomous-system 2
!
router bgp 2
network 10.2.2.0 mask 255.255.255.0
network 10.20.20.0 mask 255.255.255.0
neighbor 192.168.2.1 remote-as 1
neighbor 192.168.2.1 weight 10
neighbor 192.168.3.1 remote-as 3
neighbor 192.168.3.1 weight 15
!
ip classless
...
Router3 Configuration
----------------------
version 12.0
...
...
interface Loopback0
ip address 10.30.30.1 255.255.255.0
no ip directed-broadcast
!
!
interface Ethernet0
ip address 10.3.3.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
ip address 192.168.3.1 255.255.255.0
no ip directed-broadcast
!
router bgp 3
network 10.3.3.0 mask 255.255.255.0
network 10.30.30.0 mask 255.255.255.0
neighbor 192.168.3.2 remote-as 2
neighbor 192.168.3.2 weight 15
!
ip classless
...
Router1 - show ip bgp
----------------------
BGP table version is 21, local router ID is 192.168.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 0.0.0.0 0 32768 i
*> 10.3.3.0/24 192.168.2.2 5 2 3 i
*> 10.20.20.0/24 192.168.2.2 0 5 2 i
*> 10.30.30.0/24 192.168.2.2 5 2 3 i
Router2 - show ip bgp
----------------------
BGP table version is 21, local router ID is 192.168.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 192.168.2.1 0 10 1 i
*> 10.3.3.0/24 192.168.3.1 0 15 3 i
*> 10.20.20.0/24 0.0.0.0 0 32768 i
*> 10.30.30.0/24 192.168.3.1 0 15 3 i
Router3 - show ip bgp
----------------------
BGP table version is 5, local router ID is 10.30.30.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 192.168.3.2 15 2 1 i
*> 10.3.3.0/24 0.0.0.0 0 32768 i
*> 10.20.20.0/24 192.168.3.2 0 15 2 i
*> 10.30.30.0/24 0.0.0.0 0 32768 i
AS1 AS2 AS3
Router1 Router2 Router3
E0 S0----------------S0 S1-------------S1 E0---------Computer2
|
|
Computer1
Router1 Interfaces
e0 - 10.1.1.1
255.255.255.0
s0 - 192.168.2.1
255.255.255.0
Router2 Interfaces
Loopback0 - 10.20.20.1
255.255.255.0
s0 - 192.168.2.2 255.255.255.0
s1 - 192.168.3.2 255.255.255.0
Router3 Interfaces
Loopback0 - 10.30.30.1 255.255.255.0
Ethernet0 - 10.3.3.1 255.255.255.0
Serial1 - 192.168.3.1 255.255.255.0
I only copied over the important stuff I believe.
Router1 Configuration
---------------------
version 12.0
...
...
!
interface Ethernet0
ip address 10.1.1.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 192.168.2.1 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
interface Serial1
no ip address
no ip directed-broadcast
shutdown
!
router bgp 1
network 10.1.1.0 mask 255.255.255.0
neighbor 192.168.2.2 remote-as 2
neighbor 192.168.2.2 weight 5
!
ip classless
!
...
Router2 Configuration
----------------------
version 12.0
...
...
interface Loopback0
ip address 10.20.20.1 255.255.255.0
no ip directed-broadcast
!
interface Ethernet0
ip address 10.2.2.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
ip address 192.168.2.2 255.255.255.0
no ip directed-broadcast
no ip mroute-cache
no fair-queue
!
interface Serial1
ip address 192.168.3.2 255.255.255.0
no ip directed-broadcast
clockrate 64000
!
autonomous-system 2
!
router bgp 2
network 10.2.2.0 mask 255.255.255.0
network 10.20.20.0 mask 255.255.255.0
neighbor 192.168.2.1 remote-as 1
neighbor 192.168.2.1 weight 10
neighbor 192.168.3.1 remote-as 3
neighbor 192.168.3.1 weight 15
!
ip classless
...
Router3 Configuration
----------------------
version 12.0
...
...
interface Loopback0
ip address 10.30.30.1 255.255.255.0
no ip directed-broadcast
!
!
interface Ethernet0
ip address 10.3.3.1 255.255.255.0
no ip directed-broadcast
!
interface Serial0
no ip address
no ip directed-broadcast
shutdown
!
interface Serial1
ip address 192.168.3.1 255.255.255.0
no ip directed-broadcast
!
router bgp 3
network 10.3.3.0 mask 255.255.255.0
network 10.30.30.0 mask 255.255.255.0
neighbor 192.168.3.2 remote-as 2
neighbor 192.168.3.2 weight 15
!
ip classless
...
Router1 - show ip bgp
----------------------
BGP table version is 21, local router ID is 192.168.2.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 0.0.0.0 0 32768 i
*> 10.3.3.0/24 192.168.2.2 5 2 3 i
*> 10.20.20.0/24 192.168.2.2 0 5 2 i
*> 10.30.30.0/24 192.168.2.2 5 2 3 i
Router2 - show ip bgp
----------------------
BGP table version is 21, local router ID is 192.168.2.2
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 192.168.2.1 0 10 1 i
*> 10.3.3.0/24 192.168.3.1 0 15 3 i
*> 10.20.20.0/24 0.0.0.0 0 32768 i
*> 10.30.30.0/24 192.168.3.1 0 15 3 i
Router3 - show ip bgp
----------------------
BGP table version is 5, local router ID is 10.30.30.1
Status codes: s suppressed, d damped, h history, * valid, > best, i - internal
Origin codes: i - IGP, e - EGP, ? - incomplete
Network Next Hop Metric LocPrf Weight Path
*> 10.1.1.0/24 192.168.3.2 15 2 1 i
*> 10.3.3.0/24 0.0.0.0 0 32768 i
*> 10.20.20.0/24 192.168.3.2 0 15 2 i
*> 10.30.30.0/24 0.0.0.0 0 32768 i