We have an a network comprised of about 40 ASAs connected via VPN. We have one particular ASA that periodically locks down and loses the ability to establish new connections. This happens during periods of particularly high data transfer (offsite backup) primarily. Now the weird part: once it happens connections that have already been created complete successfully, but the ability to establish new connections is lost. Additionally, neither outside IPs nor VPN peers can be resolved. I originally thought it was a DNS issue and the ASA was losing access to its DNS server; however, I have changed the DNS server several times with no apparent effect.
A copy of the config is posted below, any thoughts or suggestions are welcome.
Richard
JH13765(config)# show run
: Saved
:
ASA Version 7.2(3)
!
hostname JH13765
domain-name accountingpros1.local
enable password XXX encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 10.101.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd XXXX encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name accountingpros1.local
same-security-traffic permit intra-interface
access-list vpn_to_jhschq extended permit ip 10.101.0.0 255.255.255.0 10.20.0.0 255.255.255.0
access-list vpn_to_jhschq extended permit ip 10.101.0.0 255.255.255.0 10.131.0.0 255.255.255.0
access-list vpn_to_jhschq extended permit ip 10.101.0.0 255.255.255.0 10.105.0.0 255.255.255.0
access-list nonat extended permit ip 10.101.0.0 255.255.255.0 10.20.0.0 255.255.255.0
access-list nonat extended permit ip 10.101.0.0 255.255.255.0 10.131.0.0 255.255.255.0
access-list nonat extended permit ip 10.101.0.0 255.255.255.0 10.105.0.0 255.255.255.0
pager lines 24
logging enable
logging timestamp
logging emblem
logging trap debugging
logging history informational
logging asdm informational
logging device-id hostname
logging host inside 10.101.0.220 format emblem
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
nat (outside) 1 0.0.0.0 255.255.255.255 outside
timeout xlate 12:00:00
timeout conn 12:00:00 half-closed 12:00:00 udp 12:00:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 12:00:00 h225 12:00:00 mgcp 12:00:00 mgcp-pat 12:00:00
timeout sip 12:00:00 sip_media 12:00:00 sip-invite 0:30:00 sip-disconnect 0:10:00
timeout uauth 3:00:00 absolute uauth 3:00:00 inactivity
http server enable
http 10.101.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 10 match address vpn_to_jhschq
crypto map outside_map 10 set peer x.x.x.x
crypto map outside_map 10 set transform-set ESP-AES-MD5
crypto map outside_map 10 set reverse-route
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes
hash md5
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd dns 10.20.0.10 24.25.5.60
dhcpd domain accountingpros1.local
dhcpd auto_config outside
dhcpd option 176 ascii "TFTPSRVR=10.20.0.33,MCIPADD=10.20.0.32,MCPORT=1719"
!
dhcpd address 10.101.0.150-10.101.0.200 inside
dhcpd domain accountingpros1.local interface inside
dhcpd enable inside
!
priority-queue outside
tx-ring-limit 256
!
class-map Voice
match dscp ef
class-map inspection_default
match default-inspection-traffic
class-map Data
match flow ip destination-address
match tunnel-group x.x.x.x
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
policy-map Voicepolicy
class Voice
priority
class Data
police output 200000 37500
!
service-policy global_policy global
tunnel-group x.x.x.x type ipsec-l2l
tunnel-group x.x.x.x ipsec-attributes
pre-shared-key *
tunnel-group y.y.y.y type ipsec-l2l
tunnel-group y.y.y.y ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:793b8b79c1db29eddbfa6b3687854978
: end
JH13765(config)#
A copy of the config is posted below, any thoughts or suggestions are welcome.
Richard
JH13765(config)# show run
: Saved
:
ASA Version 7.2(3)
!
hostname JH13765
domain-name accountingpros1.local
enable password XXX encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 10.101.0.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address dhcp setroute
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
passwd XXXX encrypted
ftp mode passive
dns server-group DefaultDNS
domain-name accountingpros1.local
same-security-traffic permit intra-interface
access-list vpn_to_jhschq extended permit ip 10.101.0.0 255.255.255.0 10.20.0.0 255.255.255.0
access-list vpn_to_jhschq extended permit ip 10.101.0.0 255.255.255.0 10.131.0.0 255.255.255.0
access-list vpn_to_jhschq extended permit ip 10.101.0.0 255.255.255.0 10.105.0.0 255.255.255.0
access-list nonat extended permit ip 10.101.0.0 255.255.255.0 10.20.0.0 255.255.255.0
access-list nonat extended permit ip 10.101.0.0 255.255.255.0 10.131.0.0 255.255.255.0
access-list nonat extended permit ip 10.101.0.0 255.255.255.0 10.105.0.0 255.255.255.0
pager lines 24
logging enable
logging timestamp
logging emblem
logging trap debugging
logging history informational
logging asdm informational
logging device-id hostname
logging host inside 10.101.0.220 format emblem
mtu inside 1500
mtu outside 1500
icmp unreachable rate-limit 1 burst-size 1
asdm image disk0:/asdm-523.bin
asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list nonat
nat (inside) 1 0.0.0.0 0.0.0.0
nat (outside) 1 0.0.0.0 255.255.255.255 outside
timeout xlate 12:00:00
timeout conn 12:00:00 half-closed 12:00:00 udp 12:00:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 12:00:00 h225 12:00:00 mgcp 12:00:00 mgcp-pat 12:00:00
timeout sip 12:00:00 sip_media 12:00:00 sip-invite 0:30:00 sip-disconnect 0:10:00
timeout uauth 3:00:00 absolute uauth 3:00:00 inactivity
http server enable
http 10.101.0.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-AES-MD5 esp-aes esp-md5-hmac
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto map outside_map 10 match address vpn_to_jhschq
crypto map outside_map 10 set peer x.x.x.x
crypto map outside_map 10 set transform-set ESP-AES-MD5
crypto map outside_map 10 set reverse-route
crypto map outside_map interface outside
crypto isakmp identity address
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption aes
hash md5
group 2
lifetime 86400
crypto isakmp policy 30
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 inside
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
management-access inside
dhcpd dns 10.20.0.10 24.25.5.60
dhcpd domain accountingpros1.local
dhcpd auto_config outside
dhcpd option 176 ascii "TFTPSRVR=10.20.0.33,MCIPADD=10.20.0.32,MCPORT=1719"
!
dhcpd address 10.101.0.150-10.101.0.200 inside
dhcpd domain accountingpros1.local interface inside
dhcpd enable inside
!
priority-queue outside
tx-ring-limit 256
!
class-map Voice
match dscp ef
class-map inspection_default
match default-inspection-traffic
class-map Data
match flow ip destination-address
match tunnel-group x.x.x.x
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
policy-map Voicepolicy
class Voice
priority
class Data
police output 200000 37500
!
service-policy global_policy global
tunnel-group x.x.x.x type ipsec-l2l
tunnel-group x.x.x.x ipsec-attributes
pre-shared-key *
tunnel-group y.y.y.y type ipsec-l2l
tunnel-group y.y.y.y ipsec-attributes
pre-shared-key *
prompt hostname context
Cryptochecksum:793b8b79c1db29eddbfa6b3687854978
: end
JH13765(config)#