Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations gkittelson on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

ASA 5505 VLANs Cannot Communicate

Status
Not open for further replies.

nojohn

IS-IT--Management
Jun 16, 2011
3
US
I'm attempting to configure an ASA 5505 for the first time and am running into trouble. I've configured regular Cisco routers and switches before without issue but this ASA is kicking my butt!

I'd like to setup 5 VLANs, inside, outside, guests, seal, and cat. The goal is to have them all reach the internet, cat reach anything on inside and seal only access a samba share on inside.

I want to setup a trunk on interface ethernet0/7 to a switch that I have already configured with a trunk port, 802.1q.

From what I've read the problem is with NAT. So I've configured a static NAT rule to allow the Guest VLAN to have internet and also for the Cat VLAN but when I try to access inside from cat nothing gets through.

So I've undone the NAT for cat and guests and pasted my current config below. As of now only the inside vlan has access to the internet. All input is more than welcome, thanks!


ASA Version 8.2(1)
!
hostname MyName
enable password 654654654654 encrypted
passwd 654654654654 encrypted
names
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.1.1 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address x.x.x.x 255.255.255.248
!
interface Vlan20
nameif GUESTS
security-level 20
ip address 192.168.20.1 255.255.255.0
!
interface Vlan30
nameif CAT
security-level 100
ip address 192.168.30.1 255.255.255.0
!
interface Vlan40
nameif SEAL
security-level 40
ip address 192.168.40.1 255.255.255.0
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
switchport mode trunk
switchport trunk native vlan 1
switchport trunk allowed vlan 1,20,30,40
speed 100
duplex full
!
ftp mode passive
dns domain-lookup inside
dns server-group DefaultDNS
name-server 8.8.8.8
name-server 4.2.2.2
same-security-traffic permit intra-interface
access-list outside_access_in extended permit tcp any host x.x.x.x eq https
access-list outside_access_in extended permit tcp any host x.x.x.x eq 8443
access-list outside_access_in extended permit tcp any host x.x.x.x eq 123
access-list outside_access_in extended permit tcp any host x.x.x.x eq 321
access-list outside_access_in extended permit tcp any host x.x.x.x eq 456
access-list outside_access_in extended permit udp any host x.x.x.x eq 654
access-list outside_access_in extended permit tcp any host x.x.x.x eq 789
access-list inside_access_in extended permit tcp host 192.168.1.1 any eq ssh
pager lines 24
logging enable
logging timestamp
logging trap informational
logging asdm informational
mtu outside 1500
mtu inside 1500
no failover
icmp unreachable rate-limit 1 burst-size 1
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 1 192.168.0.0 255.255.0.0
static (inside,outside) tcp interface https 192.168.1.3 8443 netmask 255.255.255.255
static (inside,outside) tcp interface 123 192.168.1.4 123 netmask 255.255.255.255
static (inside,outside) tcp interface 654 192.168.1.4 654 netmask 255.255.255.255
static (inside,outside) tcp interface 456 192.168.1.3 456 netmask 255.255.255.255
static (inside,outside) tcp interface 789 192.168.1.2 789 netmask 255.255.255.255
access-group outside_access_in in interface outside
access-group inside_access_in in interface inside control-plane
route outside 0.0.0.0 0.0.0.0 x.x.x.x 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication ssh console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
telnet timeout 5
ssh 192.168.1.89 255.255.255.255 inside
ssh timeout 5
console timeout 0
dhcpd dns 8.8.8.8
dhcpd auto_config outside
!
dhcpd address 192.168.1.200-192.168.1.250 inside
dhcpd dns 8.8.8.8 4.2.2.2 interface inside
dhcpd enable inside
!

threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
webvpn
username meme password 654654654654 15
!
class-map inspection-default
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect rsh
inspect rtsp
inspect esmtp
inspect sqlnet
inspect skinny
inspect sunrpc
inspect xdmcp
inspect sip
inspect netbios
inspect tftp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:654654654654654654654
: end
 
log into the asdm interface....set logging to warning first and then open logging tab....set it to warning and view logging....try to send some traffic...see what it tells you...if no warnings, set logging to informational and retry....Thats my first thoughts...

CCNA, BCNE, Security+, Network +
 
You need to allow your guests, cat and seal vlans to access the internet too. see sample code below
Code:
access-group inside_access_in in interface guests
access-group inside_access_in in interface cat
access-group inside_access_in in interface seal
 
Post the output of a show version. Does this ASA have a Security Plus license?
 
It has a security plus license and is running version 8.2(1).

Viconsul those commands didn't work, I had to create a NAT rule to get them on the internet.

Something I failed to mention in my original post is that all of the inside hosts are sharing a single IP address from my ISP usting NAT overload.

Anywho, I think I'm just going to end up paying for help and then I'll post the scrubbed running config.
 
Add the command below to allow cat to access the inside.

same-security-traffic permit inter-interface



What else isn't working?
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top