For some reason I can connect to my ASA via AnyConnect, once connected I can ping the ASA's IP on my LAN 192.168.100.248 and it replies. But I can't ping or telnet to any other devices like 192.168.100.1 on the same LAN. Funny thing is, if I use the webvpn portal where I setup the SSH/Telnet plug-in, I can telnet right to 192.168.100.1.
The remote anyconnect users get an ip of 192.168.101.x, how come they can't access the 192.168.100.x subnet (besides the ASA)?
Here is my config, what am I missing, thanks!
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.100.248 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address xxx 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 4.2.2.2
name-server xxx
domain-name xxx
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group network DM_INLINE_NETWORK_1
network-object 192.168.100.0 255.255.255.0
network-object 192.168.101.0 255.255.255.0
object-group network DM_INLINE_NETWORK_2
network-object 192.168.100.0 255.255.255.0
network-object 192.168.101.0 255.255.255.0
object-group network DM_INLINE_NETWORK_3
network-object 192.168.100.0 255.255.255.0
network-object 192.168.101.0 255.255.255.0
object-group network DM_INLINE_NETWORK_4
network-object 192.168.200.0 255.255.255.0
network-object 192.168.201.0 255.255.255.0
object-group network DM_INLINE_NETWORK_5
network-object 192.168.100.0 255.255.255.0
network-object 192.168.101.0 255.255.255.0
object-group network DM_INLINE_NETWORK_6
network-object 192.168.200.0 255.255.255.0
network-object 192.168.201.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 192.168.200.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip object-group DM_INLINE_NETWORK_1 object-group DM_INLINE_NETWORK_2
access-list inside_nat0_outbound extended permit ip object-group DM_INLINE_NETWORK_3 object-group DM_INLINE_NETWORK_4
access-list outside_1_cryptomap extended permit ip 192.168.100.0 255.255.255.0 192.168.200.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip object-group DM_INLINE_NETWORK_5 object-group DM_INLINE_NETWORK_6
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in_1 extended permit icmp any any echo-reply
access-list Networks_to_tunnel standard permit 192.168.100.0 255.255.255.0
access-list Networks_to_tunnel standard permit 192.168.200.0 255.255.255.0
access-list Networks_to_tunnel standard permit 192.168.201.0 255.255.255.0
access-list Networks_to_tunnel standard permit 192.168.101.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool DHCP 192.168.101.2-192.168.101.50 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.100.0 255.255.255.0
nat (inside) 1 192.168.101.0 255.255.255.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 192.168.100.0 255.255.255.0 inside
http 192.168.0.0 255.255.255.0 inside
http 192.168.200.0 255.255.255.0 inside
http 192.168.101.0 255.255.255.0 inside
http 192.168.201.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer xxx
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 192.168.200.0 255.255.255.0 inside
telnet 192.168.101.0 255.255.255.0 inside
telnet 192.168.100.0 255.255.255.0 inside
telnet timeout 5
ssh 192.168.100.0 255.255.255.0 inside
ssh 192.168.200.0 255.255.255.0 inside
ssh 192.168.101.0 255.255.255.0 inside
ssh 192.168.201.0 255.255.255.0 inside
ssh timeout 5
console timeout 10
management-access inside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl trust-point ASDM_TrustPoint1 outside
webvpn
enable outside
svc image disk0:/anyconnect-win-2.3.0254-k9.pkg 1
svc enable
tunnel-group-list enable
group-policy Engineers internal
group-policy Engineers attributes
vpn-tunnel-protocol svc webvpn
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Networks_to_tunnel
webvpn
url-list value Links
svc ask none default webvpn
customization value DfltCustomization
hidden-shares visible
file-entry enable
file-browsing enable
url-entry enable
tunnel-group xxx type ipsec-l2l
tunnel-group xxx ipsec-attributes
pre-shared-key *
tunnel-group Engineers type remote-access
tunnel-group Engineers general-attributes
address-pool Engineers_DHCP
default-group-policy Engineers
tunnel-group Engineers webvpn-attributes
group-alias Engineer disable
group-alias xxx enable
group-url enable
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b44165a5a7409809a8b5ed55504e5aa3
: end
no asdm history enable
The remote anyconnect users get an ip of 192.168.101.x, how come they can't access the 192.168.100.x subnet (besides the ASA)?
Here is my config, what am I missing, thanks!
!
interface Vlan1
nameif inside
security-level 100
ip address 192.168.100.248 255.255.255.0
!
interface Vlan2
nameif outside
security-level 0
ip address xxx 255.255.255.252
!
interface Ethernet0/0
switchport access vlan 2
!
interface Ethernet0/1
!
interface Ethernet0/2
!
interface Ethernet0/3
!
interface Ethernet0/4
!
interface Ethernet0/5
!
interface Ethernet0/6
!
interface Ethernet0/7
!
ftp mode passive
clock timezone CEST 1
clock summer-time CEDT recurring last Sun Mar 2:00 last Sun Oct 3:00
dns domain-lookup inside
dns domain-lookup outside
dns server-group DefaultDNS
name-server 4.2.2.2
name-server xxx
domain-name xxx
same-security-traffic permit inter-interface
same-security-traffic permit intra-interface
object-group network DM_INLINE_NETWORK_1
network-object 192.168.100.0 255.255.255.0
network-object 192.168.101.0 255.255.255.0
object-group network DM_INLINE_NETWORK_2
network-object 192.168.100.0 255.255.255.0
network-object 192.168.101.0 255.255.255.0
object-group network DM_INLINE_NETWORK_3
network-object 192.168.100.0 255.255.255.0
network-object 192.168.101.0 255.255.255.0
object-group network DM_INLINE_NETWORK_4
network-object 192.168.200.0 255.255.255.0
network-object 192.168.201.0 255.255.255.0
object-group network DM_INLINE_NETWORK_5
network-object 192.168.100.0 255.255.255.0
network-object 192.168.101.0 255.255.255.0
object-group network DM_INLINE_NETWORK_6
network-object 192.168.200.0 255.255.255.0
network-object 192.168.201.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip 192.168.100.0 255.255.255.0 192.168.200.0 255.255.255.0
access-list inside_nat0_outbound extended permit ip object-group DM_INLINE_NETWORK_1 object-group DM_INLINE_NETWORK_2
access-list inside_nat0_outbound extended permit ip object-group DM_INLINE_NETWORK_3 object-group DM_INLINE_NETWORK_4
access-list outside_1_cryptomap extended permit ip 192.168.100.0 255.255.255.0 192.168.200.0 255.255.255.0
access-list outside_1_cryptomap extended permit ip object-group DM_INLINE_NETWORK_5 object-group DM_INLINE_NETWORK_6
access-list outside_access_in extended permit icmp any any
access-list outside_access_in extended permit icmp any any echo-reply
access-list outside_access_in_1 extended permit icmp any any echo-reply
access-list Networks_to_tunnel standard permit 192.168.100.0 255.255.255.0
access-list Networks_to_tunnel standard permit 192.168.200.0 255.255.255.0
access-list Networks_to_tunnel standard permit 192.168.201.0 255.255.255.0
access-list Networks_to_tunnel standard permit 192.168.101.0 255.255.255.0
pager lines 24
logging enable
logging asdm informational
mtu inside 1500
mtu outside 1500
ip local pool DHCP 192.168.101.2-192.168.101.50 mask 255.255.255.0
icmp unreachable rate-limit 1 burst-size 1
icmp permit any inside
icmp permit any outside
no asdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_nat0_outbound
nat (inside) 1 192.168.100.0 255.255.255.0
nat (inside) 1 192.168.101.0 255.255.255.0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 xxx 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02
timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00
timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00
timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute
timeout tcp-proxy-reassembly 0:01:00
dynamic-access-policy-record DfltAccessPolicy
aaa authentication enable console LOCAL
aaa authentication http console LOCAL
aaa authentication serial console LOCAL
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 192.168.100.0 255.255.255.0 inside
http 192.168.0.0 255.255.255.0 inside
http 192.168.200.0 255.255.255.0 inside
http 192.168.101.0 255.255.255.0 inside
http 192.168.201.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server enable traps snmp authentication linkup linkdown coldstart
crypto ipsec transform-set ESP-3DES-SHA esp-3des esp-sha-hmac
crypto ipsec security-association lifetime seconds 28800
crypto ipsec security-association lifetime kilobytes 4608000
crypto map outside_map 1 match address outside_1_cryptomap
crypto map outside_map 1 set pfs group1
crypto map outside_map 1 set peer xxx
crypto map outside_map 1 set transform-set ESP-3DES-SHA
crypto map outside_map interface outside
crypto isakmp enable outside
crypto isakmp policy 10
authentication pre-share
encryption 3des
hash sha
group 2
lifetime 86400
telnet 192.168.200.0 255.255.255.0 inside
telnet 192.168.101.0 255.255.255.0 inside
telnet 192.168.100.0 255.255.255.0 inside
telnet timeout 5
ssh 192.168.100.0 255.255.255.0 inside
ssh 192.168.200.0 255.255.255.0 inside
ssh 192.168.101.0 255.255.255.0 inside
ssh 192.168.201.0 255.255.255.0 inside
ssh timeout 5
console timeout 10
management-access inside
threat-detection basic-threat
threat-detection statistics access-list
no threat-detection statistics tcp-intercept
ssl trust-point ASDM_TrustPoint1 outside
webvpn
enable outside
svc image disk0:/anyconnect-win-2.3.0254-k9.pkg 1
svc enable
tunnel-group-list enable
group-policy Engineers internal
group-policy Engineers attributes
vpn-tunnel-protocol svc webvpn
split-tunnel-policy tunnelspecified
split-tunnel-network-list value Networks_to_tunnel
webvpn
url-list value Links
svc ask none default webvpn
customization value DfltCustomization
hidden-shares visible
file-entry enable
file-browsing enable
url-entry enable
tunnel-group xxx type ipsec-l2l
tunnel-group xxx ipsec-attributes
pre-shared-key *
tunnel-group Engineers type remote-access
tunnel-group Engineers general-attributes
address-pool Engineers_DHCP
default-group-policy Engineers
tunnel-group Engineers webvpn-attributes
group-alias Engineer disable
group-alias xxx enable
group-url enable
!
class-map inspection_default
match default-inspection-traffic
!
!
policy-map type inspect dns preset_dns_map
parameters
message-length maximum 512
policy-map global_policy
class inspection_default
inspect dns preset_dns_map
inspect ftp
inspect h323 h225
inspect h323 ras
inspect netbios
inspect rsh
inspect rtsp
inspect skinny
inspect esmtp
inspect sqlnet
inspect sunrpc
inspect tftp
inspect sip
inspect xdmcp
!
service-policy global_policy global
prompt hostname context
Cryptochecksum:b44165a5a7409809a8b5ed55504e5aa3
: end
no asdm history enable