I'm trying to get an aironet 1231 configure with two vlans. They are working right now but I can't get to the web interface to configure the access point. The IP address of the accesspoint should be 192.168.85.6. Vlan 99 is 10.99.3.x subnet. Vlan 2 is 192.168.99.x subnet.
When i turn off trunking, i can access the interface, but only one vlan works.
Any help?
*************************
\\switchport//
interface FastEthernet1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
no mdix auto
spanning-tree portfast
end
*************************
*************************
\\access point//
Current configuration : 2214 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname TECHTEST
!
enable secret 5 *removed*
!
ip subnet-zero
!
!
no aaa new-model
dot11 vlan-name Data vlan 2
dot11 vlan-name Voice vlan 99
!
dot11 ssid lacksphones
vlan 99
authentication open
!
dot11 ssid warehouse2
vlan 2
authentication open
!
!
!
username test password 7 *removed*
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 99 key 1 size 128bit 7 *removed* transmit-key
encryption vlan 99 mode wep mandatory
!
encryption vlan 2 key 1 size 128bit 7 *removed* transmit-key
encryption vlan 2 mode wep mandatory
!
ssid lacksphones
!
ssid warehouse2
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.2
encapsulation dot1Q 2 native
no ip route-cache
bridge-group 1
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.99
encapsulation dot1Q 99
no ip route-cache
bridge-group 99
bridge-group 99 subscriber-loop-control
bridge-group 99 block-unknown-source
no bridge-group 99 source-learning
no bridge-group 99 unicast-flooding
bridge-group 99 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
hold-queue 160 in
!
interface FastEthernet0.2
encapsulation dot1Q 2 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface FastEthernet0.99
encapsulation dot1Q 99
no ip route-cache
bridge-group 99
no bridge-group 99 source-learning
bridge-group 99 spanning-disabled
!
interface BVI1
ip address 192.168.85.6 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.85.1
ip http server
no ip http secure-server
ip http help-path !
snmp-server community test RO
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end
When i turn off trunking, i can access the interface, but only one vlan works.
Any help?
*************************
\\switchport//
interface FastEthernet1/0/20
switchport trunk encapsulation dot1q
switchport mode trunk
no ip address
no mdix auto
spanning-tree portfast
end
*************************
*************************
\\access point//
Current configuration : 2214 bytes
!
version 12.3
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname TECHTEST
!
enable secret 5 *removed*
!
ip subnet-zero
!
!
no aaa new-model
dot11 vlan-name Data vlan 2
dot11 vlan-name Voice vlan 99
!
dot11 ssid lacksphones
vlan 99
authentication open
!
dot11 ssid warehouse2
vlan 2
authentication open
!
!
!
username test password 7 *removed*
!
bridge irb
!
!
interface Dot11Radio0
no ip address
no ip route-cache
!
encryption vlan 99 key 1 size 128bit 7 *removed* transmit-key
encryption vlan 99 mode wep mandatory
!
encryption vlan 2 key 1 size 128bit 7 *removed* transmit-key
encryption vlan 2 mode wep mandatory
!
ssid lacksphones
!
ssid warehouse2
!
speed basic-1.0 basic-2.0 basic-5.5 6.0 9.0 basic-11.0 12.0 18.0 24.0 36.0 48.0 54.0
station-role root
!
interface Dot11Radio0.2
encapsulation dot1Q 2 native
no ip route-cache
bridge-group 1
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
bridge-group 1 spanning-disabled
!
interface Dot11Radio0.99
encapsulation dot1Q 99
no ip route-cache
bridge-group 99
bridge-group 99 subscriber-loop-control
bridge-group 99 block-unknown-source
no bridge-group 99 source-learning
no bridge-group 99 unicast-flooding
bridge-group 99 spanning-disabled
!
interface FastEthernet0
no ip address
no ip route-cache
duplex auto
speed auto
hold-queue 160 in
!
interface FastEthernet0.2
encapsulation dot1Q 2 native
no ip route-cache
bridge-group 1
no bridge-group 1 source-learning
bridge-group 1 spanning-disabled
!
interface FastEthernet0.99
encapsulation dot1Q 99
no ip route-cache
bridge-group 99
no bridge-group 99 source-learning
bridge-group 99 spanning-disabled
!
interface BVI1
ip address 192.168.85.6 255.255.255.0
no ip route-cache
!
ip default-gateway 192.168.85.1
ip http server
no ip http secure-server
ip http help-path !
snmp-server community test RO
!
control-plane
!
bridge 1 route ip
!
!
!
line con 0
line vty 0 4
login local
!
end