Hello everyone!
I'm having some trouble accessing Windows shares over a VPN connection using the Cisco client (v4.8). I am connecting to a PIX 501 witout trouble and I'm able to ping and ssh to machines on our LAN. I've tried mapping the shares to a drive using the IP address of the windows machine, ie. \\192.168.1.5\ShareName. I've enabled NetBIOS over TCP/IP for the adapter that makes the connection on my machine.
I also can't surf using my internet connection while connected even though I have the Allow Local Lan option selected in the client. Below is my PIX config...
I've also tried this with the Windows PPTP client as well. Same thing, can connect fine and access anything internally except for Windows shares.
Can anyone help?
Thanks!
jason
I'm having some trouble accessing Windows shares over a VPN connection using the Cisco client (v4.8). I am connecting to a PIX 501 witout trouble and I'm able to ping and ssh to machines on our LAN. I've tried mapping the shares to a drive using the IP address of the windows machine, ie. \\192.168.1.5\ShareName. I've enabled NetBIOS over TCP/IP for the adapter that makes the connection on my machine.
I also can't surf using my internet connection while connected even though I have the Allow Local Lan option selected in the client. Below is my PIX config...
Code:
PIX Version 6.3(5)
interface ethernet0 10baset
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password xxxx encrypted
passwd xxxx encrypted
hostname pix
domain-name blah.com
clock timezone EST -3
clock summer-time EDT recurring
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol pptp 1723
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
name xxx webserver
name 10.0.2.0 site1
name 10.1.223.95 site2
name 10.1.223.7 site3
access-list 101 remark Linux Webserver
access-list 101 permit tcp any host webserver eq www
access-list 101 remark Allow ssh from home.
access-list 101 permit tcp xxxx 255.255.255.0 host webserver eq ssh
access-list 101 permit tcp any host webserver eq 8080
access-list 101 permit icmp any any
access-list 101 permit tcp xxx 255.255.255.0 host webserver eq ssh
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 site1 255.255.255.0
access-list inside_outbound_nat0_acl permit ip any 192.168.2.0 255.255.255.248
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 host site2
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 host site3
access-list inside_outbound_nat0_acl permit udp any 192.168.2.0 255.255.255.248
access-list inside_outbound_nat0_acl permit tcp any 192.168.2.0 255.255.255.248
access-list inside_outbound_nat0_acl permit ip 192.168.1.0 255.255.255.0 192.168.2.0 255.255.255.0
access-list outside_cryptomap_20 permit ip 192.168.1.0 255.255.255.0 site1 255.255.255.0
access-list outside_cryptomap_40 permit ip 192.168.1.0 255.255.255.0 host site2
access-list outside_cryptomap_40 permit ip 192.168.1.0 255.255.255.0 host site3
access-list blah_splitTunnelAcl permit ip any any
pager lines 24
logging on
logging timestamp
logging console errors
logging buffered informational
logging trap notifications
logging facility 17
logging host inside 192.168.1.5
icmp permit any echo-reply inside
mtu outside 1500
mtu inside 1500
ip address outside xxx.99 255.255.255.248
ip address inside 192.168.1.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool vpnpool 192.168.1.225-192.168.1.230 mask 255.255.255.0
ip local pool remotepool 192.168.2.1-192.168.2.5 mask 255.255.255.0
pdm location 192.168.1.0 255.255.255.255 inside
pdm location 192.168.1.5 255.255.255.255 inside
pdm location webserver 255.255.255.255 outside
pdm location 0.0.0.0 255.255.255.248 outside
pdm location site1 255.255.255.0 outside
pdm location xxx 255.255.255.0 outside
pdm location site2 255.255.255.255 outside
pdm location site3 255.255.255.255 outside
pdm location 192.168.2.0 255.255.255.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list inside_outbound_nat0_acl
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) webserver 192.168.1.5 dns netmask 255.255.255.255 0 0
access-group 101 in interface outside
rip outside default version 1
route outside 0.0.0.0 0.0.0.0 xxx.98 1
timeout xlate 0:05:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout sip-disconnect 0:02:00 sip-invite 0:03:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
aaa authentication ssh console LOCAL
aaa authentication telnet console LOCAL
http server enable
http 192.168.1.0 255.255.255.0 inside
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
crypto ipsec transform-set ESP-3DES-MD5 esp-3des esp-md5-hmac
crypto dynamic-map outside_dyn_map 20 set pfs group2
crypto dynamic-map outside_dyn_map 20 set transform-set ESP-3DES-MD5
crypto dynamic-map outside_dyn_map 40 set pfs group2
crypto dynamic-map outside_dyn_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 20 ipsec-isakmp
crypto map outside_map 20 match address outside_cryptomap_20
crypto map outside_map 20 set peer xxx
crypto map outside_map 20 set transform-set ESP-3DES-MD5
crypto map outside_map 40 ipsec-isakmp
crypto map outside_map 40 match address outside_cryptomap_40
crypto map outside_map 40 set peer xxx
crypto map outside_map 40 set transform-set ESP-3DES-MD5
crypto map outside_map 65535 ipsec-isakmp dynamic outside_dyn_map
crypto map outside_map interface outside
isakmp enable outside
isakmp key ***** address xxxxx netmask 255.255.255.255 no-xauth no-config-mode
isakmp key ***** address xxxxx netmask 255.255.255.255 no-xauth no-config-mode
isakmp identity address
isakmp nat-traversal 20
isakmp policy 20 authentication pre-share
isakmp policy 20 encryption 3des
isakmp policy 20 hash md5
isakmp policy 20 group 2
isakmp policy 20 lifetime 28800
isakmp policy 40 authentication pre-share
isakmp policy 40 encryption 3des
isakmp policy 40 hash md5
isakmp policy 40 group 2
isakmp policy 40 lifetime 86400
vpngroup remote address-pool remotepool
vpngroup remote dns-server xxxx xxxx
vpngroup remote split-tunnel skyrocket_splitTunnelAcl
vpngroup remote pfs
vpngroup remote idle-time 1800
vpngroup remote password ****
telnet 0.0.0.0 0.0.0.0 inside
telnet timeout 15
ssh 0.0.0.0 0.0.0.0 inside
ssh timeout 15
console timeout 0
vpdn group remote accept dialin pptp
vpdn group remote ppp authentication mschap
vpdn group remote ppp encryption mppe 40 required
vpdn group remote client configuration address local remotepool
vpdn group remote client configuration dns xxxx xxxx
vpdn group remote pptp echo 60
vpdn group remote client authentication local
vpdn username remote password ****
vpdn enable outside
dhcpd address 192.168.1.10-192.168.1.100 inside
dhcpd dns xxxx xxxx
dhcpd lease 3600
dhcpd ping_timeout 750
dhcpd enable inside
username xxx password **** encrypted privilege 5
username xxx password **** encrypted privilege 15
terminal width 80
I've also tried this with the Windows PPTP client as well. Same thing, can connect fine and access anything internally except for Windows shares.
Can anyone help?
Thanks!
jason