emso
IS-IT--Management
- Oct 10, 2003
- 22
I have two vendors who needs access to our server through RDP. They do not wish to use VPN. We have a PIX 501 and I have set up the access-list and stuff as seen below. But this does not work. Does anybody have any ideas ???
I have posted the config in two parts:
Accesslist config:
access-list outside_access_in permit tcp host 195.xxx.xxx.xxx host 172.20.30.240 eq 3389
access-list outside_access_in permit tcp host 195.xxx.xxx.xxx host 172.20.30.240 eq 1433
access-list outside_access_in permit tcp host 80.xxx.xxx.xxx host 172.20.30.240 eq 3389
access-list outside_access_in permit tcp host 80.xxx.xxx.xxx host 172.20.30.240 eq 1433
access-list 101 permit ip 172.20.0.0 255.255.0.0 172.20.0.0 255.255.0.0
access-list 101 permit ip 172.20.30.0 255.255.255.0 172.20.30.0 255.255.255.0
static (inside,outside) tcp interface 3389 172.20.30.240 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1433 172.20.30.240 1433 netmask 255.255.255.255 0 0
Whole COnfig:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password bSaReVNStzKHNgsT encrypted
passwd bSaReVNStzKHNgsT encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit gre any any
access-list outside_access_in permit tcp host 195.xxx.xxx.xxx host 172.20.30.240 eq 3389
access-list outside_access_in permit tcp host 195.xxx.xxx.xxx host 172.20.30.240 eq 1433
access-list outside_access_in permit tcp host 80.xxx.xxx.xxx host 172.20.30.240 eq 3389
access-list outside_access_in permit tcp host 80.xxx.xxx.xxx host 172.20.30.240 eq 1433
access-list 101 permit ip 172.20.0.0 255.255.0.0 172.20.0.0 255.255.0.0
access-list 101 permit ip 172.20.30.0 255.255.255.0 172.20.30.0 255.255.255.0
pager lines 24
icmp permit any redirect inside
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.xxx 255.255.255.0
ip address inside 172.20.30.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 172.20.30.250-172.20.30.254
pdm location 172.20.0.0 255.255.0.0 inside
pdm location 172.20.30.0 255.255.255.0 inside
pdm location 172.20.30.0 255.255.255.0 outside
pdm location 172.20.0.0 255.255.0.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 172.20.30.240 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1433 172.20.30.240 1433 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 213.188.26.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 172.20.0.0 255.255.0.0 inside
http 172.20.30.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
isakmp enable outside
telnet 172.20.0.0 255.255.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
terminal width 80
So, why cant they access our server ??
I have posted the config in two parts:
Accesslist config:
access-list outside_access_in permit tcp host 195.xxx.xxx.xxx host 172.20.30.240 eq 3389
access-list outside_access_in permit tcp host 195.xxx.xxx.xxx host 172.20.30.240 eq 1433
access-list outside_access_in permit tcp host 80.xxx.xxx.xxx host 172.20.30.240 eq 3389
access-list outside_access_in permit tcp host 80.xxx.xxx.xxx host 172.20.30.240 eq 1433
access-list 101 permit ip 172.20.0.0 255.255.0.0 172.20.0.0 255.255.0.0
access-list 101 permit ip 172.20.30.0 255.255.255.0 172.20.30.0 255.255.255.0
static (inside,outside) tcp interface 3389 172.20.30.240 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1433 172.20.30.240 1433 netmask 255.255.255.255 0 0
Whole COnfig:
PIX Version 6.3(4)
interface ethernet0 auto
interface ethernet1 100full
nameif ethernet0 outside security0
nameif ethernet1 inside security100
enable password bSaReVNStzKHNgsT encrypted
passwd bSaReVNStzKHNgsT encrypted
hostname pixfirewall
domain-name ciscopix.com
fixup protocol dns maximum-length 512
fixup protocol ftp 21
fixup protocol h323 h225 1720
fixup protocol h323 ras 1718-1719
fixup protocol http 80
fixup protocol rsh 514
fixup protocol rtsp 554
fixup protocol sip 5060
fixup protocol sip udp 5060
fixup protocol skinny 2000
fixup protocol smtp 25
fixup protocol sqlnet 1521
fixup protocol tftp 69
names
access-list outside_access_in permit gre any any
access-list outside_access_in permit tcp host 195.xxx.xxx.xxx host 172.20.30.240 eq 3389
access-list outside_access_in permit tcp host 195.xxx.xxx.xxx host 172.20.30.240 eq 1433
access-list outside_access_in permit tcp host 80.xxx.xxx.xxx host 172.20.30.240 eq 3389
access-list outside_access_in permit tcp host 80.xxx.xxx.xxx host 172.20.30.240 eq 1433
access-list 101 permit ip 172.20.0.0 255.255.0.0 172.20.0.0 255.255.0.0
access-list 101 permit ip 172.20.30.0 255.255.255.0 172.20.30.0 255.255.255.0
pager lines 24
icmp permit any redirect inside
mtu outside 1500
mtu inside 1500
ip address outside xxx.xxx.xxx.xxx 255.255.255.0
ip address inside 172.20.30.1 255.255.255.0
ip audit info action alarm
ip audit attack action alarm
ip local pool pptp-pool 172.20.30.250-172.20.30.254
pdm location 172.20.0.0 255.255.0.0 inside
pdm location 172.20.30.0 255.255.255.0 inside
pdm location 172.20.30.0 255.255.255.0 outside
pdm location 172.20.0.0 255.255.0.0 outside
pdm logging informational 100
pdm history enable
arp timeout 14400
global (outside) 1 interface
nat (inside) 0 access-list 101
nat (inside) 1 0.0.0.0 0.0.0.0 0 0
static (inside,outside) tcp interface 3389 172.20.30.240 3389 netmask 255.255.255.255 0 0
static (inside,outside) tcp interface 1433 172.20.30.240 1433 netmask 255.255.255.255 0 0
access-group outside_access_in in interface outside
route outside 0.0.0.0 0.0.0.0 213.188.26.1 1
timeout xlate 3:00:00
timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 rpc 0:10:00 h225 1:00:00
timeout h323 0:05:00 mgcp 0:05:00 sip 0:30:00 sip_media 0:02:00
timeout uauth 0:05:00 absolute
aaa-server TACACS+ protocol tacacs+
aaa-server TACACS+ max-failed-attempts 3
aaa-server TACACS+ deadtime 10
aaa-server RADIUS protocol radius
aaa-server RADIUS max-failed-attempts 3
aaa-server RADIUS deadtime 10
aaa-server LOCAL protocol local
http server enable
http 172.20.0.0 255.255.0.0 inside
http 172.20.30.0 255.255.255.0 inside
no snmp-server location
no snmp-server contact
snmp-server community public
no snmp-server enable traps
floodguard enable
sysopt connection permit-ipsec
sysopt connection permit-pptp
sysopt connection permit-l2tp
isakmp enable outside
telnet 172.20.0.0 255.255.0.0 inside
telnet timeout 5
ssh 0.0.0.0 0.0.0.0 outside
ssh timeout 5
console timeout 0
terminal width 80
So, why cant they access our server ??