I've followed the following document:
in an attempt to get my (first ever) cisco router online and providing internet access - it seems to have achieved the first bit - show ip int brief gives an expected public ip address on Dialer1 interface ...
on the private side I have got it giving me a private ip address (10.10.10.x) as well as a known DNS server -
I can ping the DNS from the router (ping ip 195.74.113.58) but I cannot ping the same DNS server from my client ...
HELP!
TIA!
<configuration>
Router#show config
Using 1557 out of 262136 bytes
!
! Last configuration change at 12:19:41 UTC Tue Apr 5 2011
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
memory-size iomem 10
!
!
ip source-route
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool dhcppool
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 195.74.113.58 195.74.113.62
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO887M-K9 sn FCZ1447C1UT
!
!
!
!
!
!
!
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 10.10.10.1 255.255.255.0
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp chap hostname <username>
ppp chap password 0 <password>
ppp pap sent-username <username> password 0 <password>
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 10.10.10.0 0.0.0.255
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end
</configuration>
in an attempt to get my (first ever) cisco router online and providing internet access - it seems to have achieved the first bit - show ip int brief gives an expected public ip address on Dialer1 interface ...
on the private side I have got it giving me a private ip address (10.10.10.x) as well as a known DNS server -
I can ping the DNS from the router (ping ip 195.74.113.58) but I cannot ping the same DNS server from my client ...
HELP!
TIA!
<configuration>
Router#show config
Using 1557 out of 262136 bytes
!
! Last configuration change at 12:19:41 UTC Tue Apr 5 2011
!
version 15.0
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no logging console
!
no aaa new-model
memory-size iomem 10
!
!
ip source-route
!
!
ip dhcp excluded-address 10.10.10.1
!
ip dhcp pool dhcppool
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
dns-server 195.74.113.58 195.74.113.62
!
!
ip cef
no ipv6 cef
!
!
license udi pid CISCO887M-K9 sn FCZ1447C1UT
!
!
!
!
!
!
!
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface ATM0
no ip address
no atm ilmi-keepalive
pvc 0/38
encapsulation aal5mux ppp dialer
dialer pool-member 1
!
!
interface FastEthernet0
!
interface FastEthernet1
!
interface FastEthernet2
!
interface FastEthernet3
!
interface Vlan1
ip address 10.10.10.1 255.255.255.0
!
interface Dialer1
ip address negotiated
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
ppp chap hostname <username>
ppp chap password 0 <password>
ppp pap sent-username <username> password 0 <password>
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip nat inside source list 1 interface Dialer1 overload
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 1 permit 10.10.10.0 0.0.0.255
!
!
!
!
!
control-plane
!
!
line con 0
no modem enable
line aux 0
line vty 0 4
login
!
scheduler max-task-time 5000
end
</configuration>