militarymedic22
Technical User
Hello folks,
Have a cisco 831 router I’m trying to get up and running. I have seen a few threads here and there about configs for this unit, and I have read through and tried every bit of advice mentioned.
So far my research has pointed to a number of people trying to use this router in a broadband/cable modem type setup, which is exactly my goal too. Although it hasn’t been explicitly mentioned, I get the idea there shouldn’t be a major issue having the 831 obtain a dhcp address on eth1 and serve out (NAT) addresses to clients on fa1 through 4 connections.
I had the unit running, eth1 configured to grab a dhcp address, was able to ping and telnet/ssh access from the WAN side. Even had SDM access going.
But at no point in the last 7 hours (and counting!!) have I been able to get this unit to dish out DHCP addresses to clients connected on fa1 through 4. All 4 ports are not administratively down (they were initially) I was able to set a client computer with manual settings to get a new IOS upgrade pushed, but never dhcp. Every time the unit was reset, I was able to see the windows notification about cable unplugged and so on, but when the unit would get through the boot process the windows machine would never pickup a dhcp address. The windows client works perfectly on the rest of my domain network.
So, since I was never able to see any hint of the dhcp server actually working therefore not able to test further, I have knocked this thing back to the stone age. Fully ready to accept configs.
I thought it best to take it back to defaults so I can start fresh and work with any tips all you knowledgeable folks could give.
I do have a show run script from someone who ‘claims’ to have a perfectly working setup.
If you wish to comment on this script or post any code you think is better, I’m game for anything.
I’m not going to give up on this! I will learn!
Thanks
---------------------
Have a cisco 831 router I’m trying to get up and running. I have seen a few threads here and there about configs for this unit, and I have read through and tried every bit of advice mentioned.
So far my research has pointed to a number of people trying to use this router in a broadband/cable modem type setup, which is exactly my goal too. Although it hasn’t been explicitly mentioned, I get the idea there shouldn’t be a major issue having the 831 obtain a dhcp address on eth1 and serve out (NAT) addresses to clients on fa1 through 4 connections.
I had the unit running, eth1 configured to grab a dhcp address, was able to ping and telnet/ssh access from the WAN side. Even had SDM access going.
But at no point in the last 7 hours (and counting!!) have I been able to get this unit to dish out DHCP addresses to clients connected on fa1 through 4. All 4 ports are not administratively down (they were initially) I was able to set a client computer with manual settings to get a new IOS upgrade pushed, but never dhcp. Every time the unit was reset, I was able to see the windows notification about cable unplugged and so on, but when the unit would get through the boot process the windows machine would never pickup a dhcp address. The windows client works perfectly on the rest of my domain network.
So, since I was never able to see any hint of the dhcp server actually working therefore not able to test further, I have knocked this thing back to the stone age. Fully ready to accept configs.
I thought it best to take it back to defaults so I can start fresh and work with any tips all you knowledgeable folks could give.
I do have a show run script from someone who ‘claims’ to have a perfectly working setup.
If you wish to comment on this script or post any code you think is better, I’m game for anything.
I’m not going to give up on this! I will learn!
Thanks
---------------------
Code:
ip subnet-zero
ip name-server 4.2.2.5
ip name-server 4.2.2.6
!
ip dhcp pool DTMFP
import all
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 4.2.2.5
lease infinite
!
ip urlfilter alert
ip audit notify log
ip audit po max-events 100
!
!
!
!
!
!
interface Ethernet0
description CRWS Generated text. Please do not delete this:192.168.1.1-255.255.255.0
ip address 192.168.1.1 255.255.255.0
ip nat inside
no cdp enable
hold-queue 32 in
hold-queue 100 out
!
interface Ethernet1
description Internet
ip address dhcp client-id Ethernet1
no ip redirects
no ip unreachables
no ip proxy-arp
ip nat outside
no ip mroute-cache
duplex auto
no cdp enable
!
ip nat inside source list 1 interface Ethernet1 overload
ip classless
ip http server
no ip http secure-server
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
no cdp run
!
line con 0
no modem enable
stopbits 1
line aux 0
stopbits 1
line vty 0 4
exec-timeout 120 0
password mindyourdamnbizz
login local
length 0
!
scheduler max-task-time 5000