Tek-Tips is the largest IT community on the Internet today!

Members share and learn making Tek-Tips Forums the best source of peer-reviewed technical information on the Internet!

  • Congratulations SkipVought on being selected by the Tek-Tips community for having the most helpful posts in the forums last week. Way to Go!

3Com NBX and Cisco QoS

Status
Not open for further replies.

paarlberg

ISP
Aug 11, 2004
4
0
0
ZA
We are trying to setup QoS on Cisco routers for VoIP traffic. We are using a 3Com NBX phone system. Due to very limited bandwidth options, we need to make sure that voice traffic gets highest priority.

I have the following config on my external router.


interface FastEthernet0/0 (LAN link NBX network)
priority-group 1

interface Serial0/0 (external link)
priority-group 1

access-list 30 permit x.x.x.x (NBX IP Address)

priority-list 1 protocol ip high tcp 1040
priority-list 1 protocol ip high udp 2093
priority-list 1 protocol ip high udp 2094
priority-list 1 protocol ip high udp 2095
priority-list 1 protocol ip high udp 2096
priority-list 1 protocol ip high list 30
priority-list 1 protocol ip high tcp 1041
priority-list 1 protocol ip high tcp 1042
priority-list 1 protocol ip high tcp 1043
priority-list 1 protocol ip high tcp 1044


It appears to have helped somewhat. However, I am seeing that when the line becomes saturated and a call is placed, the rules do not appear to be working as needed.

Any help would be appreciated.

Thanks

David
 
I know someone has setup QoS on Cisco to handle the NBX traffic...
 
I have this sample config from 3Com, hope it helps.

Mansell

Basic Remote Router Configuration (Cisco xxxx – IOS ver 12.2.5d IP PLUS)

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname xxxxxxxxxx
!
enable secret xxxxxxxxxxxxxxx
!
ip subnet-zero
!
ip multicast-routing ---------------------- Loads Multicast routing on router (requires IOS IP Plus)
!
interface Ethernet0
ip address 10.10.11.201 255.255.255.0
ip helper-address 10.10.10.200 -------- Points to NBX call processor at the main site
ip pim dense-mode ----------------------- IGMP multicast assigned to interface
ip route-cache ----------------------------- Fast IP switching
ip mroute-cache -------------------------- Fast Multicast switching
ip igmp ver 2 ------------------------------ Specify’s IGMP version 2
fair-queue 300 256 0---------------------- QOS based on IPTOS priority bit 6 (NBX)
!
interface Serial0
shutdown
!
interface Serial1
no ip address
encapsulation frame-relay
fair-queue 300 256 0 ---------------------- QOS based on IPTOS priority bit 6 (NBX) (cannot assign to serial sub-
! interfaces must be at the serial interface level)
!
interface Serial1.16 point-to-point
description PVC to Main Site ------------ (Main site)
ip address 192.168.1.5 255.255.255.252
ip pim dense-mode ----------------------- IGMP multicast assigned to interface
ip route-cache ----------------------------- Fast IP switching
ip mroute-cache -------------------------- Fast Multicast switching
ip igmp ver 2 ------------------------------ Specify’s IGMP version 2
frame-relay interface-dlci 16
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
ip forward-protocol udp 2093 ----------- UDP helper to forward NBX UDP
ip forward-protocol udp 2094 ----------- UDP helper to forward NBX UDP
ip forward-protocol udp 2095----------- UDP helper to forward NBX UDP
ip forward-protocol udp 2096----------- UDP helper to forward NBX UDP
ip route 0.0.0.0 0.0.0.0 192.168.1.6
no ip http server
no ip pim bidir-enable
!
line con 0
line vty 0 4
password !nterprise
login
!




LEGEND:
Text in normal black – standard router config
Text in bold black – Config commands for NBX multicast, QOS, UDP helpers, & fast switching



Basic Main Site Router Configuration (Cisco xxxx – IOS ver 12.2.5d IP PLUS)

!
version 12.2
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname rescue-main
!
logging buffered 64000 debugging
enable secret 5 $1$Pzy3$FziOY.tv5tAHHkA1optnM.
!
ip subnet-zero
no ip source-route
!
ip multicast-routing ---------------------- Loads Multicast routing on router (requires IOS IP Plus)
ip ssh time-out 120
ip ssh authentication-retries 3
!
!
interface Ethernet0
ip address 10.10.10.201 255.255.255.0
ip pim dense-mode ----------------------- IGMP multicast assigned to interface
ip route-cache ----------------------------- Fast IP switching
ip mroute-cache -------------------------- Fast Multicast switching
ip igmp ver 2 ------------------------------ Specify’s IGMP version 2
fair-queue 300 256 0---------------------- QOS based on IPTOS priority bit 6 (NBX)
!
interface Serial0
no ip address
shutdown
!
interface Serial1
no ip address
encapsulation frame-relay
service-module t1 timeslots 1-24
fair-queue 300 256 0 ---------------------- QOS based on IPTOS priority bit 6 (NBX) (cannot assign to serial sub-
! interfaces must be at the serial interface level)
!
interface Serial1.16 point-to-point
description PVC to Remote site A ------------ (remote site)
ip address 192.168.1.6 255.255.255.252
no arp frame-relay
frame-relay interface-dlci 16
ip pim dense-mode ----------------------- IGMP multicast assigned to interface
ip route-cache ----------------------------- Fast IP switching
ip mroute-cache -------------------------- Fast Multicast switching
ip igmp ver 2 ------------------------------ Specify’s IGMP version 2
!
interface Serial1.17 point-to-point
description PVC to Remote site B ------------ (remote site)
ip address 192.168.3.6 255.255.255.252
ip pim dense-mode ----------------------- IGMP multicast assigned to interface
ip route-cache ----------------------------- Fast IP switching
ip mroute-cache -------------------------- Fast Multicast switching
ip igmp ver 2 ------------------------------ Specify’s IGMP version 2
no arp frame-relay
frame-relay interface-dlci 17
!
interface Serial1.18 point-to-point
description PVC to Remote site C------------ (remote site)
ip address 192.168.2.6 255.255.255.252
ip pim dense-mode ----------------------- IGMP multicast assigned to interface
ip route-cache ----------------------------- Fast IP switching
ip mroute-cache -------------------------- Fast Multicast switching
ip igmp ver 2 ------------------------------ Specify’s IGMP version 2
no arp frame-relay
frame-relay interface-dlci 18
!
router eigrp 1
network 10.0.0.0
network 192.168.1.0
network 192.168.2.0
network 192.168.3.0
no auto-summary
no eigrp log-neighbor-changes
!
ip classless
ip forward-protocol udp 2093 ----------- UDP helper to forward NBX UDP
ip forward-protocol udp 2094 ----------- UDP helper to forward NBX UDP
ip forward-protocol udp 2095----------- UDP helper to forward NBX UDP
ip forward-protocol udp 2096----------- UDP helper to forward NBX UDP
ip route 0.0.0.0 0.0.0.0 Serial1.20
no ip http server
no ip pim bidir-enable
!
!
line con 0
line vty 0 4
password 7 14561C1F09163A392D3B36
login
!
end


LEGEND:
Text in normal black – standard router config
Text in bold black – Config commands for NBX multicast, QOS, UDP helpers, & fast switching

 
Unable to see the bold characters..Please send in an e-mail to p_a_a_r_l_b_e_r_g@m_s_r_o_a_d_.c_o_m

remove the _ for the real address..

Thanks

David
 
Below is my new config, I am still seeing issues. These may also be related to our international connectivity. After adding the helper address it did improve somewhat though..

We have an interesting configuration. Both us (ISP) and 1 of our clients have an NBX. Also, our partner company overseas has one as well, which we have a single phone on. That would mean that we have 3 NBX connection possibilities that need to be addressed..


Current configuration : 4266 bytes
!
! Last configuration change at 14:10:46 UTC Tue Aug 31 2004
! NVRAM config last updated at 14:21:37 UTC Fri Aug 20 2004
!
version 12.2
service timestamps debug datetime msec localtime show-timezone
service timestamps log datetime msec localtime show-timezone
no service password-encryption
!
hostname paarl01
!
logging buffered 16384 debugging
enable secret 5 $1$y7ZZ$IJY5B7eD9nTCCZ1jsNJwz.
enable password
!
ip subnet-zero
ip wccp web-cache
!
!
ip domain-name
ip name-server xxx.xxx.xxx.10
ip name-server xxx.xxx.xxx.20
!
ip multicast-routing
!
!
!
!
!
!
!
fax interface-type fax-mail
mta receive maximum-recipients 0
!
!
!
!
interface FastEthernet0/0
description Local LAN (our NBX is on this network)
ip address 192.168.196.1 255.255.255.0 secondary
ip address 192.168.3.1 255.255.255.0 secondary
ip address xxx.xxx.xxx.1 255.255.255.240
ip nat inside
ip pim dense-mode
speed auto
full-duplex
ip helper-address xxx.xxx.45.2 (overseas office NBX)
traffic-shape group 150 64000 64000 64000 1000
traffic-shape group 151 64000 64000 64000 1000
traffic-shape group 152 128000 128000 128000 1000
no cdp enable
!
interface Serial0/0
description 384k
bandwidth 384
ip address xxx.xxx.xxx.222 255.255.255.252
ip access-group 100 in
ip wccp web-cache redirect out
ip nat outside
ip pim dense-mode
ip route-cache flow
no cdp enable
!
interface FastEthernet0/1
no ip address
duplex auto
speed auto
no cdp enable
!
interface Serial0/1
description cust1 (client with an NBX)
bandwidth 256
ip address xxx.xxx.xxx.33 255.255.255.252
ip pim dense-mode
fair-queue 300 256 0
no cdp enable
!
interface Serial0/2
no ip address
no cdp enable
!
interface Serial0/3
no ip address
no cdp enable
!
interface Serial1/0
description cust2
bandwidth 64
ip address xxx.xxx.xxx.41 255.255.255.252
no cdp enable
!
interface Serial1/1
description cust3
bandwidth 64
ip address xxx.xxx.xxx.45 255.255.255.252
no cdp enable
!
interface Serial1/2
no ip address
shutdown
no cdp enable
!
interface Serial1/3
no ip address
shutdown
no cdp enable
!
interface Serial1/4
no ip address
shutdown
no cdp enable
!
interface Serial1/5
no ip address
shutdown
no cdp enable
!
interface Serial1/6
physical-layer async
description cust3
ip address xxx.xxx.xxx.17 255.255.255.252
encapsulation ppp
async default routing
async mode dedicated
!
interface Serial1/7
physical-layer async
description cust4
ip address xxx.xxx.xxx.21 255.255.255.252
encapsulation ppp
async default routing
async mode dedicated
!
ip nat inside source list 1 interface Serial0/0 overload
ip classless
ip forward-protocol udp 2093
ip forward-protocol udp 2094
ip forward-protocol udp 2095
ip forward-protocol udp 2096
ip route 0.0.0.0 0.0.0.0 xxx.xxx.xxx.221
ip route xxx.xxx.xxx.24 255.255.255.252 xxx.xxx.xxx.34
ip route xxx.xxx.xxx.36 255.255.255.252 xxx.xxx.xxx.34
no ip http server
ip pim bidir-enable
!
!
logging trap debugging
logging source-interface FastEthernet0/0
logging xxx.xxx.xxx.11
access-list 1 permit 192.168.196.0 0.0.0.255
access-list 20 permit xxx.x5.241.17
access-list 20 permit xxx.x0.77.34
access-list 20 permit xxx.x0.77.33
access-list 100 deny udp any any eq 2048
access-list 100 permit ip any any
access-list 101 deny udp any host 192.168.196.2 eq 443
access-list 101 deny tcp any host 192.168.196.2 eq 443
access-list 102 permit ip any any
access-list 103 permit ip any any
access-list 150 permit ip any host xxx.xxx.xxx.7
access-list 151 permit ip any host xxx.xxx.xxx.6
access-list 151 permit ip any host 192.168.196.8
access-list 152 permit tcp any eq smtp any
no cdp run
!
snmp-server community inet-stats RO
snmp-server packetsize 2048
snmp-server contact NOC
call rsvp-sync
!
!
mgcp profile default
!
dial-peer cor custom
!
!
!
!
line con 0
autoselect arap
autoselect ppp
line 39
transport input all
autoselect ppp
stopbits 1
speed 38400
flowcontrol hardware
line 40
transport input all
autoselect ppp
stopbits 1
speed 115200
flowcontrol hardware
line aux 0
line vty 0 4
password xxxxxxxx
login
!
ntp clock-period 17180277
ntp access-group peer 20
ntp server xxx.x5.241.17
ntp server xxx.x0.77.33
ntp server xxx.x0.77.34
!
end
 
Status
Not open for further replies.

Part and Inventory Search

Sponsor

Back
Top