silverhairb
IS-IT--Management
I'm setting up a simple config for a 3640. DHCP is working on the LAN side and I'm able to access the router via SDM. On the WAN side, I'm getting a DHCP-assigned address from the downstream 877. But a PC connected to the 3640 cannot access the internet through the 877.
(I suspect ip route - similar to the earlier 877 question, but not sure which interface to apply it to.)
Any help would be appreciated.
TIA,
Bill
Follows is the running config from the 3640:
Current configuration : 2349 bytes
!
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 3640Router1
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
clock timezone PCTime -6
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
no aaa new-model
ip subnet-zero
!
!
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.10.10.1 10.10.10.99
ip dhcp excluded-address 10.10.10.155 10.10.10.254
!
ip dhcp pool CLIENT
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
lease 2 2
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
username silver privilege 15 secret 5 $1$RenU$6XSNMjVSwSISEAKhC./Ot/
!
!
controller T1 0/0
framing sf
linecode ami
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
no cdp enable
hold-queue 32 in
!
interface Ethernet1/0
ip address dhcp client-id Ethernet1/0
ip access-group 111 in
ip nat outside
half-duplex
no cdp enable
!
ip nat inside source list 102 interface Ethernet1/0 overload
ip http server
ip classless
!
!
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
access-list 111 permit icmp any any administratively-prohibited
access-list 111 permit icmp any any echo
access-list 111 permit icmp any any echo-reply
access-list 111 permit icmp any any packet-too-big
access-list 111 permit icmp any any time-exceeded
access-list 111 permit icmp any any traceroute
access-list 111 permit icmp any any unreachable
access-list 111 permit udp any eq bootps any eq bootpc
access-list 111 permit udp any eq bootps any eq bootps
access-list 111 permit udp any eq domain any
access-list 111 permit esp any any
access-list 111 permit udp any any eq isakmp
access-list 111 permit udp any any eq 10000
access-list 111 permit tcp any any eq 1723
access-list 111 permit tcp any any eq 139
access-list 111 permit udp any any eq netbios-ns
access-list 111 permit udp any any eq netbios-dgm
access-list 111 permit gre any any
access-list 111 deny ip any any
no cdp run
!
!
!
!
!
!
!
!
line con 0
exec-timeout 120 0
transport output all
stopbits 1
line aux 0
transport output all
line vty 0 4
access-class 23 in
exec-timeout 120 0
login local
length 0
transport input all
transport output all
!
scheduler max-task-time 5000
!
end
(I suspect ip route - similar to the earlier 877 question, but not sure which interface to apply it to.)
Any help would be appreciated.
TIA,
Bill
Follows is the running config from the 3640:
Current configuration : 2349 bytes
!
version 12.3
no service pad
service timestamps debug uptime
service timestamps log uptime
service password-encryption
!
hostname 3640Router1
!
boot-start-marker
boot-end-marker
!
no logging buffered
!
clock timezone PCTime -6
clock summer-time PCTime date Apr 6 2003 2:00 Oct 26 2003 2:00
no aaa new-model
ip subnet-zero
!
!
ip dhcp excluded-address 10.10.10.1
ip dhcp excluded-address 10.10.10.1 10.10.10.99
ip dhcp excluded-address 10.10.10.155 10.10.10.254
!
ip dhcp pool CLIENT
import all
network 10.10.10.0 255.255.255.0
default-router 10.10.10.1
lease 2 2
!
ip cef
!
!
!
!
!
!
!
!
!
!
!
username silver privilege 15 secret 5 $1$RenU$6XSNMjVSwSISEAKhC./Ot/
!
!
controller T1 0/0
framing sf
linecode ami
!
!
!
interface FastEthernet0/0
ip address 10.10.10.1 255.255.255.0
ip nat inside
duplex auto
speed auto
no cdp enable
hold-queue 32 in
!
interface Ethernet1/0
ip address dhcp client-id Ethernet1/0
ip access-group 111 in
ip nat outside
half-duplex
no cdp enable
!
ip nat inside source list 102 interface Ethernet1/0 overload
ip http server
ip classless
!
!
access-list 23 permit 10.10.10.0 0.0.0.255
access-list 102 permit ip 10.10.10.0 0.0.0.255 any
access-list 111 permit icmp any any administratively-prohibited
access-list 111 permit icmp any any echo
access-list 111 permit icmp any any echo-reply
access-list 111 permit icmp any any packet-too-big
access-list 111 permit icmp any any time-exceeded
access-list 111 permit icmp any any traceroute
access-list 111 permit icmp any any unreachable
access-list 111 permit udp any eq bootps any eq bootpc
access-list 111 permit udp any eq bootps any eq bootps
access-list 111 permit udp any eq domain any
access-list 111 permit esp any any
access-list 111 permit udp any any eq isakmp
access-list 111 permit udp any any eq 10000
access-list 111 permit tcp any any eq 1723
access-list 111 permit tcp any any eq 139
access-list 111 permit udp any any eq netbios-ns
access-list 111 permit udp any any eq netbios-dgm
access-list 111 permit gre any any
access-list 111 deny ip any any
no cdp run
!
!
!
!
!
!
!
!
line con 0
exec-timeout 120 0
transport output all
stopbits 1
line aux 0
transport output all
line vty 0 4
access-class 23 in
exec-timeout 120 0
login local
length 0
transport input all
transport output all
!
scheduler max-task-time 5000
!
end