Ok, so I have been banging my head against the wall and need a fresh set of eyes...
Network set up is as follows;
ISP -> 1841 Router -> Endian Mini Firewall -> 3560 layer 3 switch
Connected to the 3560 is the Firewall, 2960 Switch for server connections and a 1131AG Wifi AP.
I will post the config below, but to explain the problem... There are 4 networks (management, server, users, wifi) and they can ALL talk to one another, but the ONLY way for them to go out the firewall is if you ping the firewall first and get a connection going... So long as you leave the ping going you can access the internet, but if you stop the ping it loses its connection in approx 30 seconds.
Ok, here is the config to the 3560;
Building configuration...
Current configuration : 5909 bytes
!
! Last configuration change at 13:47:38 UTC Mon Apr 20 2009
! NVRAM config last updated at 13:26:52 UTC Mon Apr 20 2009
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
!
hostname 3560Gateway
!
enable secret 5
!
username brent privilege 15 password 7
no aaa new-model
clock timezone UTC -6
system mtu routing 1500
ip subnet-zero
ip routing
ip domain-name
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1-2,5,10,20 priority 24576
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
!
interface FastEthernet0/1
description Copier
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
description Chris Lafield Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/6
description Danny Thompson Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/8
description Jack Lafield Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/10
description Susan Samore Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/12
description Rick Moncrief Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/13
description Boardroom
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/18
description Receptionist
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/19
spanning-tree portfast
!
interface FastEthernet0/20
spanning-tree portfast
!
interface FastEthernet0/21
spanning-tree portfast
!
interface FastEthernet0/22
spanning-tree portfast
!
interface FastEthernet0/23
spanning-tree portfast
!
interface FastEthernet0/24
spanning-tree portfast
!
interface FastEthernet0/25
spanning-tree portfast
!
interface FastEthernet0/26
spanning-tree portfast
!
interface FastEthernet0/27
spanning-tree portfast
!
interface FastEthernet0/28
spanning-tree portfast
!
interface FastEthernet0/29
spanning-tree portfast
!
interface FastEthernet0/30
spanning-tree portfast
!
interface FastEthernet0/31
spanning-tree portfast
!
interface FastEthernet0/32
spanning-tree portfast
!
interface FastEthernet0/33
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/34
spanning-tree portfast
!
interface FastEthernet0/35
spanning-tree portfast
!
interface FastEthernet0/36
spanning-tree portfast
!
interface FastEthernet0/37
spanning-tree portfast
!
interface FastEthernet0/38
spanning-tree portfast
!
interface FastEthernet0/39
spanning-tree portfast
!
interface FastEthernet0/40
spanning-tree portfast
!
interface FastEthernet0/41
spanning-tree portfast
!
interface FastEthernet0/42
spanning-tree portfast
!
interface FastEthernet0/43
spanning-tree portfast
!
interface FastEthernet0/44
spanning-tree portfast
!
interface FastEthernet0/45
switchport access vlan 99
spanning-tree portfast
!
interface FastEthernet0/46
spanning-tree portfast
!
interface FastEthernet0/47
description Cisco1131AG WiFi
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface FastEthernet0/48
description Endian Firewall
switchport access vlan 5
switchport mode access
no cdp enable
spanning-tree portfast
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
description Management VLAN
ip address 192.168.0.1 255.255.255.0
!
interface Vlan5
description Server VLAN
ip address 192.168.1.1 255.255.255.0
!
interface Vlan10
description User VLAN
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.1.2
!
interface Vlan20
description Wireless VLAN
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.1.2
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.100
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
privilege level 15
login
length 0
line vty 5 15
privilege level 15
login
!
ntp clock-period 36028547
ntp server 192.168.1.2
end
3560Gateway#
------------------------------------
Dallas, Texas
Telecommunications Tech
CCVP, CCNA, Net+
CCNP in the works
Network set up is as follows;
ISP -> 1841 Router -> Endian Mini Firewall -> 3560 layer 3 switch
Connected to the 3560 is the Firewall, 2960 Switch for server connections and a 1131AG Wifi AP.
I will post the config below, but to explain the problem... There are 4 networks (management, server, users, wifi) and they can ALL talk to one another, but the ONLY way for them to go out the firewall is if you ping the firewall first and get a connection going... So long as you leave the ping going you can access the internet, but if you stop the ping it loses its connection in approx 30 seconds.
Ok, here is the config to the 3560;
Building configuration...
Current configuration : 5909 bytes
!
! Last configuration change at 13:47:38 UTC Mon Apr 20 2009
! NVRAM config last updated at 13:26:52 UTC Mon Apr 20 2009
!
version 12.2
no service pad
service timestamps debug uptime
service timestamps log datetime
service password-encryption
!
hostname 3560Gateway
!
enable secret 5
!
username brent privilege 15 password 7
no aaa new-model
clock timezone UTC -6
system mtu routing 1500
ip subnet-zero
ip routing
ip domain-name
!
!
!
!
no file verify auto
!
spanning-tree mode pvst
spanning-tree extend system-id
spanning-tree vlan 1-2,5,10,20 priority 24576
!
vlan internal allocation policy ascending
!
interface Port-channel1
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
!
interface FastEthernet0/1
description Copier
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/2
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
description Chris Lafield Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/5
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/6
description Danny Thompson Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/8
description Jack Lafield Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/10
description Susan Samore Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/12
description Rick Moncrief Office
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/13
description Boardroom
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/18
description Receptionist
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/19
spanning-tree portfast
!
interface FastEthernet0/20
spanning-tree portfast
!
interface FastEthernet0/21
spanning-tree portfast
!
interface FastEthernet0/22
spanning-tree portfast
!
interface FastEthernet0/23
spanning-tree portfast
!
interface FastEthernet0/24
spanning-tree portfast
!
interface FastEthernet0/25
spanning-tree portfast
!
interface FastEthernet0/26
spanning-tree portfast
!
interface FastEthernet0/27
spanning-tree portfast
!
interface FastEthernet0/28
spanning-tree portfast
!
interface FastEthernet0/29
spanning-tree portfast
!
interface FastEthernet0/30
spanning-tree portfast
!
interface FastEthernet0/31
spanning-tree portfast
!
interface FastEthernet0/32
spanning-tree portfast
!
interface FastEthernet0/33
switchport access vlan 10
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/34
spanning-tree portfast
!
interface FastEthernet0/35
spanning-tree portfast
!
interface FastEthernet0/36
spanning-tree portfast
!
interface FastEthernet0/37
spanning-tree portfast
!
interface FastEthernet0/38
spanning-tree portfast
!
interface FastEthernet0/39
spanning-tree portfast
!
interface FastEthernet0/40
spanning-tree portfast
!
interface FastEthernet0/41
spanning-tree portfast
!
interface FastEthernet0/42
spanning-tree portfast
!
interface FastEthernet0/43
spanning-tree portfast
!
interface FastEthernet0/44
spanning-tree portfast
!
interface FastEthernet0/45
switchport access vlan 99
spanning-tree portfast
!
interface FastEthernet0/46
spanning-tree portfast
!
interface FastEthernet0/47
description Cisco1131AG WiFi
switchport trunk encapsulation dot1q
switchport trunk native vlan 20
switchport mode trunk
!
interface FastEthernet0/48
description Endian Firewall
switchport access vlan 5
switchport mode access
no cdp enable
spanning-tree portfast
!
interface GigabitEthernet0/1
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet0/2
switchport trunk encapsulation dot1q
switchport trunk native vlan 2
switchport mode trunk
channel-group 1 mode on
!
interface GigabitEthernet0/3
!
interface GigabitEthernet0/4
!
interface Vlan1
no ip address
shutdown
!
interface Vlan2
description Management VLAN
ip address 192.168.0.1 255.255.255.0
!
interface Vlan5
description Server VLAN
ip address 192.168.1.1 255.255.255.0
!
interface Vlan10
description User VLAN
ip address 192.168.2.1 255.255.255.0
ip helper-address 192.168.1.2
!
interface Vlan20
description Wireless VLAN
ip address 192.168.3.1 255.255.255.0
ip helper-address 192.168.1.2
!
ip classless
ip route 0.0.0.0 0.0.0.0 192.168.1.100
ip http server
!
!
control-plane
!
!
line con 0
line vty 0 4
privilege level 15
login
length 0
line vty 5 15
privilege level 15
login
!
ntp clock-period 36028547
ntp server 192.168.1.2
end
3560Gateway#
------------------------------------
Dallas, Texas
Telecommunications Tech
CCVP, CCNA, Net+
CCNP in the works