Hello,
I am currently trying to set up a new branch location, i am wondering if my desgin will work and what the config should be.
so here is the design, my provider is giving me 2 lan extensions (point to point 10mb) and then giving me 4 ports on a switch they are providing ( 2 on one lan ext and 2 on the other) ( going to be redundant provider switches someday).
my plan is to have 2 2950's and two 1841's so i would go 1 connection to each lan extention into each 2950 then trunk from each 2950 to each 1841, the 1841s will have hsrp running on 2 separate sub interfaces, one sub interface for each lan extension.
my local network will then connect to f0/1 on both routers where i am also running hsrp.
my main problem right now is i cannot seem to have 2 fe's on the 2950 in two different vlan and have them connected to the same switch, it gives me the following errors:
02:31:17: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEt
hernet0/1 (10), with top FastEthernet0/2 (20).
02:32:17: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEt
hernet0/2 (20), with top FastEthernet0/1 (10).
any help would be much appreciated.
2950 config.
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname top
!
!
ip subnet-zero
!
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
vlan 10,20
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport nonegotiate
switchport protected
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
switchport nonegotiate
switchport protected
shutdown
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport trunk allowed vlan 10,20
switchport mode trunk
!
interface GigabitEthernet0/1
!
!
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan10
ip address 10.0.1.70 255.255.255.240
no ip route-cache
!
interface Vlan20
ip address 10.0.1.61 255.255.255.240
no ip route-cache
shutdown
!
ip http server
!
line con 0
line vty 5 15
!
!
end
top#
1841 config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.100.1.66 255.255.255.240
standby delay minimum 20 reload 25
standby 64 ip 10.100.1.65
standby 64 preempt
standby 64 authentication md5 key-string xxxxxxxxxxxxxxxxx
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.100.1.57 255.255.255.240
standby delay minimum 20 reload 25
standby 48 ip 10.100.1.56
standby 48 preempt
standby 48 authentication md5 key-string xxxxxxxxxxxxxxxxx
!
interface FastEthernet0/1
ip address 10.147.211.0 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end
Router#
I am currently trying to set up a new branch location, i am wondering if my desgin will work and what the config should be.
so here is the design, my provider is giving me 2 lan extensions (point to point 10mb) and then giving me 4 ports on a switch they are providing ( 2 on one lan ext and 2 on the other) ( going to be redundant provider switches someday).
my plan is to have 2 2950's and two 1841's so i would go 1 connection to each lan extention into each 2950 then trunk from each 2950 to each 1841, the 1841s will have hsrp running on 2 separate sub interfaces, one sub interface for each lan extension.
my local network will then connect to f0/1 on both routers where i am also running hsrp.
my main problem right now is i cannot seem to have 2 fe's on the 2950 in two different vlan and have them connected to the same switch, it gives me the following errors:
02:31:17: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEt
hernet0/1 (10), with top FastEthernet0/2 (20).
02:32:17: %CDP-4-NATIVE_VLAN_MISMATCH: Native VLAN mismatch discovered on FastEt
hernet0/2 (20), with top FastEthernet0/1 (10).
any help would be much appreciated.
2950 config.
version 12.1
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname top
!
!
ip subnet-zero
!
vtp mode transparent
!
spanning-tree mode pvst
no spanning-tree optimize bpdu transmission
spanning-tree extend system-id
!
!
!
!
vlan 10,20
!
interface FastEthernet0/1
switchport access vlan 10
switchport mode access
switchport nonegotiate
switchport protected
!
interface FastEthernet0/2
switchport access vlan 20
switchport mode access
switchport nonegotiate
switchport protected
shutdown
!
interface FastEthernet0/3
!
interface FastEthernet0/4
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface FastEthernet0/13
!
interface FastEthernet0/14
!
interface FastEthernet0/15
!
interface FastEthernet0/16
!
interface FastEthernet0/17
!
interface FastEthernet0/18
!
interface FastEthernet0/19
!
interface FastEthernet0/20
!
interface FastEthernet0/21
!
interface FastEthernet0/22
!
interface FastEthernet0/23
!
interface FastEthernet0/24
switchport trunk allowed vlan 10,20
switchport mode trunk
!
interface GigabitEthernet0/1
!
!
!
interface Vlan1
no ip address
no ip route-cache
shutdown
!
interface Vlan10
ip address 10.0.1.70 255.255.255.240
no ip route-cache
!
interface Vlan20
ip address 10.0.1.61 255.255.255.240
no ip route-cache
shutdown
!
ip http server
!
line con 0
line vty 5 15
!
!
end
top#
1841 config
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
ip cef
!
!
ip auth-proxy max-nodata-conns 3
ip admission max-nodata-conns 3
!
!
!
!
!
!
!
!
!
!
!
interface FastEthernet0/0
no ip address
duplex auto
speed auto
!
interface FastEthernet0/0.10
encapsulation dot1Q 10
ip address 10.100.1.66 255.255.255.240
standby delay minimum 20 reload 25
standby 64 ip 10.100.1.65
standby 64 preempt
standby 64 authentication md5 key-string xxxxxxxxxxxxxxxxx
!
interface FastEthernet0/0.20
encapsulation dot1Q 20
ip address 10.100.1.57 255.255.255.240
standby delay minimum 20 reload 25
standby 48 ip 10.100.1.56
standby 48 preempt
standby 48 authentication md5 key-string xxxxxxxxxxxxxxxxx
!
interface FastEthernet0/1
ip address 10.147.211.0 255.255.255.0
duplex auto
speed auto
!
ip forward-protocol nd
!
ip http server
no ip http secure-server
!
!
!
control-plane
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
end
Router#